Notification applet and sound applet are connected into one. [Lucid]

Bug #546985 reported by Screatch
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
indicator-applet (Ubuntu)
Won't Fix
Undecided
Unassigned

Bug Description

Prerequisite:
You need Lucid Lynx Beta 1 installed.

How to reproduce it:
No need, by default installation, notification applet is included on the top panel.

Description:
Since i installed Lucid Beta 1, i was a little bit dissapointed with inability to remove mail icon from notification applet without touching the sound applet.

Sound applet and the notification applet is connected into one applet, what is my opinion is wrong.

Maybe it's a feature, i am not sure..

Possible solution of the problem:
Separate the sound applet and the notification applet into the two different applets.

For example there is no need for me of the notification applet on the top panel

Please see screenshot for a better understanding of what do i mean.
http://img441.imageshack.us/img441/6140/mailr.png
The mail icon(highlighted on the screenshot) and the sound applet, should be separated

affects: ubuntu → indicator-applet (Ubuntu)
Revision history for this message
Ted Gould (ted) wrote : Re: [Bug 546985] [NEW] Notification applet and sound applet are connected into one. [Lucid]

This is by design. The goal is to have the applets be connected so that
you can scrub the menus and switch between them. That can't be done if
they're separated.

  status wontfix

Changed in indicator-applet (Ubuntu):
status: New → Won't Fix
Revision history for this message
LucyB (lucybridges) wrote :

I don't use email on this computer, so I don't see the point in having it. It should be removable!

Revision history for this message
Screatch (screatch) wrote :

I agree, i use gmail webinterface and for IM notification, using Pidgin tray icon. I believe these should be 2 different applets and users must have an ability to choose, what to remove and what to keep.

Maybe submit a brainstorm idea?...

Revision history for this message
Gazraeli (gazraeli) wrote :

I agree as well. The usage for web based email is very high and is only likely to increase. I do not wish to have the evolution mail with my sound applet either. Please make them separate.

Changed in indicator-applet (Ubuntu):
status: Won't Fix → Incomplete
Revision history for this message
Alexey Kotlyarov (koterpillar) wrote :

I have long ago removed the mail icon, seeing no use for it, but now my sound icon disappeared, and I have no idea where to find it.
The description for the applet is misleading as well: "Notification of events needing your attention". The applet has messaging (ok), sound and Bluetooth icons. The latter two don't "need my attention".

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to make Ubuntu better. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

Changed in indicator-applet (Ubuntu):
status: Incomplete → Won't Fix
Revision history for this message
C. Coates (ccoates) wrote :

Hey guys, I'm new to Lucid Lynx, but I think I have a solution. Go into the Synaptic Package Manager and do a search for "indicator-messages". Uninstall that package, but do NOT uninstall "indicator-applet".

You'll need to logout and then login again to see the changes. Caveat emptor, I don't know if this will break anything else related to the indicator applet, but it got rid of the little mail icon for me. I also can't remember who to credit for the fix, as I found it in a random forum post.

I do find the attitude of forcing an interface design decision onto users with no easy way to change it to their liking an annoying philosophy, as it simultaneously blames the user and limits their choices, when one of the best things about Linux is how you can tailor it to your liking. Still, I quite enjoy Ubuntu and appreciate the efforts of various individuals to develop it.

I have a similar problem with wanting to separate Gwibber from the power button, as I sometimes accidentally click the chat bubble instead of shutdown. I'm not an idiot, it's just that sometimes you're in a hurry, and they're right next to each other.

Alexey: If you remove the indicator applet entirely, it also removes the volume applet. If you just uninstall the "indicator-messages" package as described above, you should be able to add it back onto your system tray.

To get it back, simply right-click on the taskbar/panel, select "Add to panel", and scroll down until you see "indicator applet". Then click add. Tadaa.

Cheers!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers