Inconsistent Naming of "Invisible" status in indicator applet and Empathy

Bug #489097 reported by Bernd Schlapsi on 2009-11-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
One Hundred Papercuts
Low
Unassigned
empathy (Ubuntu)
Low
Ubuntu Desktop Bugs
Lucid
Low
Ubuntu Desktop Bugs
indicator-applet (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: indicator-applet

In the indicator-applet there are the following status available:
- Available
- Away
- Busy
- Invisible
- Offline

In Empathy there are the following status available:
- Available
- Away
- Busy
- Hidden
- Offline

So the status "Invisible" / "Hidden" are inconsistence between this two applications

ProblemType: Bug
Architecture: i386
Date: Fri Nov 27 09:37:14 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: indicator-applet-session 0.2.0-0ubuntu2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: indicator-applet
Uname: Linux 2.6.31-15-generic i686

Bernd Schlapsi (bernd-sch) wrote :
Vish (vish) wrote :

Assigning this bug to the empathy schedule. Either this needs to fixed in empathy or indicator applet

Changed in indicator-applet (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → lucid-round-4
status: New → Triaged
summary: - Inconsistence Naming of "Invisible" status in indicator applet and
+ Inconsistent Naming of "Invisible" status in indicator applet and
Empathy
Vish (vish) wrote :

This is actually an empathy bug , since it is not using the latest xdg spces > https://bugs.launchpad.net/icon-naming-spec/+bug/396822

Changed in empathy (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Could you give details on what it should be using and is not?

Changed in empathy (Ubuntu):
importance: Undecided → Low
Changed in indicator-applet (Ubuntu):
importance: Undecided → Low
Cédric M. Campos (cedricmc) wrote :

In my opinion, as one appears offline both when one logs out or one changes the status to Hidden/Invisible, it will be more accurate if Empathy and the indicator applet use the following naming:

- "Offline (Hidden)" instead of "Hidden", since "Hidden" is not a status by itself that your contacts can see, but "Offline".
- "Offline (Close session)" instead of "Offline", since you are taking the action of closing your session.

I think that in that way we would reflect better that our status will change to "Offline" for your contacts, while it is clear which action one has taken.

Bernd Schlapsi (bernd-sch) wrote :

@CedricMC
I disagree with you. Hidden/Invisible isn't Offline. The user is online, but couldn't / shouldn't be seen from the other users.

As mac_v (https://bugs.edge.launchpad.net/ubuntu/+source/indicator-applet/+bug/489097/comments/3) already mentioned there was a discussion on this topic.

In my opinion Hidden should be changed to Invisible in Empathy. Couldn't be that hard?!

Vish (vish) wrote :

Discussed with empathy folks and filed bug in empathy.
They probably might rename it. ;)

affects: indicator-applet → empathy
Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
Changed in empathy (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

the issue is not an indicator-applet one there

Changed in indicator-applet (Ubuntu Lucid):
status: Confirmed → Invalid
Omer Akram (om26er) wrote :

This is fixed upstream

Changed in empathy (Ubuntu Lucid):
status: Triaged → Fix Committed
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package empathy - 2.29.6-0ubuntu1

---------------
empathy (2.29.6-0ubuntu1) lucid; urgency=low

  [ Ken VanDine ]
  * debian/patches/20_libindicate.patch:
    - split out notification related stuff into separate patches
  * debian/patches/35_check_actions_notifications.patch
    - If notifications support actions, inhibit updates
  * debian/patches/32_append_notifications.patch
    - use built in empathy functions to check caps

  [ Steve Langasek ]
  * debian/control: have empathy-common Breaks: libempathy-{gtk-,}common
    and empathy-doc instead of conflicting with them, and drop the Provides:;
    the special semantics of C/R/P aren't applicable here, and in fact seem
    to confuse update-manager in some cases into refusing to upgrade empathy.

  [ Didier Roche ]
  * New upstream release
    - #603472, Rename "Hidden" to "Invisible" (G.Balaji) (LP: #489097)
    - #606329, Buttons in GtkInfoBar are too big. (Felix Kaser)
    - #573407, Empathy and telepathy-idle don't pass on server commands to
               server (LP: #509802, #397504)
    - #585168, Scrollback search and jump-to-highlight would be nice.
               (Thomas Meire) (LP: #447097)
    - #596575, Automatic salut account creation doesn't work
              (Guillaume Desmottes) (LP: #437396)
    - #599159, Stop to handle tube channels (Guillaume Desmottes)
    - #599163, Should use ContactCapability to get A/V caps
               (Guillaume Desmottes)
    - #599164, Should use ContactCapability to get FT caps (Guillaume Desmottes)
    - #600693, Empathy calls xmlCleanupParser() where it shouldn't
               (Guillaume Desmottes)
    - #600949, Deleting accounts from the treeview is weird
    - #603498, Escaped text displayed in notifications (Guillaume Desmottes)
    - #606642, IRC account: "Connect" button is not sensitive when changing the
               IRC network (Guillaume Desmottes)
    - #606753, Scrollback search is not case sensitive
    - #607207, show protocol icons in compact view (Guillaume Desmottes)
    - #607306, /join fails to work on the latest version of empathy
               (Thomas Meire) (LP: #509160)
    - #607436, Salut account should only automatically created when the wizard
               is run (Guillaume Desmottes)
    - #607455, Misc fixes regarding the accounts assistant (Guillaume Desmottes)
    - #607463, Edit Custom Messages window is too narrow (Ken VanDine)
               (LP: #502996)
    - #607868, Change Hidden to Invisible in docs
    - #607925, edit account from infobar does not open the right account
               (Guillaume Desmottes)
    - #608043, Should ellipsize text in connection error infobars
               (Will Thompson)
    - #604700, (null) status infobar with IRC account (Guillaume Desmottes)
    - #604706, infobar shows no icon if the presence is empty (Felix Kaser)
    - #605309, Show the status of accounts in the treeview (Guillaume Desmottes)
               (LP: #470096)
    - #605532, on account-creation some field should be persistent over a
               protocol change (Guillaume Desmottes)
    - #606510, Unclear string meaning (Guillaume Desmottes)
    - #585364, Get rid of...

Read more...

Changed in empathy (Ubuntu Lucid):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-01-26
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.