Broken icon and missing full name

Bug #420186 reported by Nicklas W Bjurman on 2009-08-27
94
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Indicator Applet
Fix Released
Undecided
Unassigned
indicator-applet (Ubuntu)
High
cos
Karmic
High
Unassigned

Bug Description

The icon is missing and instead there is a black square thingie(yes that is the scientific terminology)

Using Alpha4

Nicklas W Bjurman (lordmetroid) wrote :
affects: ubuntu → indicator-applet (Ubuntu)
description: updated
Matthew Gregg (mcg) wrote :

Not related to this bug, but your screenshot shows the message "bubble" in the middle of the screen not at the top right where it is normally displayed(this is happening to me atm), before i file a bug, is this intentional?

Nicklas W Bjurman (lordmetroid) wrote :

Yes, the notification bubble has been intentionally positioned at in the middle of the right edge.
It has already has had a bug report filed which became invalid(can not find it now). There apparently was complaints that the bubble covered the window control icons.

https://wiki.ubuntu.com/NotifyOSD controversy about the position has obviously unfolded and it is being discussed on the Ayatana mailing list.

Loïc Minier (lool) wrote :

I do see the broken icon in the top right corner too; I'm bumping this to high since it's quite ugly to release with

Changed in indicator-applet (Ubuntu):
importance: Undecided → High
status: New → Confirmed
summary: - Icon in shutdown menu is missing
+ Broken icon
Dominik George (natureshadow) wrote :

The full user name is also missing.

I htink the problem might be with something crucial to account data rather than the applet itself?

summary: - Broken icon
+ Broken icon and missing full name
Sebastien Bacher (seb128) wrote :

the icon issue is fixed in karmic

Dominik George (natureshadow) wrote :

The user image was replaced with the status icon again. I would very much like to have this configurable.

Still the full name is missing, which might be a feature (one I do not understand, fwiw ;)).

Nicklas W Bjurman (lordmetroid) wrote :

I suppose it is an improvement but it is still unsightly compared to Jaunty.
In Jaunty(Jaunty sus.png) the red off button was good from a usability standpoint.
While in alpha 5(Alpha 5 sus.png) it is just a grey square.

Nicklas W Bjurman (lordmetroid) wrote :
Martin Pitt (pitti) wrote :

In current Karmic, the icon looks fine and the full name is in the menu, so I close this now. Please yell if it still does not work for you. Thanks!

Changed in indicator-applet (Ubuntu Karmic):
status: Confirmed → Fix Released

I have three ubuntu desktop machines all running karmic. The weird thing is
that it seems fine at home (well at least I see some round icon there,
although I don't get my full name displayed right next to the icon). At work
however, the two other machines still have no icon and only display the
logged in user account name.
Regards,
Fahim

On Fri, Sep 11, 2009 at 9:23 AM, Martin Pitt <email address hidden> wrote:

> In current Karmic, the icon looks fine and the full name is in the menu,
> so I close this now. Please yell if it still does not work for you.
> Thanks!
>
> ** Changed in: indicator-applet (Ubuntu Karmic)
> Status: Confirmed => Fix Released
>
> --
> Broken icon and missing full name
> https://bugs.launchpad.net/bugs/420186
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Fahim Abdun-Nur (fahim-a) wrote :

Oh, any suggestions on what I can try? Or any preference file I could nuke
and have things reset back to normal?
Much appreciated!

/f

On Fri, Sep 11, 2009 at 9:23 AM, Martin Pitt <email address hidden> wrote:

> In current Karmic, the icon looks fine and the full name is in the menu,
> so I close this now. Please yell if it still does not work for you.
> Thanks!
>
> ** Changed in: indicator-applet (Ubuntu Karmic)
> Status: Confirmed => Fix Released
>
> --
> Broken icon and missing full name
> https://bugs.launchpad.net/bugs/420186
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Martin Pitt (pitti) wrote :

> Oh, any suggestions on what I can try? Or any preference file I could nuke
> and have things reset back to normal?

I subscribed Ted Gould, the upstream author, for this question. Thanks!

Matthew Gregg (mcg) wrote :

I have a status icon and my user name instead of a first name.

Martin Pitt (pitti) wrote :

Matthew Gregg [2009-09-11 15:02 -0000]:
> I have a status icon and my user name instead of a first name.

In the panel itself? That's deliberate, since real names tend to be
quite long, and thus taking too much space in the panel. (Also, you
probably know your own name anyway :-)) The real name
is the first menu item entry, as I said.

Matthew Gregg (mcg) wrote :

Oh ok, fixed for me then. I was looking for the old FUSA full name. It's confusing how in some places names are shown(gdm, screensaver unlock dialog) and in others, user names.

Ted Gould (ted) wrote :

On Fri, 2009-09-11 at 15:20 +0000, Martin Pitt wrote:
> Matthew Gregg [2009-09-11 15:02 -0000]:
> > I have a status icon and my user name instead of a first name.
>
> In the panel itself? That's deliberate, since real names tend to be
> quite long, and thus taking too much space in the panel. (Also, you
> probably know your own name anyway :-)) The real name
> is the first menu item entry, as I said.

We also don't know your first name. Through out install and everything
the only thing stored is "Full Name" so we have no way to figure out
what your first name. Also, we have no idea if your first name is
something appropriate for your computer to call you. (this could offend
some folks)

Matthew Gregg (mcg) wrote :

FUSA defaulted to showing a real name, now it's replacement doesn't. That was my confusion.

Fahim Abdun-Nur (fahim-a) wrote :

Seems to have been resolved on all three machines (not sure what, if
anything, fixed it...but all's well that ends well). The icon is there; the
full name is there in the menu;
Regards,
Fahim

On Fri, Sep 11, 2009 at 12:32 PM, Matthew Gregg <email address hidden> wrote:

> FUSA defaulted to showing a real name, now it's replacement doesn't.
> That was my confusion.
>
> --
> Broken icon and missing full name
> https://bugs.launchpad.net/bugs/420186
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Martin Pitt (pitti) on 2009-09-14
Changed in indicator-applet:
status: New → Fix Released
Phonteus Nevolius (phontanka) wrote :

I think there should be at least an option to display the full name in the top right corner instead of the username. Usernames do look clumsy when doing presentations at work.

Dominik George (natureshadow) wrote :

phontanka schrieb:
> I think there should be at least an option to display the full name in
> the top right corner instead of the username. Usernames do look clumsy
> when doing presentations at work.
>
>
Full ACK!

mlaverdiere (mlaverdiere) wrote :

I don't think that having the full name in the menu, instead that of having it in the taskbar like in previous versions, is a good solution from an esthetical point of view. User names tend to be quite cryptic ow weird on Linux... It doesn't look really professional to have a "joe" username in the upper right corner... For me, that's clearly a regression.

hammelrudi (hammelrudi) wrote :

What I really miss is the option to show no name, be it username oder full name, whatsoever, but only the status icon in the panel. That option existed in Jaunty. My username is also my first name which happens to be kind of rare and I don't really want to edit it out in every screenshot i post online. This might just be me, but I like to keep the connections between my online- and my real life persona to a minimum.

cos (gipson-lespaul) on 2009-11-10
Changed in indicator-applet (Ubuntu):
assignee: nobody → cos (gipson-lespaul)
Andres Mujica (andres.mujica) wrote :

Putting this in context.

This seems like a dupe for bug #475443 but as this is marked as fix released and that one as wishlist i'll let them apart for the time being.

However is important to note this thread

http://<email address hidden>/msg00916.html

https://wiki.ubuntu.com/MeMenu#Changes%20to%20About%20Me

so this eventually would get completely solved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers