OAFIID:GNOME_IndicatorApplet error

Bug #349237 reported by Andrew Starr-Bochicchio
130
This bug affects 24 people
Affects Status Importance Assigned to Milestone
indicator-applet (Ubuntu)
Medium
amazkiT

Bug Description

Binary package hint: indicator-applet

Every time I log into GNOME, I get the following warning:

The panel encountered a problem while loading "OAFIID:GNOME_IndicatorApplet".

Do you want to delete the applet from your configuration?

No crash report seems to be generated.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: indicator-applet 0.1.3-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-applet
Uname: Linux 2.6.28-11-generic i686

Related branches

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :
Changed in indicator-applet (Ubuntu):
importance: Undecided → Medium
Revision history for this message
CRCarl (craigkcarl) wrote :
Revision history for this message
Andreas Jonsson (sonofjon) wrote :

I'm marking this as confirmed, as I have the same problem on up-to date Ubuntu 9.04.

Changed in indicator-applet (Ubuntu):
status: New → Confirmed
Revision history for this message
Ted Gould (ted) wrote :

Could you guys please try and run it from the command line and see if any useful error are thrown?

The binary path is: /usr/lib/indicator-applet/indicator-applet

Also, you may need to execute that, and then readd it to your panel to pick up that it's running again.

Changed in indicator-applet (Ubuntu):
assignee: nobody → ted-gould
Revision history for this message
Andreas Jonsson (sonofjon) wrote :

I get the following error messages when running /usr/lib/indicator-applet/indicator-applet

andreas@brain2:~$ /usr/lib/indicator-applet/indicator-applet
/usr/share/themes/Dust/gtk-2.0/gtkrc:708: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/Dust/gtk-2.0/gtkrc:709: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
andreas@brain2:~$

I am obviously using the Dust theme. If I change to the Human theme these error messages do not occur.

However, I am not sure how related this is to the reported bug. There was no response in the panel to running /usr/lib/indicator-applet/indicator-applet. Since I updated to Ubuntu 9.04 Beta (from Intrepid) I have not seen any "indicator-applet" in my panel. Neither does one appear if I try to add one by right-clicking on the panel -> Add to Panel. Well, I do see a thin vertical bar added, but there is nothing else there, like an icon or something.

Furthermore, I can no longer reproduce the bug originally posted, regardless whether I use the Human or the Dust theme.

Sorry if this is somewhat of a confused response (I am confused at the moment). Nevertheless, I hope it helps to some extent.

Revision history for this message
Ted Gould (ted) wrote :

Okay, I'm going to mark it as incomplete for now. There have been a couple of updates recently that might have fixed it. The warnings you're seeing are coming from the GTK theme engine and should be fine. Though you should use "Human" ;) Please comment again if this comes back.

Changed in indicator-applet (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

I can no longer reproduce this as well.

Changed in indicator-applet (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Kees Cook (kees) wrote :

I seemed to be having this problem because indicator-applet suddenly got uninstalled. Not sure how, though. :P

Changed in indicator-applet (Ubuntu):
status: Invalid → New
Revision history for this message
David Barth (dbarth) wrote :

Yes, this is typically the error message you get when you have the indicator applet referenced in your panel, but not installed.

Please re-open the bug if you have information showing that de-installation was the result of a packaging error.

Thanks

Revision history for this message
Ted Gould (ted) wrote :

I'm marking this as incomplete. If someone can give some steps to reproduce the uninstall, or more information I'd be happy to change it :)

Changed in indicator-applet (Ubuntu):
status: New → Incomplete
Revision history for this message
Jorrit Kronjee (jorrit-wafel) wrote :

After upgrading to Jaunty I encountered the exact same error. Apparently the package was silently removed during the upgrade. I had to install indicator-applet again to make the problem go away.

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Re: [Dx-team] [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error

@Jorrit, did you have it installed before the upgrade?

Revision history for this message
Sebastien Bacher (seb128) wrote :

that is a good point we add the applet to the configuration if it's not installed too

Revision history for this message
Mark Shuttleworth (sabdfl) wrote :

Sebastien Bacher wrote:
> that is a good point we add the applet to the configuration if it's not
> installed too
>
Aha. That would do it :-). We should definitely install it during
upgrade, not remove it if it's installed.

Mark

Revision history for this message
Michael Vogt (mvo) wrote :

@Jorrit: if the applet got removed, please attach the logs from /var/log/dist-upgrade/ (if it was a release upgrade) so that we can diagnose if/why it was removed.

Revision history for this message
Jorrit Kronjee (jorrit-wafel) wrote :

@Michael and Mark, I'm not entirely comfortable posting everything here that I have in /var/log/dist-upgrade/, but here's - what I think is - the relevant excerpt:

# grep -E "Log|indicator" /var/log/dist-upgrade/apt.log
Log time: 2009-04-04 11:00:45.212100
Log time: 2009-04-04 11:00:46.904048
Log time: 2009-04-04 11:01:13.620748
new important dependency: evolution-indicator
Installing evolution-indicator as dep of ubuntu-desktop
Installing evolution as dep of evolution-indicator
Installing libindicate0 as dep of evolution-indicator
new important dependency: indicator-messages
Installing indicator-messages as dep of ubuntu-desktop
Installing indicator-applet as dep of indicator-messages
Log time: 2009-04-04 15:11:37.940439
Investigating indicator-applet
Package indicator-applet has broken dep on libgnome2-0
  Considering libgnome2-0 213 as a solution to indicator-applet 2
  Removing indicator-applet rather than change libgnome2-0
Investigating indicator-messages
Package indicator-messages has broken dep on indicator-applet
  Considering indicator-applet 213 as a solution to indicator-messages 2
  Removing indicator-messages rather than change indicator-applet
Investigating evolution-indicator
Package evolution-indicator has broken dep on evolution
  Considering evolution 213 as a solution to evolution-indicator -1
  Removing evolution-indicator rather than change evolution

Revision history for this message
Michael Vogt (mvo) wrote :

@Jorrit: Thanks, this is helpful, but it would be nice to get the full apt.log and main.log to figure out what packages were installed before the upgrade and the full resolver log (e.g. why libgnome2-0 was not marked for upgrade earlier). Is its ok to mail the logs to me personally?

Revision history for this message
Pietro Montagna (pietmon) wrote :

Hello boys,
sorry but my english is not very good.
I have the same problem with the sam message of CRCarl.
I from 8.10 to 9.04 RC (Amd64) and my mouse doesnt' work and only thing that I can do is to reset.
I had only simply to upgrdate from 8.10 to 9.04......

Revision history for this message
Pietro Montagna (pietmon) wrote :

@Michael and mark
these are apt.log and main.log.....Please help me!!

Revision history for this message
Pietro Montagna (pietmon) wrote :
Revision history for this message
CRCarl (craigkcarl) wrote :

Pietro -
     You can fix the issue by starting terminal and re-installing the missing application -

#sudo aptitude install indicator-applet

     Thank you for submitting the log files, they will help.

C

Revision history for this message
Pietro Montagna (pietmon) wrote : R: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error

ok This night when i Will come back to home I will do it
Thanks
------Messaggio originale------
Da: CRCarl
Mittente:<email address hidden>
A:<email address hidden>
Rispondi a:Bug 349237
Oggetto: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error
Inviato: 22 Apr 2009 03:10

Pietro -
     You can fix the issue by starting terminal and re-installing the missing application -

#sudo aptitude install indicator-applet

     Thank you for submitting the log files, they will help.

C

--
OAFIID:GNOME_IndicatorApplet error
https://bugs.launchpad.net/bugs/349237
You received this bug notification because you are a direct subscriber
of the bug.

Pietro Montagna
cell. 3807131810
Le mail ti raggiungono ovunque con BlackBerry® 9500 Storm!

Revision history for this message
Jorrit Kronjee (jorrit-wafel) wrote :

@Michael, logfiles have been sent to you.

Revision history for this message
Pietro Montagna (pietmon) wrote :

@CRCarl.....I dislike but your solution is no good.....when I start with root of recovery mode and I digit
#startx

The result is the same....The panel encountered a problem while loading "OAFIID:GNOME_IndicatorApplet".
Do you want to delete the applet from your configuration?

And then I can only press reset buton.
If I start in the normal way I have only desk without anything (icons, files, bar menu, ect....only pictures of my desk)

Can you again help me? I have not pc from 4 days!!!

Revision history for this message
CRCarl (craigkcarl) wrote : Re: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error

Pietro -
     The only symptom of this issue is the error message. If your desktop is
locked up there are more serious issues. I strongly suggest you try and get
into a console, (Ctrl-Alt-F5) get a copy of /var/log/dmesg and
/var/log/messages and start a thread at http://ubuntuforums.org.
    Put your first name somewhere in the post and I'll watch for it.

Craig

On Wed, Apr 22, 2009 at 1:02 PM, Pietro Montagna <email address hidden> wrote:

> @CRCarl.....I dislike but your solution is no good.....when I start with
> root of recovery mode and I digit
> #startx
>
> The result is the same....The panel encountered a problem while loading
> "OAFIID:GNOME_IndicatorApplet".
> Do you want to delete the applet from your configuration?
>
> And then I can only press reset buton.
> If I start in the normal way I have only desk without anything (icons,
> files, bar menu, ect....only pictures of my desk)
>
> Can you again help me? I have not pc from 4 days!!!
>
> --
> OAFIID:GNOME_IndicatorApplet error
> https://bugs.launchpad.net/bugs/349237
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “indicator-applet” source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: indicator-applet
>
> Every time I log into GNOME, I get the following warning:
>
> The panel encountered a problem while loading
> "OAFIID:GNOME_IndicatorApplet".
>
> Do you want to delete the applet from your configuration?
>
>
> No crash report seems to be generated.
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: indicator-applet 0.1.3-0ubuntu1
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: indicator-applet
> Uname: Linux 2.6.28-11-generic i686
>

Revision history for this message
Pietro Montagna (pietmon) wrote : Rif: Re: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error
  • unnamed Edit (6.2 KiB, Text/HTML; charset="utf-8")
  • unnamed Edit (18.0 KiB, image/jpeg; name="ele.jpg")
  • unnamed Edit (42.1 KiB, image/gif; name="imstp_animation_monkey_it_030908.gif")

Thanks....You suggest to start a thread or a bug report??
I ask this because on ubuntu italian forum I had not a solution, from Sunday
 about my problem.
-------Messaggio originale-------

Da: CRCarl
Data: 22/04/2009 22.30.27
A: <email address hidden>
Oggetto: Re: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error

Pietro -
     The only symptom of this issue is the error message. If your desktop is
locked up there are more serious issues. I strongly suggest you try and get
into a console, (Ctrl-Alt-F5) get a copy of /var/log/dmesg and
/var/log/messages and start a thread at http://ubuntuforums.org.
    Put your first name somewhere in the post and I'll watch for it.

Craig

On Wed, Apr 22, 2009 at 1:02 PM, Pietro Montagna <email address hidden> wrote:

> @CRCarl.....I dislike but your solution is no good.....when I start with
> root of recovery mode and I digit
> #startx
>
> The result is the same....The panel encountered a problem while loading
> "OAFIID:GNOME_IndicatorApplet".
> Do you want to delete the applet from your configuration?
>
> And then I can only press reset buton.
> If I start in the normal way I have only desk without anything (icons,
> files, bar menu, ect....only pictures of my desk)
>
> Can you again help me? I have not pc from 4 days!!!
>
> --
> OAFIID:GNOME_IndicatorApplet error
> https://bugs.launchpad.net/bugs/349237
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “indicator-applet” source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: indicator-applet
>
> Every time I log into GNOME, I get the following warning:
>
> The panel encountered a problem while loading
> "OAFIID:GNOME_IndicatorApplet".
>
> Do you want to delete the applet from your configuration?
>
>
> No crash report seems to be generated.
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: indicator-applet 0.1.3-0ubuntu1
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: indicator-applet
> Uname: Linux 2.6.28-11-generic i686
>

--
OAFIID:GNOME_IndicatorApplet error
https://bugs.launchpad.net/bugs/349237
You received this bug notification because you are a direct subscriber
of the bug.

____________________________________________________________

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.0.238 / Virus Database: 270.12.3/2076 - Release Date: 04/23/09
06:30:00

Revision history for this message
CRCarl (craigkcarl) wrote :
Download full text (4.0 KiB)

Pietro -
     From your earlier posts it sounds like when you login to Gnome your
screen is locked up, the mouse cursor does not move, etc. You also have the
OAFIID error on the screen. If this is accurate you should start a thread
re: Gnome being locked up. I strongly suggest you don't mention the OAFFID
error, that is a minor, and unrelated issue.

Craig

On Thu, Apr 23, 2009 at 7:25 AM, Pietro Montagna <email address hidden> wrote:

> Thanks....You suggest to start a thread or a bug report??
> I ask this because on ubuntu italian forum I had not a solution, from
> Sunday
> about my problem.
> -------Messaggio originale-------
>
> Da: CRCarl
> Data: 22/04/2009 22.30.27
> A: <email address hidden>
> Oggetto: Re: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error
>
> Pietro -
> The only symptom of this issue is the error message. If your desktop is
> locked up there are more serious issues. I strongly suggest you try and get
> into a console, (Ctrl-Alt-F5) get a copy of /var/log/dmesg and
> /var/log/messages and start a thread at http://ubuntuforums.org.
> Put your first name somewhere in the post and I'll watch for it.
>
> Craig
>
>
> On Wed, Apr 22, 2009 at 1:02 PM, Pietro Montagna <email address hidden> wrote:
>
> > @CRCarl.....I dislike but your solution is no good.....when I start with
> > root of recovery mode and I digit
> > #startx
> >
> > The result is the same....The panel encountered a problem while loading
> > "OAFIID:GNOME_IndicatorApplet".
> > Do you want to delete the applet from your configuration?
> >
> > And then I can only press reset buton.
> > If I start in the normal way I have only desk without anything (icons,
> > files, bar menu, ect....only pictures of my desk)
> >
> > Can you again help me? I have not pc from 4 days!!!
> >
> > --
> > OAFIID:GNOME_IndicatorApplet error
> > https://bugs.launchpad.net/bugs/349237
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in “indicator-applet” source package in Ubuntu: Incomplete
> >
> > Bug description:
> > Binary package hint: indicator-applet
> >
> > Every time I log into GNOME, I get the following warning:
> >
> > The panel encountered a problem while loading
> > "OAFIID:GNOME_IndicatorApplet".
> >
> > Do you want to delete the applet from your configuration?
> >
> >
> > No crash report seems to be generated.
> >
> > ProblemType: Bug
> > Architecture: i386
> > DistroRelease: Ubuntu 9.04
> > Package: indicator-applet 0.1.3-0ubuntu1
> > ProcEnviron:
> > LANG=en_US.UTF-8
> > SHELL=/bin/bash
> > SourcePackage: indicator-applet
> > Uname: Linux 2.6.28-11-generic i686
> >
>
> --
> OAFIID:GNOME_IndicatorApplet error
> https://bugs.launchpad.net/bugs/349237
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> ____________________________________________________________
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.0.238 / Virus Database: 270.12.3/2076 - Release Date: 04/23/09
> 06:30:00
>
>
>
> ** Attachment added: "unnamed"
> http://launchpadlibrarian.net/25890963/unnamed
>
> ** Attachment added: "unnamed"
> http://launchpadlibrarian.net/2589096...

Read more...

Revision history for this message
Pietro Montagna (pietmon) wrote : R: Re: Rif: Re: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error
Download full text (4.6 KiB)

Ok many thanks

Pietro Montagna
cell. 3807131810
Le mail ti raggiungono ovunque con BlackBerry® 9500 Storm!

-----Original Message-----
From: CRCarl <email address hidden>

Date: Fri, 24 Apr 2009 01:05:51
To: <email address hidden>
Subject: Re: Rif: Re: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error

Pietro -
     From your earlier posts it sounds like when you login to Gnome your
screen is locked up, the mouse cursor does not move, etc. You also have the
OAFIID error on the screen. If this is accurate you should start a thread
re: Gnome being locked up. I strongly suggest you don't mention the OAFFID
error, that is a minor, and unrelated issue.

Craig

On Thu, Apr 23, 2009 at 7:25 AM, Pietro Montagna <email address hidden> wrote:

> Thanks....You suggest to start a thread or a bug report??
> I ask this because on ubuntu italian forum I had not a solution, from
> Sunday
> about my problem.
> -------Messaggio originale-------
>
> Da: CRCarl
> Data: 22/04/2009 22.30.27
> A: <email address hidden>
> Oggetto: Re: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error
>
> Pietro -
> The only symptom of this issue is the error message. If your desktop is
> locked up there are more serious issues. I strongly suggest you try and get
> into a console, (Ctrl-Alt-F5) get a copy of /var/log/dmesg and
> /var/log/messages and start a thread at http://ubuntuforums.org.
> Put your first name somewhere in the post and I'll watch for it.
>
> Craig
>
>
> On Wed, Apr 22, 2009 at 1:02 PM, Pietro Montagna <email address hidden> wrote:
>
> > @CRCarl.....I dislike but your solution is no good.....when I start with
> > root of recovery mode and I digit
> > #startx
> >
> > The result is the same....The panel encountered a problem while loading
> > "OAFIID:GNOME_IndicatorApplet".
> > Do you want to delete the applet from your configuration?
> >
> > And then I can only press reset buton.
> > If I start in the normal way I have only desk without anything (icons,
> > files, bar menu, ect....only pictures of my desk)
> >
> > Can you again help me? I have not pc from 4 days!!!
> >
> > --
> > OAFIID:GNOME_IndicatorApplet error
> > https://bugs.launchpad.net/bugs/349237
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in “indicator-applet” source package in Ubuntu: Incomplete
> >
> > Bug description:
> > Binary package hint: indicator-applet
> >
> > Every time I log into GNOME, I get the following warning:
> >
> > The panel encountered a problem while loading
> > "OAFIID:GNOME_IndicatorApplet".
> >
> > Do you want to delete the applet from your configuration?
> >
> >
> > No crash report seems to be generated.
> >
> > ProblemType: Bug
> > Architecture: i386
> > DistroRelease: Ubuntu 9.04
> > Package: indicator-applet 0.1.3-0ubuntu1
> > ProcEnviron:
> > LANG=en_US.UTF-8
> > SHELL=/bin/bash
> > SourcePackage: indicator-applet
> > Uname: Linux 2.6.28-11-generic i686
> >
>
> --
> OAFIID:GNOME_IndicatorApplet error
> https://bugs.launchpad.net/bugs/349237
> You received this bug notification because you are a direct subscriber
> of...

Read more...

Revision history for this message
rayterrill (rayjohnterrill) wrote :

I also have received this error. No applets have loaded in the panel, and I have a bunch of messages such as the following:

The panel encountered a problem while loading "OAFIID:GNOME_NotificationAreaApplet".

In addition, when I try to reinstall the 'indicator-applet' program (as some have indicated might resolve the issue), I get the following error:

Original exception was:
Traceback (most recent call last):
  File "/usr/sbin/gconf-schemas", line 7, in <module>
    from optparse import OptionParser
  File "/usr/lib/python2.6/optparse.py", line 77, in <module>
    from gettext import gettext
  File "/usr/lib/python2.6/gettext.py", line 49, in <module>
    import locale, copy, os, re, struct, sys
EOFError: EOF read where object expected
dpkg: error processing indicator-applet (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 indicator-applet
E: Sub-process /usr/bin/dpkg returned an error code (1)

-Ray

Revision history for this message
Adolfo R. Brandes (arbrandes) wrote :

I'm getting this bug ("The panel encountered a problem while loading...) in an up-to-date 9.04-amd64. However, indicator-applet is properly installed, as shown by a dpkg -l:

ii indicator-appl 0.1.6-0ubuntu1 GNOME panel indicator applet

This only happens the first time I log into Gnome when the machine boots up. If I log out and back in, everything's fine.

Revision history for this message
wilbur (wilburgr) wrote :

I get this message at startup on an intermittent basis:

The panel encountered a problem while loading "OAFIID:TomboyApplet".

9.04

After I clear the message everything including Tomboy seems to work without a problem.

Reinstalling Tomboy does not help.

Revision history for this message
Ted Gould (ted) wrote : Re: [Bug 349237] Re: OAFIID:GNOME_IndicatorApplet error

I think that the indicator-applet aspects of this bug have been fixed
and discovered to be invalid for some folks. I think there are perhaps
other more generic issues for folks with the gnome-panel, which aren't
indicator applet related. I think a bug should be opened on the
gnome-panel package to discuss those. I'm marking this one as fixed.

  status fixreleased

Changed in indicator-applet (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Narcis Garcia (narcisgarcia) wrote :

I got this error when enter to the desktop:

1. installing a Xubuntu 9.04
2. updating on 2009.09.09
3. sudo apt-get install ubuntu-desktop
4. Restarting computer
5. Logging in with Gnome

And I've solved the problem with:

sudo apt-get install indicator-messages

Revision history for this message
W3ird_N3rd (w3ird-n3rd) wrote :

I just got this error on Ubuntu 9.10 Karmic. I'm not aware of having changed anything yesterday. When starting the computer today the message was there out of the blue.

When I ran /usr/lib/indicator-applet/indicator-applet nothing seemed to happen. No error messages either. indicator-applet is installed (according to synaptic), I run a fresh install (no upgrade) and use the (default) human theme.

I restarted the computer and this time indicator-applet was loaded without any problems or error messages. I didn't change anything, only a reboot.

Revision history for this message
Neill_R (neill-rutherford) wrote :

I also just got this error on Ubuntu 9.10 Karmic. I'm not aware of having changed anything When starting the computer today the message was there out of the blue.

When I ran /usr/lib/indicator-applet/indicator-applet nothing seemed to happen. No error messages either. indicator-applet is installed (according to synaptic), I run a fresh install (no upgrade) and use the (default) human theme.

Revision history for this message
Brewster Malevich (brews) wrote :

Reading the initial report, I have this problem with the 'indicator applet' and the 'indicator applet session' after having upgraded from karmic to lucid.
... But I see that a fix has been released. Should I file a new report?

Revision history for this message
Ted Gould (ted) wrote :

On Wed, 2010-03-10 at 12:50 +0000, Brews wrote:
> Reading the initial report, I have this problem with the 'indicator applet' and the 'indicator applet session' after having upgraded from karmic to lucid.
> .... But I see that a fix has been released. Should I file a new report?

Yes, please do.

Сергей (logut7)
Changed in indicator-applet (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

I still get this message. Not every boot, but quite often and it's really annoying.

Revision history for this message
Jeff (jdorenbush) wrote :

Yea I just got this when I booted up today. I chose the option to not delete it and then I open up "Add to Panel" dialog and just re-add it and it seems to work okay. It's done this a couple times though, so re-adding the app wasn't a permanent fix.

I'm on Ubuntu 10.04.

Revision history for this message
Pawel (mafeusek) wrote :

I've got the same problem on 10.04. I chose not deleting this and after logging in I have empty desktop, no icons, no panels.

workaround is:
killall gnome-panel, but it is annoying.

Jeff,
> It's done this a couple times though, so re-adding the app wasn't a permanent fix.
what YOu mean, did YOur "add to panel" trick help or not?

Revision history for this message
qwertinsky (qwertinsky) wrote :

Just got this error today after adding a new user.
 Now every boot for every user gives error.
None of the "fixes" posted here fixes it.

Sad...

Revision history for this message
curran_kelleher (curran-kelleher) wrote :

I got this error "The panel encountered a problem while loading "OAFIID:GNOME_IndicatorApplet"." as well, after a fresh install of Lucid Lynx and a package update/upgrade. It does not occur at every boot, only sporadically. The "indicator-applet" package is installed and was not removed.

I think the status "Fix Released" is misleading, as it is indeed still a bug in the most current version of Ubuntu.

Please let me know if posting some specific files would help diagnose the problem.

Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

Now lots of people with latest Ubuntu calls me because of this.

The most common thing I've noticed is, that it happens more with those that has two displays. For example, one on monitor and second on TV. So xorg configuration of separate X screens.

Does this point in any direction?

Revision history for this message
curran_kelleher (curran-kelleher) wrote :

Ah yes, I forgot to mention, I have a dual monitor setup (using ATI drivers).

Revision history for this message
Peter Davis (peterichardavis) wrote :

I recently installed openSUSE on a new notebook, having used K/ubuntu for some years. We have two users, and one starts openSUSE sessions without a problem. The other begins with The panel encountered a problem while loading "OAFIID:GNOME_IndicatorApplet". If it would help to know any more detail, let me know.

Revision history for this message
Sebastien Bacher (seb128) wrote :

the bug tracker is not an user forum, you should ask such questions on an user forum or list rather

Revision history for this message
curran_kelleher (curran-kelleher) wrote :

Since this also occurs in openSUSE it looks like this bug is upstream in
Gnome. Does anyone have any idea what may be causing this? So far we know:
 - It occurs in the latest Ubuntu sporadically (for users with dual monitor
systems)
 - It occurs in openSUSE

Since it doesn't occur all the time, I would guess it is due to some race
condition in the Gnome startup sequence. Any thoughts?

On Tue, Jun 22, 2010 at 3:41 PM, Peter Davis <email address hidden>wrote:

> I recently installed openSUSE on a new notebook, having used K/ubuntu
> for some years. We have two users, and one starts openSUSE sessions
> without a problem. The other begins with The panel encountered a
> problem while loading "OAFIID:GNOME_IndicatorApplet". If it would help
> to know any more detail, let me know.
>
> --
> OAFIID:GNOME_IndicatorApplet error
> https://bugs.launchpad.net/bugs/349237
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Greg (g6) wrote :

Me too. I'm now getting this message on every login. This must have happened as a result of an update on lucid within the last couple of days. Looking back through dpkg.log, I suspect one of these updates is to blame (perhaps libpng?):

2010-07-12 09:00:57 startup archives unpack
2010-07-12 09:01:04 upgrade libpng12-0 1.2.42-1ubuntu2 1.2.42-1ubuntu2.1
2010-07-12 09:01:04 status half-configured libpng12-0 1.2.42-1ubuntu2
2010-07-12 09:01:04 status unpacked libpng12-0 1.2.42-1ubuntu2
2010-07-12 09:01:04 status half-installed libpng12-0 1.2.42-1ubuntu2
2010-07-12 09:01:04 status triggers-pending doc-base 0.9.5
2010-07-12 09:01:04 status half-installed libpng12-0 1.2.42-1ubuntu2
2010-07-12 09:01:04 status half-installed libpng12-0 1.2.42-1ubuntu2
2010-07-12 09:01:04 status unpacked libpng12-0 1.2.42-1ubuntu2.1
2010-07-12 09:01:04 status unpacked libpng12-0 1.2.42-1ubuntu2.1
2010-07-12 09:01:04 trigproc doc-base 0.9.5 0.9.5
2010-07-12 09:01:04 status half-configured doc-base 0.9.5
2010-07-12 09:01:06 status installed doc-base 0.9.5
2010-07-12 09:01:07 startup packages configure
2010-07-12 09:01:07 configure libpng12-0 1.2.42-1ubuntu2.1 1.2.42-1ubuntu2.1
2010-07-12 09:01:07 status unpacked libpng12-0 1.2.42-1ubuntu2.1
2010-07-12 09:01:07 status half-configured libpng12-0 1.2.42-1ubuntu2.1
2010-07-12 09:01:07 status installed libpng12-0 1.2.42-1ubuntu2.1
2010-07-12 09:01:07 status triggers-pending libc-bin 2.11.1-0ubuntu7.2
2010-07-12 09:01:07 trigproc libc-bin 2.11.1-0ubuntu7.2 2.11.1-0ubuntu7.2
2010-07-12 09:01:07 status half-configured libc-bin 2.11.1-0ubuntu7.2
2010-07-12 09:01:07 status installed libc-bin 2.11.1-0ubuntu7.2

Both indicator-applet and indicator-messages are installed.

Revision history for this message
rockfx01 (tim-filmchicago) wrote :

I am also seeing this in a brand new desktop system with Ubuntu 10.04 (64-bit) installed. I have the nvidia drivers installed, but do not have dual monitors configured.

indicator-messages is installed.

UbuntuBoy (hakim-am)
Changed in indicator-applet (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → In Progress
status: In Progress → Fix Released
Revision history for this message
Florian Rathgeber (florian-rathgeber) wrote :

I just got the exact same error after booting a clean install of natty. When I run the binary on the command line, no output is created at all and nothing happens either. However, time until it exits and the shell prompt comes back varies between 1s and 2min.

On another note, my network connection indicators have suddenly disappeared from the indicator applet and I didn't manage to get them back.

Revision history for this message
Kevin Cole (kjcole) wrote :

In my case, it was some momentary glitch, perhaps. I've been running Maverick since it came out, and this morning was the first time seeing the error. Yesterday, I was altering the Startup Applications preferences, and deleted an application from the list that was being started twice -- once from explicitly adding it to the list and once from "Save all running applications". I reinstalled all the related packages, and rebooted. No problem on the second reboot. Haven't tried again...

Revision history for this message
Florian Rathgeber (florian-rathgeber) wrote :

For me the error didn't reappear either, no idea what initially caused it. Network connections didn't come back though.

Revision history for this message
Ubuntu_tc7 (th9) wrote :

Today is the first time I got the OAFIID error. I am using Ubuntu 11.04 - the Natty Narwhal and Gnome Version: 2.32.0

I have a colour laser printer that I have been using for a long time without errors. The printer's software installed an applet in the notification area next to the network. This morning when I got the error both were gone. What I have noticed is that normally I turn off the printer before logging out and shutting down my pc. Yesterday I didn't and booted into win7.

This morning I booted into Ubuntu. At the same time of the OAFIID error the printer's software popped up a trouble shooting window saying the printer was either not turned on or missing. I acknowledged the error and rebooted. I have not gotten the error since. I have rebooted several times just to check and still everything is ok.

Revision history for this message
Esben Madsen (zd) wrote :

hmmm... I just experienced something similar to Ubuntu_tc7... (also got this for the first time)

Like some other posters I also have a dual-head setup (with 2 x-servers)

I did:
1) boot in ubuntu (Ubuntu 10.04.1 LTS, Linux 2.6.32-27-generic #49-Ubuntu SMP Thu Dec 2 00:51:09 UTC 2010 x86_64), working as normal
2) reboot to windows (Win7, 64 bit) to test a few things, updated firefox and thunderbird on startup of those, updated tortoiseSvn to 1.6.12, which asked for a reboot - I agreed to reboot and booted Ubuntu from there
3) After logging in I got the error and no panel
4) I rebooted and got no error

Just to test if it was the win-ubuntu reboot, I tried the same cycle again (reboot to windows and then reboot to ubuntu) and recieved no error, so it requires more than that simple reboot-cycle to trigger it...

from dpkg -l indicator-applet:
ii indicator-appl 0.3.7-0ubuntu1 GNOME panel indicator applet

please let me know if any further info could be useful (or if we really should open a different bug rather than staying in this one?)

amazkiT (amazkid)
Changed in indicator-applet (Ubuntu):
assignee: Ted Gould (ted) → amazkiT (amazkid)
Revision history for this message
Klaus Alexander Seistrup (kseistrup) wrote :

This happens when the indicator-applet cannot write to the files ~/.cache/indicator-applet.log and ~/.cache/indicator-applet-session.log.

To reproduce:
  $ rm -f ~/.cache/indicator-applet.log && sudo chattr =i $_
  $ fm -t ~/.cache/indicator-applet-session.log && chattr =i $_

Then re-login.

Cheers.

Revision history for this message
Nick B (iviei2cury) wrote :

I got the same error message:
The panel encountered a problem while loading "OAFIID:GNOME_IndicatorApplet".

I am running 10.04.2 Ubuntu in amd64 on a Compaq nc6320. I just installed virtualbox so I suspect that might have something to do with it.

Revision history for this message
sanjitok (sanjitok) wrote :

Running on Ubuntu 10.04, got lots of these errors at startup.
The last thing I remembered before these errors appeared, I updated python to 2.7 with zlib enabled, don't know if it has something to do with it though :/
Updating indicator-applet doesn't work, and restarting gnome doesn't work too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers