do not display tray handle, but add back standard right-click menu

Bug #339818 reported by Martin Pitt on 2009-03-09
38
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Indicator Applet
Fix Released
Undecided
Unassigned
indicator-applet (Ubuntu)
Medium
Ted Gould
Jaunty
Medium
Ted Gould

Bug Description

Binary package hint: indicator-applet

By default, the indicator-applet just looks like an extra panel tray handle, without any menus or explanation. This wastes panel space and just looks confusing, since it's not at all clear what it is.

I believe this was done so that the user can place the applet sensibly. However, we'll add the applet automatically on upgrades and new installs, so few people will actually have to add it manually.

I think a much better solution is to not hide the envelope icon when you just added the applet to your panel. Then the user can drag it around to her likings.

This applet shouldn't ever have such a handle.

Doesn't it need the handle at the moment because it would be impossible to remove the applet without the handle? (Right clicking on the applet performs the same action as left-clicking)

Martin Pitt (pitti) wrote :

Right, that's the second bug. It doesn't have the standard right-click menu for moving/removing the applet, but it really must.

I know that the DX guys don't like the right-click menu. But we have to accept that every other applet in Jaunty has it, and no other applet has such a silly handle. If we want to get rid of the right-click menu, it needs to happen consistently with all other applets, we can't sell users this confusing and inconsistent behaviour as an improvement in Jaunty.

Changed in indicator-applet:
importance: Undecided → Low
status: New → Confirmed
Martin Pitt (pitti) wrote :

This affects usability quite a lot.

Changed in indicator-applet:
importance: Low → Medium
Michael Rooney (mrooney) wrote :

Ah, I am glad I found this report. All I saw was an extra handle in my panel next to the normal one and thought "that's odd, what is this thing?" and removed it since it seemed superfluous; I figured it was a gnome-panel bug of some kind. I'll add the applet again now that I know what it is and watch for changes! It sounds potentially interesting.

After a few conversations (fights, brawls, etc.) I think that the best
solution here is to remove the handle and allow right click to go
through for controlling the applet.

While this creates a incompatibility with how menus typically users with
regards to right clicks, it is more visually appealing and is most
similar with how most applets work.

  status inprogress
  assign me

Ted Gould (ted) on 2009-03-10
Changed in indicator-applet:
assignee: nobody → ted-gould
Ted Gould (ted) on 2009-03-12
Changed in indicator-applet:
milestone: none → 0.1.2
status: New → Fix Committed
Ted Gould (ted) on 2009-03-16
Changed in indicator-applet:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-applet - 0.1.2-0ubuntu1

---------------
indicator-applet (0.1.2-0ubuntu1) jaunty; urgency=low

  * New upstream version
    * Removes duplicate prototypes (LP: #338885)
    * Fixes background color to match them on dark themes when
      the panel color is not set (LP: #334490)
    * Removing the handle and replacing it with the ability to
      right click on the applet to get a panel menu (LP: #339818)
    * Various build fixes

 -- Ted Gould <email address hidden> Sun, 15 Mar 2009 08:58:20 -0500

Changed in indicator-applet:
status: Confirmed → Fix Released
Max Bowsher (maxb) wrote :

Reopening, appears not fixed to me. On all of my Jaunty machines, the indicator applet appears as the text "No Indicators" in a box, greyed out, and it does not respond to mouse clicks (neither left or right) in any way.

This leaves me with no way to remove it from my panel!

Version 0.1.3-0ubuntu1

Changed in indicator-applet:
status: Fix Released → New
j.adredz (j-adredz) wrote :

This bug is also bugging me since I installed alpha 6. I didn't recognize it at first, so I removed it. Now if I try to add it back, nothing shows up.

sgs (sebastian-sontberg) wrote :

@Max Bowsher

I'm able to access the panel menu by clicking on the applet while putting the mouse-pointer in the topmost possible position, but this can't be the desired behaviour.

Max Bowsher (maxb) wrote :

@sgs

Aha, thanks! Confirmed.

Ted Gould (ted) wrote :

On Fri, 2009-03-20 at 01:11 +0000, Max Bowsher wrote:
> Reopening, appears not fixed to me. On all of my Jaunty machines, the
> indicator applet appears as the text "No Indicators" in a box, greyed
> out, and it does not respond to mouse clicks (neither left or right) in
> any way.
>
> This leaves me with no way to remove it from my panel!

This is a different bug. What the indicator applet is saying is that
you don't have any indicators installed. I'm not sure why this would be
happening, but to fix it you can just install "indicator-messages" and
you'll get the messaging indicator in there instead of "No Indicators".

Could you please open a bug against the indicator applet in Ubuntu so
that we can track this separately? Please include any upgrade
information or if you have any odd package repositories. Thank you.
Here's the link:

http://launchpad.net/ubuntu/+source/indicator-applet/+filebug

  status fixreleased

Max Bowsher (maxb) wrote :

Ah, thanks for the additional clarification. I have found bug 346359 which has since been filed on this issue and added appropriate comments there.

Changed in indicator-applet:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers