Please merge imview 1.1.9c-3 (universe) from Debian unstable (main).

Bug #306785 reported by Bhavani Shankar on 2008-12-10
8
Affects Status Importance Assigned to Milestone
imview (Ubuntu)
Wishlist
Unassigned

Bug Description

Debian has a new version to be merged.

Changelog since current jaunty version 1.1.9c-2ubuntu1:

imview (1.1.9c-3) unstable; urgency=low

  * Merge patches/limits_h: Include limits.h where it's needed
    (closes: #507172)
  * Merge patches/magickcore: Tweak configure.in to work with imagemagick
    from experimental

 -- Teemu Ikonen <email address hidden> Sat, 29 Nov 2008 21:28:31 +0100

Related branches

Daniel Holbach (dholbach) wrote :

It does not build on Jaunty - did you try to build it?

 -> mounting /proc filesystem
 -> mounting /dev/pts filesystem
 -> policy-rc.d already exists
Obtaining the cached apt archive contents
Installing the build-deps
This package is uninstallable
Dependency is not satisfiable: libmagick9-dev
E: pbuilder-satisfydepends failed.
Copying back the cached apt archive contents
 -> unmounting dev/pts filesystem
 -> unmounting proc filesystem

I'm unsubscribing the Sponsors' Team for now. Please re-subscribe when ready.

Ah.. Recently It was deleted in the jaunty repos....

Stefan Lesicnik (stefanlsd) wrote :

FTBFS

I tried to build it with the new virtual package - libmagickwand-dev

and the api.h is part of libmagickcore-dev

root@lsd:/# dpkg -S /usr/include/ImageMagick/magick/api.h
libmagickcore-dev: /usr/include/ImageMagick/magick/api.h

Maybe just needs an include...

x86_64-linux-gnu-g++ -D_REENTRANT -DLinux -I. -I/usr/include -O2 -Wall -Wno-return-type -Wno-unknown-pragmas -g -O2 -I.. -I.. -M printdlg.cxx savedlg.cxx imginfodlg.cxx transfer.cxx spectra.cxx savespectdlg.cxx prntspectdlg.cxx profile.cxx userprefdlg.cxx tmpmsgdlg.cxx bivdlg.cxx progress.cxx arbitrary.cxx annotatedlg.cxx toolbardlg.cxx transfer2.cxx sliderdlg.cxx view3ddlg.cxx > makedepend
make[3]: Leaving directory `/tmp/buildd/imview-1.1.9c/fluid'
(cd io ; /usr/bin/make depend)
make[3]: Entering directory `/tmp/buildd/imview-1.1.9c/io'
Makefile:117: makedepend: No such file or directory
touch makedepend
make[3]: Leaving directory `/tmp/buildd/imview-1.1.9c/io'
make[3]: Entering directory `/tmp/buildd/imview-1.1.9c/io'
x86_64-linux-gnu-g++ -D_REENTRANT -DLinux -I. -I/usr/include -O2 -Wall -Wno-return-type -Wno-unknown-pragmas -g -O2 -I.. -I.. -M readjpeg.cxx readgif.cxx readtiff.cxx readZimage.cxx readics.cxx readpnm.cxx cpostscript.cxx savetiff.cxx saveZimage.cxx imSystem.cxx gplot2.cxx newprefio.cxx readsocket.cxx readraw.cxx readmat5.cxx readMagick.cxx writeMagick.cxx readps.cxx readpng.cxx readmeta.cxx > makedepend
readMagick.cxx:66:24: error: magick/api.h: No such file or directory
writeMagick.cxx:64:24: error: magick/api.h: No such file or directory
make[3]: *** [depend] Error 1
make[3]: Leaving directory `/tmp/buildd/imview-1.1.9c/io'
make[2]: *** [depend] Error 2
make[2]: Leaving directory `/tmp/buildd/imview-1.1.9c'
make[1]: *** [makedepend] Error 2
make[1]: Leaving directory `/tmp/buildd/imview-1.1.9c'
make: *** [build-stamp] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

Stefan Lesicnik (stefanlsd) wrote :

Waiting on new merge of imagemagick from experimental.

Loïc Minier (lool) wrote :

I just pushed a new imagemagick which allows imview to build; please sync when it's built on all architectures.

Bhavani Shankar (bhavi) wrote :

Okay thanks for the update.....

Loïc Minier (lool) wrote :

My imagemagick update made the imview currently in jaunty build again, but the new one is said to fail to build nevertheless; it seems this is due to broken configure.in checks/usage.

Alessio Treglia (quadrispro) wrote :
Changed in imview:
status: New → Confirmed
Stefan Lesicnik (stefanlsd) wrote :

Hi Alessio,

Your debdiff doesnt detect ImageMagick correctly. You can see this in your buildlog here

MAGICK --with-magick=yes no

and by looking at your build flags.

  CPPFLAGS = -D_REENTRANT -DLinux -I. -I/usr/include
  LDFLAGS = -Wl,-Bsymbolic-functions -L/usr/lib -Wl,-Bsymbolic-functions /usr/lib/libfltk_images.a -lpng -ljpeg /usr/lib/libfltk.a -lXft -lfontconfig -lXinerama -lm -lX11
  LIBRARIES = -Wl,-Bsymbolic-functions /usr/lib/libfltk_images.a -lpng -ljpeg /usr/lib/libfltk.a -lXft -lfontconfig -lXinerama -lm -lX11 -ltiff -ljpeg -lpng -lz -lX11 -lXext -lXpm -lXinerama -lpthread -lm

i.e: no imagemagick support.

Stefan Lesicnik (stefanlsd) wrote :

Attached is debdiff for the proposed fix utilizing PKG_CHECK_MODULES, which is a much more sane and cleaner way of detecting the deps.

Thanks especially to Loïc Minier who spent a lot of time explaining pkg-config to me!

If this is accepted here, I will forward the necessary patch to imview debian git archive.

Stefan Lesicnik (stefanlsd) wrote :

I have some fixes and working on better aclocal integration before this is merged...

Stefan Lesicnik (stefanlsd) wrote :

I experimented with the conversion of this package to autotools but ran into a number of problems (probably to do with my understanding) - many of these being the autoheader which seems to indicate that we need to adjust source code to get this all working correctly.

I would like to work more with upstream on this issue.

I hope the below changes to use acinclude.m4 is the correct way of doing it.

Changelog below.

imview (1.1.9c-3ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #306785)
    - No remaining changes
  * configure.in: Reworked ImageMagick detection to use pkg-config
  * debian/rules: aclocal call to read acinclude.m4
  * debian/control: Build-Depends to include automake
  * acinclude.m4:
    - Moved Imview custom macros from aclocal.m4
    - Added m4_include for pkg-config pkg.m4

 -- Stefan Lesicnik <email address hidden> Wed, 14 Jan 2009 12:11:14 +0200

imview (1.1.9c-3) unstable; urgency=low

  * Merge patches/limits_h: Include limits.h where it's needed
    (closes: #507172)
  * Merge patches/magickcore: Tweak configure.in to work with imagemagick
    from experimental

 -- Teemu Ikonen <email address hidden> Sat, 29 Nov 2008 21:28:31 +0100

imview (1.1.9c-2ubuntu1) jaunty; urgency=low

  * Include limits.h in imview.cxx so that it can use INT_MAX.

 -- James Westby <email address hidden> Fri, 28 Nov 2008 18:36:27 +0000

Stefan Lesicnik (stefanlsd) wrote :

As discussed with james_w. Will stay with aclocal.m4 while i work with upstream on autotools.

imview (1.1.9c-3ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #306785)
    - No remaining changes
  * configure.in: Reworked ImageMagick detection to use pkg-config
  * debian/rules: aclocal call to read acinclude.m4
  * m4/pkg.m4: Added file for pkg-config
  * aclocal.m4:
    - Added m4_include for pkg-config m4/pkg.m4

 -- Stefan Lesicnik <email address hidden> Wed, 14 Jan 2009 12:56:09 +0200

Stefan Lesicnik (stefanlsd) wrote :

Build log

Bhavani Shankar (bhavi) on 2009-01-14
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package imview - 1.1.9c-3ubuntu1

---------------
imview (1.1.9c-3ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #306785)
    - No remaining changes
  * configure.in: Reworked ImageMagick detection to use pkg-config
  * debian/rules: aclocal call to read acinclude.m4
  * m4/pkg.m4: Added file for pkg-config
  * aclocal.m4:
    - Added m4_include for pkg-config m4/pkg.m4

imview (1.1.9c-3) unstable; urgency=low

  * Merge patches/limits_h: Include limits.h where it's needed
    (closes: #507172)
  * Merge patches/magickcore: Tweak configure.in to work with imagemagick
    from experimental

 -- Stefan Lesicnik <email address hidden> Wed, 14 Jan 2009 12:43:27 +0200

Changed in imview:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers