[UNMETDEPS] imaze has unmet dependencies

Bug #145572 reported by Andrew Mitchell on 2007-09-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
imaze (Debian)
Fix Released
Unknown
imaze (Ubuntu)
Medium
Marco Rodrigues

Bug Description

 A run of
 .
  LC_ALL=C apt-cache -i unmet | grep ^Package | cut -d' ' -f2 | grep
  -v dbgsym | sort -u | xargs apt-cache showsrc | grep ^Directory |
  sed 's/Package\:\ //g' | grep verse | cut -d'/' -f4
 indicates that the source package imaze has binary packages that are not
 installable (on AMD64) at the moment.
 .
 Please have a look and make sure it's installable again.

Luca Falavigna (dktrkranz) wrote :

Confirmed in Gutsy, for amd64 only:
imaze-sounds (= 1.4-12build1): FAILED
The following constraints cannot be satisfied:
  imaze-sounds (= 1.4-12build1) depends on imaze {NOT AVAILABLE}

Why doesn't this package build on amd64?
imaze (1.4-12build1) feisty; urgency=low

  * No change rebuild against a now amd64-enabled xview.

 -- Steve Kowalik <email address hidden> Wed, 28 Mar 2007 15:14:27 +1000

Changed in imaze:
status: New → Confirmed
Michael Bienia (geser) wrote :

I guess imaze doesn't get build on amd64 because it's listed as not to be build on amd64 in Packages-arch-specific.

Sense Egbert Hofstede (sense) wrote :

But shouldn't there be something that prevent all architecture independent packaged from coming into the package list of a not supported architecture? The way it is now is quite confusing for some users.

Savvas Radevic (medigeek) wrote :

This seems to build fine for amd64:
https://launchpad.net/~medigeek/+archive/ppa
https://launchpad.net/~medigeek/+archive/ppa/+build/860601

Note: 1.4-12build2 is actually 1.4-12build1, just testing in my PPA

Savvas Radevic (medigeek) wrote :

I've subscribed universe sponsors to enable amd64 for jaunty

Luca Falavigna (dktrkranz) wrote :

This won't build for amd64, imaze is still blacklisted in P-A-S for 64bit architectures.

https://buildd.debian.org/quinn-diff/Packages-arch-specific:
imaze-xview: !ia64 !amd64
%imaze: !ia64 !amd64

Have you tried amd64 version of imaze? If so, could you please describe your tests?
I'm unsubscribing u-u-s queue for now because this bug still requires some interaction with Debian.

Changed in imaze:
importance: Undecided → Medium
Savvas Radevic (medigeek) wrote :

I've built it for amd64 as you can see and the game has run normally, but it needs TCP/IP from what I've understood, the default server doesn't work anymore.

Changed in imaze:
status: Unknown → New
Sense Egbert Hofstede (sense) wrote :

Setting the status to Triaged for Ubuntu and letting know that this is still an issue on Karmic. The package 'imaze-sounds' is shown in the index of amd64 repositories, but is of course not installable.

Changed in imaze (Ubuntu):
status: Confirmed → Triaged
Changed in imaze (Debian):
status: New → Fix Released
Marco Rodrigues (gothicx) wrote :

This package was removed from Debian. I'm closing the bug report.

Thank you.

Changed in imaze (Ubuntu):
status: Triaged → Fix Released
assignee: nobody → Marco Rodrigues (gothicx)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.