Upgrading to edgy beta leavs imake and makedepend

Bug #63396 reported by Peter Magnusson on 2006-10-01
12
Affects Status Importance Assigned to Milestone
imake (Ubuntu)
Medium
Colin Watson

Bug Description

After upgrading to edgy beta (on 2006-09-30) and doing a forced install of xserver-xorg I still have some things left behind that troubles me.

The packages imake and makedepend are left behind as "local or old" or whatever that line is in english. When I try to remove them with synaptic or aptitude or whatever it also wants to remove a lot of other packages that it claims depend on imake and makedepend.
When doing "sudo apt-get remove imake" I get that the following will be removed.

apport-gtk
banshee
deskbar-applet
gdebi
gdm
gksu
gnome-applets
gnome-control-center
gnome-netstatus-applet
gnome-panel gnome-session
gnome-sudoku
gnome-terminal
gnome-volume-manager
gsfonts-x11
hal-device-manager
hwdb-client-gnome
imake
libgksu1.2-1
libgksu2-0
libgksuui1.0-1
libipoddevice0
libxklavier11
nautilus
nautilus-cd-burner
python-gnome2-extras
serpentine
ttf-arphic-ukai
ttf-arphic-uming
ttf-thai-tlwg
update-manager
update-notifier
x-ttcidfont-conf
xbase-clients
xserver-xorg
xutils

I know I want a lot of those packages and this dependency seems a little off.

Michael Bienia (geser) wrote :

Install xutils-dev. This will remove the old imake and makedepend and make the other packages satisfied as it provides both packages.

Peter Magnusson (kmpm) wrote :

Michaels solution did the trick.
Both imake and makedepend are now gone.

Michael Vogt (mvo) wrote :

it seems like we need a transition package for imake.

Rodrigo Novo (rodarvus) on 2006-10-03
Changed in imake:
assignee: nobody → rodarvus
importance: Undecided → Medium
Jacob Winski (winski) wrote :

bug confirmed as of 2006-10-05

Colin Watson (cjwatson) wrote :

The problem was that xutils still depended on imake, xbase-clients depended on xutils, xserver-xorg depended on xbase-clients, etc. I've verified that this change has caused 'apt-get dist-upgrade' from a clean Ubuntu 6.06.1 installation to remove imake and makedepend and install xutils-dev instead:

xorg (1:7.1.1ubuntu4) edgy; urgency=low

  * Restore xbase-clients, xlibs-dev, and xutils transitional packages for
    now, since many packages in Edgy still depend or build-depend on them.

 -- Colin Watson <email address hidden> Mon, 16 Oct 2006 21:01:43 +0100

Changed in imake:
assignee: rodarvus → kamion
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

(In the above upload, I also changed xutils' Depends from imake (>= 1:1.0.0) | xmkmf to xutils-dev.)

Jacob Winski (winski) wrote :

What upload? Status is "Fix Released", but not fix is attached. Maybe Mr. Watson forgot to attach a file?

Michael Vogt (mvo) wrote :

Just a quick confirmation that the uploaded fix works.

Thanks Colin!

Jacob Winski (winski) wrote :

Thank you for the confirmation!

And thank you for fixing this.

towsonu2003 (towsonu2003) wrote :

> What upload? Status is "Fix Released", but not fix is attached.

they upload the fixed packages to the repositories but don't upload diffs here. it's regular business for ubuntu :)

do
sudo apt-get update
and your machine will know about the fix.

On Tue, Oct 17, 2006 at 01:52:24PM -0000, AgenT wrote:
> What upload? Status is "Fix Released", but not fix is attached. Maybe
> Mr. Watson forgot to attach a file?

Maybe Mr. AgenT forgot to read the changelog I already posted to the
bug. :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers