Please merge imagezoom 0.3.1-1 from Debian unstable (main)

Bug #227577 reported by Nathan Handler
2
Affects Status Importance Assigned to Milestone
imagezoom (Ubuntu)
Wishlist
Unassigned

Bug Description

Debian has a new version which needs to be merged.

Revision history for this message
Nathan Handler (nhandler) wrote :
Changed in imagezoom:
status: New → Confirmed
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

According to http://dad.dunnewind.net/universe.php the previous uploader is working on this. Can you pls. check with him to avoid nugatory work?

Changed in imagezoom:
status: Confirmed → Incomplete
Revision history for this message
Saša Bodiroža (jazzva) wrote :

diff looks fine to me.

 - Saša, previous uploader

Changed in imagezoom:
status: Incomplete → Confirmed
Revision history for this message
Nathan Handler (nhandler) wrote :

I didn't realize you were working on this Saša. I checked launchpad prior to starting to work on the merge to see if there were in "In Progress" bugs concerning a merge. I didn't see any, so I did it myself. I'll be sure to check DaD next time as well. Also, thanks for the ok.

Revision history for this message
Saša Bodiroža (jazzva) wrote : Re: [Bug 227577] Re: Please merge imagezoom 0.3.1-1 from Debian unstable (main)

No problem, Nathan :).

--
Best regards,
Saša Bodiroža

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

In the changelog you don't mention any of the changes in 0.3-1ubuntu1 which you have carried over.
I'd also like to see an ubuntu->ubuntu diff.

Changed in imagezoom:
status: Confirmed → Incomplete
Revision history for this message
Saša Bodiroža (jazzva) wrote :

Cesare,

As far as I can see, he copy/pasted exactly what I wrote in the last upload. The packaging differs totally from the Debian one, since we started using mozilla-devscripts in hardy development cycle, which provides xpi.mk and does most of the building process. Maybe it could be explained better in the changelog (my English can suck from time to time).

I suppose that ubuntu->ubuntu diff will show no changes in the packaging. There will be one: moving zip from Build-Depends to Build-Depends-Indep. The packaging is OK for the new upstream version.

Revision history for this message
Saša Bodiroža (jazzva) wrote :

Oh, 0.3-1ubuntu1. I read it 0.3.1-0ubuntu1. Forget the first part of the previous comment.

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

There should be two changes (the other is the homepage change).
We ask for both debdiffs (see https://wiki.ubuntu.com/UbuntuDevelopment/Merging) because when you have 100 ubuntu changes and 1 debian change, it is far easier to sponsor an ubuntu->ubuntu diff (which will show 1 change) more than a debian->ubuntu diff (which will show 100 changes).
Another reason (not applicable in this case) is that you can easily see the Debian delta.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Unsubscribing u-u-s, please resubscribe it when there's a proper debdiff attached. Thanks!

Changed in imagezoom:
assignee: nobody → nhandler
status: Incomplete → In Progress
Revision history for this message
Nathan Handler (nhandler) wrote :

Debian->Ubuntu debdiff

Revision history for this message
Nathan Handler (nhandler) wrote :

Ubuntu->Ubuntu debdiff

Revision history for this message
Nathan Handler (nhandler) wrote :

imagezoom (0.3.1-1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes (LP: #227577):
    - Repackaged using XPI.TEMPLATE
    - In debian/rules:
      - added build/mozilla-imagezoom rule to make a imagezoom.xpi file
      - added clean rule to cleanup the imagezoom.xpi file
    - Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Nathan Handler <email address hidden> Sat, 07 Jun 2008 16:04:19 -0500

Changed in imagezoom:
assignee: nhandler → nobody
status: In Progress → Confirmed
Revision history for this message
Nathan Handler (nhandler) wrote :

Please ignore the last set of patches. This new set of patches is identical to the last one, but they also fix LP: 154778.

Debian->Ubuntu debdiff

Revision history for this message
Nathan Handler (nhandler) wrote :

Ubuntu->Ubuntu debdiff

Revision history for this message
Nathan Handler (nhandler) wrote :

imagezoom (0.3.1-1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes (LP: #227577):
    - Repackaged using XPI.TEMPLATE
    - In debian/rules:
      - added build/mozilla-imagezoom rule to make a imagezoom.xpi file
      - added clean rule to cleanup the imagezoom.xpi file
    - Add thunderbird support (LP: #154778)
      - Modify MOZ_XPI_MOZILLA_DIRS in debian/rules
      - Add thunderbird as an optional dependency in debian/control
    - Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Nathan Handler <email address hidden> Sat, 07 Jun 2008 18:27:53 -0500

Revision history for this message
Nathan Handler (nhandler) wrote :

The only change in this set of debdiff files is the layout of debian/changelog

Debian->Ubuntu debdiff

Revision history for this message
Nathan Handler (nhandler) wrote :

Ubuntu->Ubuntu debdiff

Revision history for this message
Nathan Handler (nhandler) wrote :

imagezoom (0.3.1-1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes (LP: #227577):
    - Repackaged using XPI.TEMPLATE
    - In debian/rules:
      - added build/mozilla-imagezoom rule to make a imagezoom.xpi file
      - added clean rule to cleanup the imagezoom.xpi file
    - Modify Maintainer value to match Debian-Maintainer-Field Spec
  * Add thunderbird support (LP: #154778)
    - Modify MOZ_XPI_MOZILLA_DIRS in debian/rules
    - Add thunderbird as an optional dependency in debian/control

 -- Nathan Handler <email address hidden> Sat, 07 Jun 2008 20:24:33 -0500

Revision history for this message
Saša Bodiroža (jazzva) wrote :

I'm not an Ubuntu developer yet, but I packaged this package with XPI.TEMPLATE and mozilla-devscripts. The packaging totally differs from the Debian's package, so I think that most of the changes in version 0.3-1ubuntu1 shouldn't be mentioned. The only change from that version that should be mentioned is the modification of Maintainer field according to DebianMaintainerField spec, which Nathan did.

So, these diffs look fine to me.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Saša Bodiroža wrote:
> The packaging totally differs from
> the Debian's package, so I think that most of the changes in version
> 0.3-1ubuntu1 shouldn't be mentioned.

Without looking at the bug report, the policy is to mention every change when
you merge a package with Debian.

Another possibility is:

"* Merge from Debian unstable, look at 0.3.0-1ubuntu1 for the remaining changes"

if they are exactly the same. No idea if that's the case here though.

Revision history for this message
Saša Bodiroža (jazzva) wrote :

Hello Emilio,

I probably didn't explain correctly. The thing is that back in 0.3-1ubuntu1 we started with the same packaging as Debian, and then made some changes in it, which are mentioned in the changelog entry for that version. For 0.3.1-0ubuntu1, we repackaged imagezoom to make use of xpi.mk in mozilla-devscripts and XPI.TEMPLATE, which is mentioned in the changelog as "Repackaged using XPI.TEMPLATE". Debian still doesn't have mozilla-devscripts, so that's why I think that changes in 0.3-1ubuntu1 shouldn't be mentioned - we use different packaging, and that is mentioned in the changelog as "Repackaged".

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

The reason to mention every single change in each merge is that when someone
else looks at the package, he will look at the merge to see our changes wrt.
Debian. So if you do a merge and don't mention every change, if I do the next
merge and only look at the changelog entry I may end doing it wrong.

Hope that explains.

Revision history for this message
Saša Bodiroža (jazzva) wrote :

I understand the reason, but I don't think it is reasonable mentioning a change like "Remove the icedove, iceweasel and iceape symlinks in debian/links" or "Change the thunderbird symlink from usr/lib/thunderbird to usr/lib/mozilla-thunderbird in debian/links" since we don't have that file anymore. We also don't use postinst and postrm scripts, so mentioning "Remove update-iceape-chrome from debian/postinst and debian/postrm" wouldn't mean too much. As I said, we use a totally different packaging for now.

Saša Bodiroža (jazzva)
Changed in imagezoom:
importance: Undecided → Wishlist
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

I fail to see what is the point of this merge.
We have diverged so much that it only makes sense to just keep the Ubuntu package as is, raise the version and add the needed changes (homepage and thunderbird support).
We may sync/merge in the future if the Debian package will converge back to something similar to our.

Changed in imagezoom:
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package imagezoom - 0.3.1-0ubuntu2

---------------
imagezoom (0.3.1-0ubuntu2) intrepid; urgency=low

  [Cesare Tirabassi]

  * debian/control:
    - add Homepage field and remove homepage from description (LP: #227577)

  [Nathan Handler]

  * Add thunderbird support (LP: #154778):
    - modify MOZ_XPI_MOZILLA_DIRS in debian/rules
    - add thunderbird as an optional dependency in debian/control

 -- Cesare Tirabassi <email address hidden> Sun, 13 Jul 2008 11:48:39 +0200

Changed in imagezoom:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers