Ubuntu

ImageMagick Font Issues

Reported by Richard Laager on 2006-10-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
imagemagick (Ubuntu)
Medium
Unassigned
Nominated for Jaunty by Alex Mauer

Bug Description

Binary package hint: libmagick9

Regarding one of our web servers, a co-worker of mine filed an internal
bug with this text:

> ImageMagick fonts don't get properly configured -- this seems like it
> may be a package bug to me, though I'm not sure.
> Basically /usr/lib/ImageMagick-6.2.4/config/type.xml, as installed,
> refers to type-ghostscript.xml, which refers to fonts that are not
> installed (we don't have any Type 1 fonts installed). The ImageMagick
> examples page ( http://www.cit.gu.edu.au/~anthony/graphics/imagick6/ )
> suggests using a script to enumerate fonts:
> http://www.cit.gu.edu.au/~anthony/graphics/imagick6/scripts/imagick_type_gen (this produces a replacement for type.xml). I did that and it seems to work fine. The proper way would probably involve having every installed font package add a file to be included in type.xml. (Well, ideally, there would be a type.d directory, I suppose :) )

Our needing to edit a configuration file which is stored
in /usr/lib/ImageMagick-6.2.4/config makes me nervous. It's going to get
overwritten on upgrades, since it's not a conffile, right?

Richard Laager (rlaager) wrote :

Perhaps this package should be using Defoma: "Defoma, which stands for DEbian FOnt MAnager, provides a framework for automatic font configuration. An application whose configuration of fonts usually requires manual intervention can automate the process through Defoma, by installing a Defoma-configuration script. The script gets called whenever a font is installed and removed, so that the script may update the application configuration."

Simon Law (sfllaw) on 2006-10-31
Changed in imagemagick:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 alpha?

Changed in imagemagick:
status: Confirmed → Incomplete
Juan Cespedes (cespedes) wrote :

Yes, it is. AFAIK, fonts configuration have not changed in ImageMagick; it still does not use defoma to be able to use new fonts, and it still comes with a fixed set of fonts, which may not be installed on your system.

Alex Mauer (hawke) on 2009-04-02
Changed in imagemagick (Ubuntu):
status: Incomplete → Confirmed
Alex Mauer (hawke) wrote :

Still a problem in Jaunty.

Reuben Thomas (rrt) wrote :

What is annoying is that this used to work, and still does in Debian lenny with Imagemagick 6.3.7: when I type

convert -list font

I get all the fonts listed that are accessible to fontconfig, as far as I can tell, including fonts installed in my home directory. I have no ~/.magick directory at all on that machine.

Since the Ubuntu imagemagick packages appear to be derived from the Debian packages, perhaps this can be sorted out with the Debian packagers? I note that the Debian package (lenny and sid) depends on libfontconfig1, whereas the Jaunty Ubuntu package doesn't. I can see nothing in the Ubuntu changelog.Debian.gz about this.

Changed in debian:
status: Confirmed → Fix Committed
Changed in debian:
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

According to the Debian bug report this is fixed in version 7:6.5.9.8-1 which is included in Ubuntu since Maverick. Subsequently I am setting this to Fix Released.

Changed in imagemagick (Ubuntu):
status: Confirmed → Fix Released
tags: added: udd-find
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.