Ubuntu

convert: "-quality" ignored in JPG to PDF conversion

Reported by Michael Opdenacker on 2009-07-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
imagemagick (Debian)
Fix Released
Unknown
imagemagick (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: imagemagick

I used to convert a series of JPG files to PDF with the following command:
convert -quality 20 *.jpg output.pdf

With 16 images sizing approximately 3 MB, the output file was about 3MB big in Ubuntu 8.10 and earlier.

This no longer works in 9.04. The output file is now more than 300MB big!

I'm using imagemagick 7:6.4.5.4.dfsg1-1ubuntu3.1

This must be a problem with this particular ImageMagick version, or with the way the package was compiled. I rebuilt ImageMagick-6.5.4-2 from its sources, and it didn't show this issue.

Kevin Ford (kford) wrote :

I can attest that the output PDF seems unusually, and unnecessarily, large.

I converted 3 JPG files, ranging in size from 200k to 400k, to a PDF with

convert *.jpg out.pdf

The resulting PDF file is 10 MBs.

I'm running Kubuntu 9.04. Imagemagick info:

convert -version
Version: ImageMagick 6.4.5 2009-06-04 Q16 OpenMP http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC

This may, or may not, be apples and oranges, but FWIW, I downloaded the most recent version of Imagemagick on Windows and, using the same 3 input JPG files, created a PDF. The resulting PDF was 1 MB. The Windows box was what I had handy.

kaefert (kaefert) wrote :

this bug really sucks..
any solution?

Martin Gernhard (gecko15x) wrote :

I can confirm this behaviour, although this does not seem to depend on either the "-quality" option or multiple input files. A ~100KiB JPEG is converted into a 1.2MiB PDF with simply "convert image.jpg image.pdf"

convert --version
Version: ImageMagick 6.4.5 2009-06-04 Q16 OpenMP http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC

Work on debian testing. Could you retest?

Works on Lucid. You can close the bug.
Thanks!

Don't forget to close this bug. Thanks!

Changed in imagemagick (Debian):
status: Unknown → Fix Released
Fabrice Coutadeur (fabricesp) wrote :

Fix in Debian has been synced since then. Closing as Fix Released.

Changed in imagemagick (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.