File read error

Bug #20600 reported by Debian Bug Importer on 2005-08-30
4
Affects Status Importance Assigned to Milestone
imagemagick (Debian)
Fix Released
Unknown
imagemagick (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #325720 http://bugs.debian.org/325720

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 26 Jul 2005 16:25:17 +0200
From: <email address hidden>
To: <email address hidden>
Subject: File read error

Package: librmagick-ruby1.8
Version: 1.6.0-1

There's something wrong with character pointers:

% ruby -r RMagick -e 'Magick::Image.read("testimage.png")'
-e:1:in `read': unable to open image `e.png': No such file or
directory: (Magick::ImageMagickError)
        from -e:1

Magick::Image.read always chops the first 8 characters of the
filename.

regards
Hadmut

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 27 Jul 2005 20:19:45 +1000
From: Mike Williams <email address hidden>
To: <email address hidden>, <email address hidden>
Subject: Re: Bug#320029: File read error

<email address hidden> wrote:

> Magick::Image.read always chops the first 8 characters of the
> filename.

I've seen this happen before, when Imagemagick was upgraded without a
corresponding rebuild of librmagick-ruby.

What versions of libmagick6 and librmagick-ruby1.8 are you running??
Normally, if you run "reportbug librmagick-ruby1.8", it will generate
all the relevant version data for inclusion in the bug report.

--
cheers, MikeW http://www.dogbiscuit.org/mdub/

Revision history for this message
Debian Bug Importer (debzilla) wrote :
Download full text (4.3 KiB)

Message-ID: <email address hidden>
Date: Wed, 27 Jul 2005 13:25:21 +0200
From: Hadmut Danisch <email address hidden>
To: Mike Williams <email address hidden>
Cc: <email address hidden>, <email address hidden>
Subject: Re: Bug#320029: File read error

On Wed, Jul 27, 2005 at 08:19:45PM +1000, Mike Williams wrote:
>
> What versions of libmagick6 and librmagick-ruby1.8 are you running??

I had the problem on my workstation at work and don't want to
send emails from that machine, that's why I didn't use
reportbug.

On the system where the bug occurs:

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11.7
Locale: LANG=C, LC_CTYPE=de_DE (charmap=ISO-8859-1)

Versions of packages librmagick-ruby1.8 depends on:
ii libbz2-1.0 1.0.2-7 high-quality
block-sorting file co
ii libc6 2.3.2.ds1-22 GNU C Library: Shared
libraries an
ii libdps1 6.8.2.dfsg.1-3 Display PostScript (DPS)
client li
ii libfreetype6 2.1.10-1 FreeType 2 font engine,
shared lib
ii libice6 6.8.2.dfsg.1-3 Inter-Client Exchange
library
ii libjasper-1.701-1 1.701.0-2 The JasPer JPEG-2000
runtime libra
ii libjpeg62 6b-10 The Independent JPEG
Group's JPEG
ii liblcms1 1.13-1 Color management library
ii libmagick6 6:6.2.3.3-1 Image manipulation
library
ii libpng12-0 1.2.8rel-1 PNG library - runtime
ii libruby1.8 1.8.2-9 Libraries necessary to
run Ruby 1.
ii libsm6 6.8.2.dfsg.1-3 X Window System Session
Management
ii libtiff4 3.7.3-1 Tag Image File Format
(TIFF) libra
ii libx11-6 6.8.2.dfsg.1-3 X Window System protocol
client li
ii libxext6 6.8.2.dfsg.1-3 X Window System
miscellaneous exte
ii libxml2 2.6.20-1 GNOME XML library
ii libxt6 6.8.2.dfsg.1-3 X Toolkit Intrinsics
ii xlibs 6.8.2.dfsg.1-3 X Window System client
libraries m
ii zlib1g 1:1.2.2-9 compression library -
runtime

librmagick-ruby1.8 recommends no packages.

-- no debconf information

Just for comparison my home system, where the bug does not occur:

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.11-danisch-p4-intel
Locale: LANG=C, LC_CTYPE=de_DE (charmap=ISO-8859-1)

Versions of packages librmagick-ruby1.8 depends on:
ii libbz2-1.0 1.0.2-5 high-quality block-sorting file co
ii libc6 2.3.2.ds1-22 GNU C Library: Shared libraries an
ii libdps1 4.3.0.dfsg.1-10 Display PostScript (DPS) client li
ii libfreetype6 2.1.10-1 FreeType 2 font engine, shared lib
ii libice6 6.8.2.dfsg.1-3 Inter-Client Exchange library
ii libjasper-1.701-1 1.701.0-2 The JasPer JPEG-2000 runtime libra
i...

Read more...

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 27 Jul 2005 21:43:00 +1000
From: Mike Williams <email address hidden>
To: Hadmut Danisch <email address hidden>
CC: <email address hidden>, <email address hidden>
Subject: Re: Bug#320029: File read error

Hadmut Danisch wrote:

> On the system where the bug occurs:
>
> ii libmagick6 6:6.2.3.3-1 ...
>
> Just for comparison my home system, where the bug does not occur:
>
> ii libmagick6 6:6.0.6.2-1.6 ...
>
> So interestingly, the system with the bug is actually on a
> newer level than my home system without the bug.

Yup, what you're seeing is a binary-compatibility conflict between
librmagick-ruby1.8_1.6.0-1 (which was built against ImageMagick-6.0.6),
and the newer ImageMagick-6.2.x libraries.

A new version of librmagick-ruby, built against ImageMagick-6.2.x, was
uploaded yesterday, and should make it's way into the archive within the
week. Until then, I suggest you temporarily downgrade libmagick6 on the
  broken system.

--
cheers, MikeW http://www.dogbiscuit.org/mdub/

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 27 Jul 2005 13:54:31 +0200
From: Hadmut Danisch <email address hidden>
To: Mike Williams <email address hidden>
Cc: <email address hidden>, <email address hidden>
Subject: Re: Bug#320029: File read error

On Wed, Jul 27, 2005 at 09:43:00PM +1000, Mike Williams wrote:
>
> Yup, what you're seeing is a binary-compatibility conflict between
> librmagick-ruby1.8_1.6.0-1 (which was built against ImageMagick-6.0.6),
> and the newer ImageMagick-6.2.x libraries.

BTW:
Isn't this an error of the ImageMagick package?

If the library is not API compatible, it should have a different
version number and not link against.

regards
Hadmut

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 30 Aug 2005 23:02:22 +1000
From: Mike Williams <email address hidden>
To: Hadmut Danisch <email address hidden>, <email address hidden>
CC: <email address hidden>
Subject: Re: Bug#320029: File read error

clone 320029 -1
reassign -1 libmagick6 6:6.2.3.3-1
thanks

Hadmut Danisch wrote:

>>Yup, what you're seeing is a binary-compatibility conflict between
>>librmagick-ruby1.8_1.6.0-1 (which was built against ImageMagick-6.0.6),
>>and the newer ImageMagick-6.2.x libraries.
>
> BTW:
> Isn't this an error of the ImageMagick package?
>
> If the library is not API compatible, it should have a different
> version number and not link against.

Apologies for the delay. Hadmut, I think you're right.

Ryuichi, given that there seems to have been an ABI change here, should
the so-version of libmagick have been increased?

--
cheers, MikeW http://www.dogbiscuit.org/mdub/

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 15:37:43 +0200
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Subject: severity of 325720 is grave, merging 325720 325651

# Automatically generated email from bts, devscripts version 2.9.5
severity 325720 grave
merge 325720 325651

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 15:58:29 +0200
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Subject: reassign 318176 to libmagick6, merging 318176 325651

# Automatically generated email from bts, devscripts version 2.9.5
reassign 318176 libmagick6
merge 318176 325651

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Marking as duplicate based on debbugs merge (318176,325720)

This bug has been marked as a duplicate of bug 20599.

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 13:37:47 -0700
From: Steve Langasek <email address hidden>
To: <email address hidden>
Subject: reassign 318176 to libmagick6, merging 318176 325651

# Automatically generated email from bts, devscripts version 2.8.14
reassign 318176 libmagick6
merge 318176 325651

Revision history for this message
Debian Bug Importer (debzilla) wrote :
Download full text (4.3 KiB)

Message-Id: <email address hidden>
Date: Tue, 27 Sep 2005 15:03:24 -0700
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Cc: Daniel Kobras <email address hidden>, Ryuichi Arafune <email address hidden>
Subject: Fixed in NMU of imagemagick 6:6.2.4.5-0.1

tag 318176 + fixed
tag 325651 + fixed
tag 325720 + fixed

quit

This message was generated automatically in response to a
non-maintainer upload. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 17 Sep 2005 01:00:09 +0200
Source: imagemagick
Binary: perlmagick libmagick9 libmagick++9 libmagick9-dev imagemagick libmagick++9-dev
Architecture: source i386
Version: 6:6.2.4.5-0.1
Distribution: unstable
Urgency: low
Maintainer: Ryuichi Arafune <email address hidden>
Changed-By: Daniel Kobras <email address hidden>
Description:
 imagemagick - Image manipulation programs
 libmagick++9 - The object-oriented C++ API to the ImageMagick library
 libmagick++9-dev - The object-oriented C++ API to the ImageMagick library--developme
 libmagick9 - Image manipulation library
 libmagick9-dev - Image manipulation library -- development
 perlmagick - A perl interface to the libMagick graphics routines
Closes: 318176 325651 325720
Changes:
 imagemagick (6:6.2.4.5-0.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Yet another bump of the soname version, this time going from
       7 to 9.
   * debian/*: Cater for soname change and corresponding change of
     library packages names in multiple places.
 .
 imagemagick (6:6.2.4.4-0.1) experimental; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Version in library soname was increased from 6 to 7 due to
       changes in binary interface starting with 6.0.7. (Yes, this
       should have happened earlier.) Closes: #318176, #325651, #325720
   * debian/*: Rename packages from libmagick6 to libmagick7, and similar.
     Adjust version in various places accordingly. Drop c2 suffix from
     C++ library package.
   * debian/control: Use shlibs information to generate Depends line for
     imagemagick binary package.
   * debian/control: Remove Pre-Depends on prehistoric version of dpkg.
   * debian/control: Package complies with policy version 3.6.2. Bump
     Standards-Version accordingly.
   * Patches to upstream sources:
     + [bin/Magick++-config.1.debdiff]
       Stray file that seems to have slipped into the previous Debian
       diffs by mistake. Removed now.
     + [magick/blob.c]
       Originally a patch from upstream, now mostly merged. Retaining a
       single hunk that upstream reverted later on, though it still looks
       correct.
     + [configure.ac, configure]
       Override location of documentation files to Debian's default
       /usr/share/doc/imagemagick. Patch to configure was present before.
       This release promotes it back to configure.ac as well. (No ill
       effects because AM_MAINTAINER_MODE is used.)
     + [coders/magick.c]
       Drop patch that exchanges upstream's logo for a DFSG-free version.
       This attempt to address #214623 (distribution of non-free logo)
       missed several ...

Read more...

Changed in imagemagick:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.