imagemagick in combination with transcode fails (amd64)

Bug #20599 reported by Debian Bug Importer on 2005-08-30
16
Affects Status Importance Assigned to Milestone
imagemagick (Debian)
Fix Released
Unknown
imagemagick (Ubuntu)
High
Michael Vogt

Bug Description

Automatically imported from Debian bug report #318176 http://bugs.debian.org/318176

severity 318176 normal

# Automatically generated email from bts, devscripts version 2.9.5
severity 318176 grave
merge 318176 325651

# Automatically generated email from bts, devscripts version 2.9.5
reassign 318176 libmagick6
merge 318176 325651

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #318176 http://bugs.debian.org/318176

Debian Bug Importer (debzilla) wrote :

Message-Id: <E1Dsoza-0001nH-0h@bluebox>
Date: Wed, 13 Jul 2005 23:42:09 +0200
From: Oliver Chief O'Cordes <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: imagemagick in combination with transcode fails (amd64)

Package: imagemagick
Version: 6:6.2.3.1-1
Severity: grave

Afer the update of imagemagic to version 6.2.3.1-1 transcode fails to
load images (logo-modules) with transcode. The reason is that the
filename of a specific file is shrunked by imagemagick:

/home/ocordes/movies/convert/logo.png -> vies/convert/logo.png

I tried to enter some dummy characters into the filename, but then
imagemagick opens the file but gives wrong pixelsizes. I think that this
error is an amd64 specific error. Please check for this behavior
otherwise imagemagick is useless for me on the amd64 platform.

Please contact me, if you need some debugging under amd64!

Oliver Cordes

-- System Information:
Debian Release: testing/unstable
Architecture: amd64 (x86_64)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.9
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages imagemagick depends on:
ii libmagick6 6:6.2.3.1-1 Image manipulation library

imagemagick recommends no packages.

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 14 Jul 2005 09:42:25 +0900 (JST)
From: Ryuichi Arafune <email address hidden>
To: <email address hidden>

severity 318176 normal

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 15:44:00 +0200
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Subject: severity of 318176 is grave, merging 318176 325651

# Automatically generated email from bts, devscripts version 2.9.5
severity 318176 grave
merge 318176 325651

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 15:58:29 +0200
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Subject: reassign 318176 to libmagick6, merging 318176 325651

# Automatically generated email from bts, devscripts version 2.9.5
reassign 318176 libmagick6
merge 318176 325651

Debian Bug Importer (debzilla) wrote :

*** Bug 20574 has been marked as a duplicate of this bug. ***

Debian Bug Importer (debzilla) wrote :

*** Bug 20600 has been marked as a duplicate of this bug. ***

Matt Zimmerman (mdz) wrote :

Thanks for the analysis; please monitor this issue

# Automatically generated email from bts, devscripts version 2.8.14
reassign 318176 libmagick6
merge 318176 325651

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 13:37:47 -0700
From: Steve Langasek <email address hidden>
To: <email address hidden>
Subject: reassign 318176 to libmagick6, merging 318176 325651

# Automatically generated email from bts, devscripts version 2.8.14
reassign 318176 libmagick6
merge 318176 325651

Download full text (4.0 KiB)

tag 318176 + fixed
tag 325651 + fixed
tag 325720 + fixed

quit

This message was generated automatically in response to a
non-maintainer upload. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 17 Sep 2005 01:00:09 +0200
Source: imagemagick
Binary: perlmagick libmagick9 libmagick++9 libmagick9-dev imagemagick libmagick++9-dev
Architecture: source i386
Version: 6:6.2.4.5-0.1
Distribution: unstable
Urgency: low
Maintainer: Ryuichi Arafune <email address hidden>
Changed-By: Daniel Kobras <email address hidden>
Description:
 imagemagick - Image manipulation programs
 libmagick++9 - The object-oriented C++ API to the ImageMagick library
 libmagick++9-dev - The object-oriented C++ API to the ImageMagick library--developme
 libmagick9 - Image manipulation library
 libmagick9-dev - Image manipulation library -- development
 perlmagick - A perl interface to the libMagick graphics routines
Closes: 318176 325651 325720
Changes:
 imagemagick (6:6.2.4.5-0.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Yet another bump of the soname version, this time going from
       7 to 9.
   * debian/*: Cater for soname change and corresponding change of
     library packages names in multiple places.
 .
 imagemagick (6:6.2.4.4-0.1) experimental; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Version in library soname was increased from 6 to 7 due to
       changes in binary interface starting with 6.0.7. (Yes, this
       should have happened earlier.) Closes: #318176, #325651, #325720
   * debian/*: Rename packages from libmagick6 to libmagick7, and similar.
     Adjust version in various places accordingly. Drop c2 suffix from
     C++ library package.
   * debian/control: Use shlibs information to generate Depends line for
     imagemagick binary package.
   * debian/control: Remove Pre-Depends on prehistoric version of dpkg.
   * debian/control: Package complies with policy version 3.6.2. Bump
     Standards-Version accordingly.
   * Patches to upstream sources:
     + [bin/Magick++-config.1.debdiff]
       Stray file that seems to have slipped into the previous Debian
       diffs by mistake. Removed now.
     + [magick/blob.c]
       Originally a patch from upstream, now mostly merged. Retaining a
       single hunk that upstream reverted later on, though it still looks
       correct.
     + [configure.ac, configure]
       Override location of documentation files to Debian's default
       /usr/share/doc/imagemagick. Patch to configure was present before.
       This release promotes it back to configure.ac as well. (No ill
       effects because AM_MAINTAINER_MODE is used.)
     + [coders/magick.c]
       Drop patch that exchanges upstream's logo for a DFSG-free version.
       This attempt to address #214623 (distribution of non-free logo)
       missed several other instances of the logo, must be applied to
       the orig.tar.gz rather than the Debian diff, and should have
       some input from upstream, so no point in carrying it around still.
Files:
 616b8b1a0a6ae660fe960521b56eb7e7 894 graphics optional imagemagick_6.2.4.5-0.1.dsc
 ...

Read more...

Debian Bug Importer (debzilla) wrote :
Download full text (4.3 KiB)

Message-Id: <email address hidden>
Date: Tue, 27 Sep 2005 15:03:24 -0700
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Cc: Daniel Kobras <email address hidden>, Ryuichi Arafune <email address hidden>
Subject: Fixed in NMU of imagemagick 6:6.2.4.5-0.1

tag 318176 + fixed
tag 325651 + fixed
tag 325720 + fixed

quit

This message was generated automatically in response to a
non-maintainer upload. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 17 Sep 2005 01:00:09 +0200
Source: imagemagick
Binary: perlmagick libmagick9 libmagick++9 libmagick9-dev imagemagick libmagick++9-dev
Architecture: source i386
Version: 6:6.2.4.5-0.1
Distribution: unstable
Urgency: low
Maintainer: Ryuichi Arafune <email address hidden>
Changed-By: Daniel Kobras <email address hidden>
Description:
 imagemagick - Image manipulation programs
 libmagick++9 - The object-oriented C++ API to the ImageMagick library
 libmagick++9-dev - The object-oriented C++ API to the ImageMagick library--developme
 libmagick9 - Image manipulation library
 libmagick9-dev - Image manipulation library -- development
 perlmagick - A perl interface to the libMagick graphics routines
Closes: 318176 325651 325720
Changes:
 imagemagick (6:6.2.4.5-0.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Yet another bump of the soname version, this time going from
       7 to 9.
   * debian/*: Cater for soname change and corresponding change of
     library packages names in multiple places.
 .
 imagemagick (6:6.2.4.4-0.1) experimental; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Version in library soname was increased from 6 to 7 due to
       changes in binary interface starting with 6.0.7. (Yes, this
       should have happened earlier.) Closes: #318176, #325651, #325720
   * debian/*: Rename packages from libmagick6 to libmagick7, and similar.
     Adjust version in various places accordingly. Drop c2 suffix from
     C++ library package.
   * debian/control: Use shlibs information to generate Depends line for
     imagemagick binary package.
   * debian/control: Remove Pre-Depends on prehistoric version of dpkg.
   * debian/control: Package complies with policy version 3.6.2. Bump
     Standards-Version accordingly.
   * Patches to upstream sources:
     + [bin/Magick++-config.1.debdiff]
       Stray file that seems to have slipped into the previous Debian
       diffs by mistake. Removed now.
     + [magick/blob.c]
       Originally a patch from upstream, now mostly merged. Retaining a
       single hunk that upstream reverted later on, though it still looks
       correct.
     + [configure.ac, configure]
       Override location of documentation files to Debian's default
       /usr/share/doc/imagemagick. Patch to configure was present before.
       This release promotes it back to configure.ac as well. (No ill
       effects because AM_MAINTAINER_MODE is used.)
     + [coders/magick.c]
       Drop patch that exchanges upstream's logo for a DFSG-free version.
       This attempt to address #214623 (distribution of non-free logo)
       missed several ...

Read more...

Michael Vogt (mvo) wrote :

This is fixed in dapper (we have 6.2.4.5-0.6), the error was fixed in 6.2.4.5-0.1.

Changed in imagemagick:
status: Unconfirmed → Fix Released

# Hi,
#
# These bugs were fixed in an NMU, but have not been acknowledged by the
# maintainers. With version tracking in the Debian BTS, it is important
# to know which version of a package fixes each bug so that they can be
# tracked for release status, so I'm closing these bugs with the
#relevant version information now

close 215928 0.4-9.3
close 310191 0.4-9.3
close 310311 0.15.1b-2.1
close 310903 1.99.11-1.2
close 311203 0.28-1.1
close 311488 0.5.2-2.1
close 311615 1:0.7.1-1.1
close 313457 0.3.1-6.1
close 315648 0.50.0-1.2
close 316180 0.41-23.1
close 316629 1.0-8.1
close 325111 1.0-8.1
close 331790 1.0-8.1
close 316657 0.6-2.1
close 316664 9.4.2-2.3
close 317196 0.3.0+beta4-1.1
close 317219 7.8-1.1
close 317229 2.2.1-2.1
close 318123 1:5.13-2.2
close 337467 1:5.13-2.2
close 347050 1:5.13-2.2
close 318150 2.2.14-1.2
close 318176 6:6.2.4.5-0.1
close 318291 1.3.0-1.1
close 321057 1.3.0-1.1
close 349191 1.3.0-1.1
close 318540 0.8-5.1
close 318559 1.3.3-2.1
close 318569 1.2.3-2.1
close 370196 1.2.3-2.1
close 318591 0.4.5+cvs20030824-1.3
close 318633 1.1.20031017-2.1
close 318675 1.2.13-1.2
close 318827 3.8.3-4.2
close 318998 0.2.7.0-1.1
close 319073 0.3.1-2.1
close 319206 0.97.20031122-5.1
close 319432 1.0-8.1
close 319490 0.9.6-0.13
close 319666 0.02-5.1
close 331870 0.02-5.1
close 360450 0.02-5.1
close 319672 0.60-3
close 319811 1.6.0.1
close 319985 2.2.9.dfsg-1.1
close 334834 2.2.9.dfsg-1.1
close 362436 2.2.9.dfsg-1.1

Changed in imagemagick:
status: Fix Committed → Fix Released
Download full text (14.1 KiB)

Source: imagemagick
Source-Version: 7:6.2.4.5.dfsg1-1

We believe that the bug you reported is fixed in the latest version of
imagemagick, which is due to be installed in the Debian FTP archive:

imagemagick_6.2.4.5.dfsg1-1.diff.gz
  to pool/main/i/imagemagick/imagemagick_6.2.4.5.dfsg1-1.diff.gz
imagemagick_6.2.4.5.dfsg1-1.dsc
  to pool/main/i/imagemagick/imagemagick_6.2.4.5.dfsg1-1.dsc
imagemagick_6.2.4.5.dfsg1-1_i386.deb
  to pool/main/i/imagemagick/imagemagick_6.2.4.5.dfsg1-1_i386.deb
libmagick++9-dev_6.2.4.5.dfsg1-1_i386.deb
  to pool/main/i/imagemagick/libmagick++9-dev_6.2.4.5.dfsg1-1_i386.deb
libmagick++9c2a_6.2.4.5.dfsg1-1_i386.deb
  to pool/main/i/imagemagick/libmagick++9c2a_6.2.4.5.dfsg1-1_i386.deb
libmagick9-dev_6.2.4.5.dfsg1-1_i386.deb
  to pool/main/i/imagemagick/libmagick9-dev_6.2.4.5.dfsg1-1_i386.deb
libmagick9_6.2.4.5.dfsg1-1_i386.deb
  to pool/main/i/imagemagick/libmagick9_6.2.4.5.dfsg1-1_i386.deb
perlmagick_6.2.4.5.dfsg1-1_i386.deb
  to pool/main/i/imagemagick/perlmagick_6.2.4.5.dfsg1-1_i386.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Kobras <email address hidden> (supplier of updated imagemagick package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 28 Apr 2007 18:00:10 +0200
Source: imagemagick
Binary: perlmagick libmagick9 libmagick9-dev imagemagick libmagick++9-dev libmagick++9c2a
Architecture: source i386
Version: 7:6.2.4.5.dfsg1-1
Distribution: unstable
Urgency: high
Maintainer: Luciano Bello <email address hidden>
Changed-By: Daniel Kobras <email address hidden>
Description:
 imagemagick - Image manipulation programs
 libmagick++9-dev - The object-oriented C++ API to the ImageMagick library--developme
 libmagick++9c2a - The object-oriented C++ API to the ImageMagick library
 libmagick9 - Image manipulation library
 libmagick9-dev - Image manipulation library -- development
 perlmagick - A perl interface to the libMagick graphics routines
Closes: 214623 317083 318176 325651 325720 330666 333616 335111 339548 340401 344997 345238 345595 345876 347486 349264 351498 352575 358148 360362 360400 364826 381831 383314 383314 385062 386964 393025 395830 398183 401047 404477 410435 412945 417237 418057 419274 420353
Changes:
 imagemagick (7:6.2.4.5.dfsg1-1) unstable; urgency=high
 .
   * New maintainers.
   * debian/compat: Splice debhelper version out of debian/rules into
     separate file (but don't bump version).
   * debian/control: Adjust jasper dependencies to current package names.
     Closes: #419274, #420353
   * Documentation minors improvements:
     - Manpages says SEE ALSO, not SEE-ALSO. Closes: #333616
     - Escaped specials chars in manpages. Closes: #381831
     - External reference in convert(1). Closes: #398183
     -...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.