ale: unable to open image `[mangled file name]': No such file or directory.

Bug #20574 reported by Debian Bug Importer on 2005-08-30
4
Affects Status Importance Assigned to Milestone
imagemagick (Debian)
Fix Released
Unknown
imagemagick (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #325651 http://bugs.debian.org/325651

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 29 Aug 2005 03:11:43 +0200
From: Wolfgang Weisselberg <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: ale: unable to open image `[mangled file name]': No such file or directory.

Package: ale
Version: 0.7.1-1.0.1
Severity: grave
Justification: renders package unusable

$ ls -l CIMG7387.jpg
-rwxr-xr-x 1 weissel weissel 1012527 2005-08-26 22:55 CIMG7387.jpg
$ file CIMG7387.jpg
CIMG7387.jpg: JPEG image data, EXIF standard
$ ale --q0 CIMG7387.jpg ale.jpg
Output file will be 'ale.jpg'.
Reading original frame 'CIMG7387.jpg'

ale: unable to open image `.jpg': No such file or directory.

$ ale CIMG7387.jpg ale.jpg
Output file will be 'ale.jpg'.
Reading original frame 'CIMG7387.jpg'

ale: unable to open image `.jpg': No such file or directory.

$ ale ./CIMG7387.jpg ale.jpg
Output file will be 'ale.jpg'.
Reading original frame './CIMG7387.jpg'

ale: unable to open image `87.jpg': No such file or directory.

1$ ale ././././CIMG7387.jpg ale.jpg
Output file will be 'ale.jpg'.
Reading original frame '././././CIMG7387.jpg'

ale: magick/exception.c:109: CatchException: Assertion `exception->signature == 0xabacadabUL' failed.
Aborted
$

Something seems broken in the file name handling. Rebuilding from
source does not show the error any more.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (990, 'unstable'), (101, 'testing'), (99, 'stable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.4.28-lvm
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages ale depends on:
ii fftw3 3.0.1-13 library for computing Fast Fourier
ii libc6 2.3.5-4 GNU C Library: Shared libraries an
ii libfreetype6 2.1.10-1 FreeType 2 font engine, shared lib
ii libgcc1 1:4.0.1-6 GCC support library
ii libmagick6 6:6.2.3.6-3 Image manipulation library
ii libstdc++5 1:3.3.6-9 The GNU Standard C++ Library v3
ii zlib1g 1:1.2.3-3 compression library - runtime

ale recommends no packages.

-- no debconf information

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 29 Aug 2005 18:45:42 -0700
From: Steve Langasek <email address hidden>
To: Wolfgang Weisselberg <email address hidden>,
 <email address hidden>
Cc: Ryuichi Arafune <email address hidden>
Subject: Re: Bug#325490: ale: unable to open image `[mangled file name]': No such file or directory.

--VywGB/WGlW4DM4P8
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

clone 325490 -1
reassign -1 libmagick6 6:6.2.3.6-3
thanks

On Mon, Aug 29, 2005 at 03:11:43AM +0200, Wolfgang Weisselberg wrote:
> Package: ale
> Version: 0.7.1-1.0.1
> Severity: grave
> Justification: renders package unusable

> $ ale ./CIMG7387.jpg ale.jpg
> Output file will be 'ale.jpg'.
> Reading original frame './CIMG7387.jpg'
>=20
> ale: unable to open image `87.jpg': No such file or directory.

> Something seems broken in the file name handling. Rebuilding from
> source does not show the error any more.

This points to silent ABI breakage in libmagick6 (of the sort that we've
seen before, sigh). Reassigning to that package. Ryuichi, please see
to it that libmagick6's package name changes, if this is indeed a broken
ABI.

--=20
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
<email address hidden> http://www.debian.org/

--VywGB/WGlW4DM4P8
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDE7pGKN6ufymYLloRAr96AJ461herMlkuN8imc+vdUflh0c3F8wCfZ/Is
s1ITPSc3L3V5A5SVrBnYlTw=
=uzJj
-----END PGP SIGNATURE-----

--VywGB/WGlW4DM4P8--

Revision history for this message
Michael Vogt (mvo) wrote :

I can confirm that this bug affects ubuntu/breezy, rebuilding ale fixes the
problem with ale (which is universe anyway).

But if it's ABI breakage we need to look closer what other packages may be affected.

Revision history for this message
Michael Vogt (mvo) wrote :

We are also affected by:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=271673

On breezy:
$ ruby -rRMagick -e 'Magick::Image.read("apple.png")'
-e:1:in `read': unable to open image `g': No such file or directory:
(Magick::ImageMagickError)
        from -e:1

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 15:37:43 +0200
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Subject: severity of 325720 is grave, merging 325720 325651

# Automatically generated email from bts, devscripts version 2.9.5
severity 325720 grave
merge 325720 325651

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 15:58:29 +0200
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Subject: reassign 318176 to libmagick6, merging 318176 325651

# Automatically generated email from bts, devscripts version 2.9.5
reassign 318176 libmagick6
merge 318176 325651

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Marking as duplicate based on debbugs merge (318176,325651)

This bug has been marked as a duplicate of bug 20599.

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 30 Aug 2005 13:37:47 -0700
From: Steve Langasek <email address hidden>
To: <email address hidden>
Subject: reassign 318176 to libmagick6, merging 318176 325651

# Automatically generated email from bts, devscripts version 2.8.14
reassign 318176 libmagick6
merge 318176 325651

Revision history for this message
Debian Bug Importer (debzilla) wrote :
Download full text (3.7 KiB)

Message-ID: <email address hidden>
Date: Sat, 17 Sep 2005 13:30:12 +0200
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Cc: Steve Langasek <email address hidden>
Subject: Re: Proposed NMU for imagemagick soname change.

[Redirecting discussion from ale bug to cloned imagemagick bug.]

On Mon, Sep 05, 2005 at 08:35:19PM -0700, Steve Langasek wrote:
> On Mon, Sep 05, 2005 at 04:19:39PM +0200, Daniel Kobras wrote:
> > Imagemagick upstream has released a new version with bumped soname this
> > weekend. Should this version go in as soon as possible, or would
> > KDE/libsnmp benefit from a few days' delay?
>
> I think it would be a good idea to wait until GNOME 2.10 makes it into
> testing before uploading; I haven't confirmed that it makes a
> difference, but the current transitions are already complicated enough
> that I believe the caution is warranted.

Okay. Steve, now that most of Gnome appears to have made it, do we have
a go for the imagemagick soname change?

Ryuichi, I've prepared an NMU with the upstream version 6.2.4.5. It has
to go through NEW processing becaused of the changed library names, so
I'd like to get it up as soon as possible. Please let me know if you
object or prefer to do a maintainer upload. The diff between your latest
upload and my proposed NMU is quite noise because of lots of boring file
renames, so I'm not including it here. Instead, I've tried to be verbose
in the changelog. The new entries are attached below. (Version
6.2.4.4-0.1 was never uploaded.) The complete set of packages can be
found on http://people.debian.org/~kobras/imagemagick/.

Regards,

Daniel.

---[snip]---

Changes:
 imagemagick (6:6.2.4.5-0.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Yet another bump of the soname version, this time going from
       7 to 9.
   * debian/*: Cater for soname change and corresponding change of
     library packages names in multiple places.
 .
 imagemagick (6:6.2.4.4-0.1) experimental; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Version in library soname was increased from 6 to 7 due to
       changes in binary interface starting with 6.0.7. (Yes, this
       should have happened earlier.) Closes: #318176, #325651, #325720
   * debian/*: Rename packages from libmagick6 to libmagick7, and similar.
     Adjust version in various places accordingly. Drop c2 suffix from
     C++ library package.
   * debian/control: Use shlibs information to generate Depends line for
     imagemagick binary package.
   * debian/control: Remove Pre-Depends on prehistoric version of dpkg.
   * debian/control: Package complies with policy version 3.6.2. Bump
     Standards-Version accordingly.
   * Patches to upstream sources:
     + [bin/Magick++-config.1.debdiff]
       Stray file that seems to have slipped into the previous Debian
       diffs by mistake. Removed now.
     + [magick/blob.c]
       Originally a patch from upstream, now mostly merged. Retaining a
       single hunk that upstream reverted later on, though it still looks
       correct.
     + [configure.ac, configure]
       Override loca...

Read more...

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 19 Sep 2005 02:13:19 -0700
From: Steve Langasek <email address hidden>
To: Daniel Kobras <email address hidden>
Cc: <email address hidden>
Subject: Re: Proposed NMU for imagemagick soname change.

--tThc/1wpZn/ma/RB
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sat, Sep 17, 2005 at 01:30:12PM +0200, Daniel Kobras wrote:
> [Redirecting discussion from ale bug to cloned imagemagick bug.]

> On Mon, Sep 05, 2005 at 08:35:19PM -0700, Steve Langasek wrote:
> > On Mon, Sep 05, 2005 at 04:19:39PM +0200, Daniel Kobras wrote:
> > > Imagemagick upstream has released a new version with bumped soname th=
is
> > > weekend. Should this version go in as soon as possible, or would
> > > KDE/libsnmp benefit from a few days' delay?

> > I think it would be a good idea to wait until GNOME 2.10 makes it into
> > testing before uploading; I haven't confirmed that it makes a
> > difference, but the current transitions are already complicated enough
> > that I believe the caution is warranted.

> Okay. Steve, now that most of Gnome appears to have made it, do we have
> a go for the imagemagick soname change?=20

Yes, I think it should be clear now.

Cheers,
--=20
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
<email address hidden> http://www.debian.org/

--tThc/1wpZn/ma/RB
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDLoEvKN6ufymYLloRAgs5AKCwuWUHsG5PTw6I0+WLOIYCFnQeawCgx6pa
ympR6Hav3Atvy26ADtYeWKU=
=Gd7b
-----END PGP SIGNATURE-----

--tThc/1wpZn/ma/RB--

Revision history for this message
Debian Bug Importer (debzilla) wrote :
Download full text (4.3 KiB)

Message-Id: <email address hidden>
Date: Tue, 27 Sep 2005 15:03:24 -0700
From: Daniel Kobras <email address hidden>
To: <email address hidden>
Cc: Daniel Kobras <email address hidden>, Ryuichi Arafune <email address hidden>
Subject: Fixed in NMU of imagemagick 6:6.2.4.5-0.1

tag 318176 + fixed
tag 325651 + fixed
tag 325720 + fixed

quit

This message was generated automatically in response to a
non-maintainer upload. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 17 Sep 2005 01:00:09 +0200
Source: imagemagick
Binary: perlmagick libmagick9 libmagick++9 libmagick9-dev imagemagick libmagick++9-dev
Architecture: source i386
Version: 6:6.2.4.5-0.1
Distribution: unstable
Urgency: low
Maintainer: Ryuichi Arafune <email address hidden>
Changed-By: Daniel Kobras <email address hidden>
Description:
 imagemagick - Image manipulation programs
 libmagick++9 - The object-oriented C++ API to the ImageMagick library
 libmagick++9-dev - The object-oriented C++ API to the ImageMagick library--developme
 libmagick9 - Image manipulation library
 libmagick9-dev - Image manipulation library -- development
 perlmagick - A perl interface to the libMagick graphics routines
Closes: 318176 325651 325720
Changes:
 imagemagick (6:6.2.4.5-0.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Yet another bump of the soname version, this time going from
       7 to 9.
   * debian/*: Cater for soname change and corresponding change of
     library packages names in multiple places.
 .
 imagemagick (6:6.2.4.4-0.1) experimental; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Version in library soname was increased from 6 to 7 due to
       changes in binary interface starting with 6.0.7. (Yes, this
       should have happened earlier.) Closes: #318176, #325651, #325720
   * debian/*: Rename packages from libmagick6 to libmagick7, and similar.
     Adjust version in various places accordingly. Drop c2 suffix from
     C++ library package.
   * debian/control: Use shlibs information to generate Depends line for
     imagemagick binary package.
   * debian/control: Remove Pre-Depends on prehistoric version of dpkg.
   * debian/control: Package complies with policy version 3.6.2. Bump
     Standards-Version accordingly.
   * Patches to upstream sources:
     + [bin/Magick++-config.1.debdiff]
       Stray file that seems to have slipped into the previous Debian
       diffs by mistake. Removed now.
     + [magick/blob.c]
       Originally a patch from upstream, now mostly merged. Retaining a
       single hunk that upstream reverted later on, though it still looks
       correct.
     + [configure.ac, configure]
       Override location of documentation files to Debian's default
       /usr/share/doc/imagemagick. Patch to configure was present before.
       This release promotes it back to configure.ac as well. (No ill
       effects because AM_MAINTAINER_MODE is used.)
     + [coders/magick.c]
       Drop patch that exchanges upstream's logo for a DFSG-free version.
       This attempt to address #214623 (distribution of non-free logo)
       missed several ...

Read more...

Changed in imagemagick:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.