Duplicate Imagemagick entries on menu

Bug #1549732 reported by David Pearson on 2016-02-25
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
imagemagick (Debian)
Fix Released
Unknown
imagemagick (Ubuntu)
Low
Unassigned
Xenial
Undecided
Unassigned
ubuntustudio-menu (Ubuntu)
Low
Ross Gammon
Xenial
Undecided
Unassigned

Bug Description

Duplicate entries for Imagemagick on Whisker menu.. One with an icon, the other without.. Neither launches the program.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: imagemagick 8:6.8.9.9-7
ProcVersionSignature: Ubuntu 4.4.0-7.22-generic 4.4.2
Uname: Linux 4.4.0-7-generic i686
ApportVersion: 2.20-0ubuntu3
Architecture: i386
CasperVersion: 1.367
CurrentDesktop: XFCE
Date: Thu Feb 25 10:36:51 2016
LiveMediaBuild: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha i386 (20160224)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: imagemagick
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

David Pearson (akxwi-dave) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1549732

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in imagemagick (Ubuntu):
status: New → Confirmed
Nairwolf (nairwolf) wrote :

This bug is also present on the Xubuntu Xenial Beta 1 (amd64)

Paul White (paulw2u) wrote :

imagemagick can be started with the command /usr/bin/display-im6. The settings in Xubuntu's Whisker menu are wrong and nothing to do with the application itself.

Will reassign bug to xubuntu-default -settings.

tags: added: amd64
affects: imagemagick (Ubuntu) → xubuntu-default-settings (Ubuntu)
Kev Bowring (flocculant) on 2016-02-26
summary: - Duplcate Imagemagick entries on menu, none work
+ Duplicate Imagemagick entries on menu, none work
Changed in xubuntu-default-settings (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium

The problem is that imagemagick has two desktop files. There is the Q8 default version, and the Q16 version.

In Debian, the Q16 desktop file has been deleted in the new version of imagemagick currently sitting in experimental.

This will leave only one entry in the menu. The full program is always available on the command line.

We should probably follow this in Ubuntu.

affects: xubuntu-default-settings (Ubuntu) → imagemagick (Ubuntu)
Changed in imagemagick (Ubuntu):
assignee: nobody → Ross Gammon (retail-0)
Ross Gammon (rosco2) wrote :

Actually, the extra desktop file display-im6.desktop (imagemagick package) contains an executable which is just a symlink to the same binary as the display-im6.q16.desktop (imagemagick-6.q16 package).

The icon doesn't show because there is a Spelling error "Icon: display-im6.Q16" instead of "Icon: display-im6.q16", but even if this was fixed, a link to the icon in the imagemagick-6.q16 package is missing.

As they both point at the same binary (duplicate), I have altered the imagemagick.install file so that the desktop file with the missing icon is not installed.

Please see Bug #1550210 for the patch that fixes both this bug and that bug.

Ross Gammon (rosco2) wrote :

OK. We can fix the duplicate menu thing ourselves, by updating ubuntustudio-menu. I have pushed a fix to the source bzr branch for that.

On Bug #1550210, I will reduce the patch down to just fixing the execution problem by settining Terminal=true in the desktop file. Hopefully it will be easier to find a sponsor then.

Changed in imagemagick (Ubuntu):
assignee: Ross Gammon (retail-0) → nobody
Changed in ubuntustudio-menu (Ubuntu):
assignee: nobody → Ross Gammon (retail-0)
Changed in imagemagick (Ubuntu):
importance: Medium → Low
Changed in ubuntustudio-menu (Ubuntu):
importance: Undecided → Low
summary: - Duplicate Imagemagick entries on menu, none work
+ Duplicate Imagemagick entries on menu
Changed in imagemagick (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntustudio-menu (Ubuntu):
status: New → Confirmed
Ross Gammon (rosco2) on 2016-04-04
Changed in ubuntustudio-menu (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-menu - 0.25

---------------
ubuntustudio-menu (0.25) xenial; urgency=medium

  [ Krytarik Raido ]
  * Fix Ubuntu Studio menu items up a bit.

 -- Kaj Ailomaa <email address hidden> Mon, 11 Apr 2016 19:17:40 +0200

Changed in ubuntustudio-menu (Ubuntu):
status: Fix Committed → Fix Released
Robert Orzanna (orschiro) wrote :

Dear all,

The bug still exists in Ubuntu 16.04.

warren (wkclemmons) wrote :

This bug also effects Ubuntu 15.10 wily 4.2.0-36-generic.

Jb (jebsolutions) wrote :

This bug still exists in Lubuntu 16.10 daily image dated 2016-Aug-14.

Paul White (paulw2u) on 2016-08-15
tags: added: yakkety
Changed in imagemagick (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: Confirmed → Fix Released
ineuw (ineuw) wrote :

I also have a problem with ImageMagick in Menulibre. It installs two menu entries in the Graphics section, but they are both hidden. Changing the Menulibre to expose the shortcut, does not work. I think that the entries are missing some category assignements.

On Wed, 26 Oct 2016, ineuw wrote:

> I also have a problem with ImageMagick in Menulibre. It installs two
> menu entries in the Graphics section, but they are both hidden. Changing
> the Menulibre to expose the shortcut, does not work. I think that the
> entries are missing some category assignements.

It is not recomended to use Menulibre as it will not allow your user to
see menu updates such as a fix for this problem. So far as I know
Menulibre also uses the stock xfce *menu file which is broken and not used
in ubuntustudio. XFCE are not interested in fixing this file and have
marked it as not a bug.

They are hidden because they do not work. They are installed if we want
them or not by the ImageMagick package which is a depend of another
package we do want. But the menu entrys don't work so we have hidden them
so as not to break package upgrading.

--
Len Ovens
www.ovenwerks.net

ineuw (ineuw) wrote :

Thanks for the info. It's much appreciated. I will pursue the issue with xfce.

Mathew Hodson (mathew-hodson) wrote :

This hasn't been fixed in any released package for Ubuntu. It might be fixed in imagemagick 8:6.9.6.6+dfsg-1ubuntu2, which is in zesty-proposed.

Changed in imagemagick (Ubuntu):
status: Fix Released → Fix Committed
Mathew Hodson (mathew-hodson) wrote :

Fixed in Zesty with imagemagick (8:6.9.6.2+dfsg-2ubuntu1) merged from Debian unstable (LP: #1645406) , which included this change:

imagemagick (8:6.9.2.10+dfsg-2) experimental; urgency=medium

  * Drop imagemagick binary package. Paving the way to multiple
  channel depth binaries and HDRI. Fix also multi-arch problems
  (Closes: #761836, #810591, #772603).
  * Fix desktop file (Closes: #812481).
  * Simplify debian/rules
  * Fix a mistake for installing config files.

 -- Bastien Roucariès <email address hidden> Sat, 30 Jan 2016 18:50:09 +0100

Changed in imagemagick (Ubuntu):
status: Fix Committed → Fix Released

Still having this problem with latest LTS.

Lubuntu 16.04 LTS 64 bit up-to-date

imagemagick-6.q16_6.9.7.4+dfsg-3ubuntu1.2_amd64.deb Zesty (17.04) package contains one desktop file with the following line:

Exec=/usr/bin/display-im6.q16 -nostdin %F

In my 16.04 LTS I tried (as possible work-around):

$ /usr/bin/display-im6 -nostdin
display-im6: unrecognized option `-nostdin' @ error/display.c/DisplayImageCommand/1426.

Not working!

It works only seeting Terminal=true as suggested at #8
( https://bugs.launchpad.net/ubuntu/+source/imagemagick/+bug/1549732/comments/8 )

But not nice having an open terminal...

Łukasz Zemczak (sil2100) wrote :

This is still a problem in the current xenial mythbuntu 16.04.3 release candidate images. Nominating for xenial.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.