ImageMagick is missing JPEG2000 support (needs to be built with openjpeg)

Bug #1447968 reported by Stanislav Bocinec on 2015-04-24
124
This bug affects 25 people
Affects Status Importance Assigned to Milestone
imagemagick (Debian)
Fix Released
Unknown
imagemagick (Ubuntu)
Medium
Unassigned

Bug Description

ImageMagick had been always built with JPEG2000 support ("JPEG-2000 --with-jp2=yes yes"). Since Vivid Vervet's 8:6.8.9.9-5 version it's not more built with jp2 support thus it lost the support to work with JPEG2000 images ("JPEG-2000 --with-jp2=").

This is pretty annoying, as JPEG 2000 is pretty popular lossless format.

$ identify -version
Version: ImageMagick 6.8.9-9 Q16 x86_64 2015-01-06 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2014 ImageMagick Studio LLC
Features: DPC Modules OpenMP
Delegates: bzlib djvu fftw fontconfig freetype jbig jng jpeg lcms lqr ltdl lzma openexr pangocairo png tiff wmf x xml zlib

$ identify pic.jp2
identify: no decode delegate for this image format `JP2' @ error/constitute.c/ReadImage/501.

$ file pic.jp2
pic.jp2: JPEG 2000 Part 1 (JP2)

$ convert pic.jp2 pic.png
convert: no decode delegate for this image format `JP2' @ error/constitute.c/ReadImage/501.
convert: no images defined `pic.png' @ error/convert.c/ConvertImageCommand/3210.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 15.04
Release: 15.04
Codename: vivid

$ uname -a
Linux ubo1504 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ dpkg -l |grep imagemagick
ii imagemagick 8:6.8.9.9-5 amd64 image manipulation programs -- binaries
ii imagemagick-6.q16 8:6.8.9.9-5 amd64 image manipulation programs -- quantum depth Q16
ii imagemagick-common 8:6.8.9.9-5 all image manipulation programs -- infrastructure

Thanks for fixing this.

tags: added: vivid
description: updated
Changed in imagemagick (Ubuntu):
status: New → Confirmed
Changed in imagemagick (Ubuntu):
importance: Undecided → Critical
importance: Critical → High
Changed in imagemagick (Debian):
status: Unknown → Fix Committed
Changed in imagemagick (Debian):
status: Fix Committed → Fix Released
tags: added: regression-release
Changed in imagemagick (Ubuntu):
status: Confirmed → Triaged
rew (r-e-wolff) wrote :

Also affects XENIAL.

I tried compiling from source: Resulting binary: no JP2 support.

Then I installed "libopenjp2-dev" and built again. Now I do have jp2 support.

So the problem is that the imagmagick upstream releas has switched to prefer libopenjp2 instead of libjasper, while the ubuntu build procedure lists libjasper-dev as a build requirement instead of libopenjp2.

Changed in imagemagick (Ubuntu):
importance: High → Medium
tags: added: packaging
tags: added: xenial
Cory Albrecht (bytor) wrote :

Add me to the list for whom this is annoying. ImageMagick switch from libjasper to libopenjp2 two years ago, and the Debian upstream packages was fixed a year ago, so why is this not fixed on Ubuntu yet?

Mathew Hodson (mathew-hodson) wrote :

The reason this has not been fixed is because imagemagick is in main, so all of its build-deps must be in main. openjpeg2 is not in main so that needs to get put in main first.

There is a main inclusion request in bug 711061, so hopefully we can see this fixed in the future.

summary: - ImageMagick lost JPEG2000 support in Vivid Vervet
+ ImageMagick is missing JPEG2000 support (needs to be built with
+ openjpeg)
Sam Wilson (samwilson.id.au) wrote :

Is there a workaround that will get JP2 support working?

tags: added: bionic
tags: added: cosmic
Earle Lyons (earlev4) wrote :

Hi. Are there any updates to ImageMagick JP2 support? Thanks!

Stefan Horning (stefan-horning) wrote :

Looks like bug #711061 is still blocking it

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.