Unable to start images installed/registered via the image store

Bug #446841 reported by Mathias Gug
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eucalyptus (Ubuntu)
High
Unassigned
Karmic
High
Unassigned
image-store-proxy (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

While trying to start an image installed via the image store, the instantiation fails:

ubuntu@cluster:~$ euca-describe-images
IMAGE eri-1DD71D9F image-store/58172e71f52f9fd0f216ef38351f2c5426fedf74a397b8040890cf0efcf3916d.manifest.xml admin available public x86_64 ramdisk
IMAGE emi-1DD31D99 image-store/58172e71f52f9fd0f216ef38351f2c5426fedf74a397b8040890cf0efcf3916d.manifest.xml admin available public x86_64 machine
IMAGE eki-02141D26 image-store/b259e8492c114013884bf73fc9c2a491e4688a4b2e183c55bc379eb1427d2a5e.manifest.xml admin available public x86_64 kernel
ubuntu@cluster:~$ euca-run-instances -k mykey emi-1DD31D99
RESERVATION None None
ubuntu@cluster:~$

Here is the cloud-error.log entry:

19:37:58 [ImageManager:ImageVerify.7] ERROR com.eucalyptus.util.EucalyptusCloudException: Manifest signature has changed since registration.
19:37:58 [ImageManager:ImageVerify.7] ERROR Failed bukkit check! Invalidating registration: image-store/58172e71f52f9fd0f216ef38351f2c5426fedf74a397b8040890cf0efcf3916d.manifest.xml
19:37:58 [DefaultServiceExceptionStrategy:ImageVerify.7] ERROR
********************************************************************************
Message : Component that caused exception is: ImageVerify. Message payload is of type: VmAllocationInfo
Type : org.mule.api.service.ServiceException
Code : MULE_ERROR--2
Payload : edu.ucsb.eucalyptus.cloud.VmAllocationInfo@1b217767
JavaDoc : http://mule.mulesource.org/docs/apidocs/org/mule/api/service/ServiceException.html
********************************************************************************
Exception stack is:
1. Failed check! Invalidating registration: image-store/58172e71f52f9fd0f216ef38351f2c5426fedf74a397b8040890cf0efcf3916d.manifest.xml (com.eucalyptus.util.EucalyptusCloudException)
  com.eucalyptus.images.util.ImageUtil:222 (null)
2. Component that caused exception is: ImageVerify. Message payload is of type: VmAllocationInfo (org.mule.api.service.ServiceException)
  org.mule.component.DefaultLifecycleAdapter:214 (http://mule.mulesource.org/docs/apidocs/org/mule/api/service/ServiceException.html)
********************************************************************************
Root Exception stack trace:
com.eucalyptus.util.EucalyptusCloudException: Failed check! Invalidating registration: image-store/58172e71f52f9fd0f216ef38351f2c5426fedf74a397b8040890cf0efcf3916d.manifest.xml
        at com.eucalyptus.images.util.ImageUtil.checkStoredImage(ImageUtil.java:222)
        at edu.ucsb.eucalyptus.cloud.ws.ImageManager.verify(ImageManager.java:231)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at org.mule.model.resolvers.AbstractEntryPointResolver.invokeMethod(AbstractEntryPointResolver.java:147)
        at org.mule.model.resolvers.ReflectionEntryPointResolver.invoke(ReflectionEntryPointResolver.java:127)
        at org.mule.model.resolvers.DefaultEntryPointResolverSet.invoke(DefaultEntryPointResolverSet.java:50)
        at org.mule.component.DefaultLifecycleAdapter.intercept(DefaultLifecycleAdapter.java:202)
        at org.mule.component.AbstractJavaComponent.invokeComponentInstance(AbstractJavaComponent.java:82)
        at org.mule.component.AbstractJavaComponent.doOnCall(AbstractJavaComponent.java:73)
        at org.mule.component.AbstractComponent.onCall(AbstractComponent.java:87)
        at org.mule.model.seda.SedaService$ComponentStageWorker.run(SedaService.java:533)
        at org.mule.work.WorkerContext.run(WorkerContext.java:310)
        at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1061)
        at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:575)
        at java.lang.Thread.run(Thread.java:636)

********************************************************************************

19:37:58 [DefaultServiceExceptionStrategy:ImageVerify.7] ERROR Message being processed is: org.mule.transport.DefaultMessageAdapter/org.mule.transport.DefaultMessageAdapter@3226191b{id=fe01935b-b46b-11de-a813-95eb8fc70e03, payload=edu.ucsb.eucalyptus.cloud.VmAllocationInfo, correlationId=fe01935b-b46b-11de-a813-95eb8fc70e03, correlationGroup=-1, correlationSeq=-1, encoding=UTF-8, exceptionPayload=org.mule.message.DefaultExceptionPayload@633a5555}

Revision history for this message
Mathias Gug (mathiaz) wrote :

Not sure if this is an issue with eucalyptus.

Changed in image-store-proxy (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-9.10
Changed in eucalyptus (Ubuntu Karmic):
importance: Undecided → High
status: New → Incomplete
Revision history for this message
Daniel Nurmi (nurmi) wrote :

Niemeyer and I tracked down the issue, which ended up being that the manifest set by the image store proxy for both the ERI and EMI was identical.

Revision history for this message
Thierry Carrez (ttx) wrote :

If I understand last comment correctly, the issue is located into image-store-proxy only. Please reopen if I got it wrong.

Changed in eucalyptus (Ubuntu Karmic):
status: Incomplete → Invalid
tags: added: eucalyptus
Revision history for this message
Mathias Gug (mathiaz) wrote :

Fixed in 1.0.4. See bug 451294.

Changed in image-store-proxy (Ubuntu Karmic):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers