im-config should not use ".xsession-errors" file for informational messages

Bug #1375089 reported by Սահակ on 2014-09-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
im-config (Ubuntu)
Low
Unassigned

Bug Description

currenty ibus leaves the following informational message in the ".xsession-errors" file:

"Script for ibus started at run_im."

".xsession-errors" file should be used only for error messages and not for informational messages.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ibus 1.5.8-2ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-17.23-generic 3.16.3
Uname: Linux 3.16.0-17-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CasperVersion: 1.344
CurrentDesktop: Unity
Date: Mon Sep 29 02:10:46 2014
LiveMediaBuild: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140923)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ibus
UpgradeStatus: No upgrade log present (probably fresh install)

Սահակ (petrosyan) wrote :
Aron Xu (happyaron) on 2014-09-29
affects: ibus (Ubuntu) → im-config (Ubuntu)
Սահակ (petrosyan) on 2014-09-29
summary: - ibus should not use ".xsession-errors" file for informational messages
+ im-config should not use ".xsession-errors" file for informational
+ messages
osamu (osamu) wrote :

STDOUT is output for piping data and im-config uses it for that purpose.

Errors and informational context messages should go to STDERR.

.xsession-errors just record everything on STDERR. (im-config does not set file name.)

If you have reference which supports your view of this being bug, please file bug in Debian.

By the way, I do not see .xsession-errors in my home directory anymore on my jessie(Debian).

Osamu

Սահակ (petrosyan) wrote :

Osamu,

when I run

$ more .xsession-errors

On Ubuntu 14.04 or Ubuntu 14.10 I get the following messages:
----------------------------------------------------------
Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
-----------------------------------------------------------

I am not sure which package creates these messages but they clearly don't belong in .xsession-errors file.

Do you know which package is responsible?

On Sun, Oct 12, 2014 at 08:47:29PM -0000, Սահակ wrote:
> Osamu,
>
> when I run
>
> $ more .xsession-errors
>
> On Ubuntu 14.04 or Ubuntu 14.10 I get the following messages:
> ----------------------------------------------------------
> Script for ibus started at run_im.
> Script for auto started at run_im.
> Script for default started at run_im.
> -----------------------------------------------------------
>
> I am not sure which package creates these messages but they clearly
> don't belong in .xsession-errors file.

??? why? It record any STDERR out put from programs started in
xsession.

> Do you know which package is responsible?

im-config

This way, we can track down what program was executed in user's system
when I get bug report.

Please re-read what I wrote, too.

Regards,

Osamu

Aron Xu (happyaron) wrote :

> On Oct 13, 2014, at 08:56, osamu <email address hidden> wrote:
>
>> On Sun, Oct 12, 2014 at 08:47:29PM -0000, Սահակ wrote:
>> Osamu,
>>
>> when I run
>>
>> $ more .xsession-errors
>>
>> On Ubuntu 14.04 or Ubuntu 14.10 I get the following messages:
>> ----------------------------------------------------------
>> Script for ibus started at run_im.
>> Script for auto started at run_im.
>> Script for default started at run_im.
>> -----------------------------------------------------------
>>
>> I am not sure which package creates these messages but they clearly
>> don't belong in .xsession-errors file.
>
> ??? why? It record any STDERR out put from programs started in
> xsession.
>
>> Do you know which package is responsible?
>
> im-config
>
> This way, we can track down what program was executed in user's system
> when I get bug report.
>
> Please re-read what I wrote, too.
>

I think it's better to avoid such informative messages by default but
add the possibility of enabling it. In my understanding
.session-errors should record stuff that's at least Warning priority
level and the output from im-config doesn't fit into the category
well..

Just 2 cents.

osamu (osamu) wrote :

HI

On Tue, Oct 14, 2014 at 03:22:47AM -0000, Aron Xu wrote:
> I think it's better to avoid such informative messages by default but
> add the possibility of enabling it.
          ^^^^^^^^^^^^^^^^^^^^^^^^^^

Patch welcome

osamu (osamu) wrote :

On Tue, Oct 14, 2014 at 03:22:47AM -0000, Aron Xu wrote:
> I think it's better to avoid such informative messages by default but
> add the possibility of enabling it.

OK, I fixed this.

Maybe, we should also discuss desktop file for Ubuntu.

Osamu

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2014-10-15 15:32, osamu wrote:
> On Tue, Oct 14, 2014 at 03:22:47AM -0000, Aron Xu wrote:
>> I think it's better to avoid such informative messages by default but
>> add the possibility of enabling it.
>
> OK, I fixed this.

Thanks, Osamu!

> Maybe, we should also discuss desktop file for Ubuntu.

Are you referring to bug #1342677?

osamu (osamu) wrote :

On Wed, Oct 15, 2014 at 01:46:59PM -0000, Gunnar Hjalmarsson wrote:
> On 2014-10-15 15:32, osamu wrote:
> > On Tue, Oct 14, 2014 at 03:22:47AM -0000, Aron Xu wrote:
> >> I think it's better to avoid such informative messages by default but
> >> add the possibility of enabling it.
> >
> > OK, I fixed this.
>
> Thanks, Osamu!
>
> > Maybe, we should also discuss desktop file for Ubuntu.
>
> Are you referring to bug #1342677?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1375089

Yes.

Changed in im-config (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package im-config - 0.27-1ubuntu1

---------------
im-config (0.27-1ubuntu1) vivid; urgency=low

  * Merge with Debian unstable, remaining Ubuntu changes:
    - debian/im-config.user-session.upstart
    - debian/rules:
      - Additional "cd $(CURDIR) ; \" in the Ubuntu specific code
      - Install upstart job script
    - debian/postinst: Additional condition to be met to edit
      80im-switch.

im-config (0.27-1) unstable; urgency=medium

  * Make STDERR output less verbose as default. LP: #1375089
  * Customize desktop file for Ubuntu. LP: #1342677
 -- Gunnar Hjalmarsson <email address hidden> Tue, 28 Oct 2014 14:11:00 +0100

Changed in im-config (Ubuntu):
status: In Progress → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

Re-opening this bug, since the fix does not work as intended.

An empty shell variable returns true in a boolean context - please see patch.

Changed in im-config (Ubuntu):
assignee: Gunnar Hjalmarsson (gunnarhj) → nobody
status: Fix Released → Triaged
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package im-config - 0.29-1ubuntu2

---------------
im-config (0.29-1ubuntu2) vivid; urgency=medium

  * Fix installation directory in rules.
 -- Aron Xu <email address hidden> Mon, 23 Mar 2015 15:01:16 +0800

Changed in im-config (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers