ilmbase symbols files were dropped by the forced merge

Bug #1770748 reported by Matthias Klose on 2018-05-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ilmbase (Debian)
Confirmed
Unknown
ilmbase (Ubuntu)
Undecided
Unassigned

Bug Description

the last ilmbase forced sync dropped the ilmbase symbols files "just for convenience", because maintenance apparently costs too much effort. So we are dropping the patches which we required for the package to be in main.

I don't think this is a sensible move, and the symbol files should be re-added before the package migrates to the release pocket.

I also think that the behavior of "delegating" these changes to another maintenance team is inappropriate.

Setting the block-proposed flag for now, until the symbol filed are re-added again.

Matthias Klose (doko) on 2018-05-11
description: updated
Jeremy Bicha (jbicha) wrote :

Could the Foundations Team please take over maintenance of ilmbase?

ilmbase was added to main with LP: #240943. It is only in main because of imagemagick (via openexr) and the Foundations Team maintains imagemagick.

There is nothing the Ubuntu Desktop Team needs from ilmbase and the Ubuntu Desktop Team is not interested in manually maintaining C++ symbols across architectures every time Debian wants to update this package.

Also, if having a symbols file is indeed Required for inclusion in main even for C++ packages, it ought to be added to https://wiki.ubuntu.com/MainInclusionRequirements

I understand that force syncing ilmbase today so quickly looks bad, but it was able to clean up the 20+ openexr reverse dependencies that failed to build because the new openexr version required ilmbase to be updated.

Jeremy Bicha (jbicha) wrote :

I suggested on #ubuntu-devel today that a compromise that might be acceptable for Debian while addressing the API stability concerns would be to have a symbols file only for amd64.

Changed in ilmbase (Debian):
status: Unknown → Confirmed
Rik Mills (rikmills) wrote :

Well, someone needs to act here, as this is blocking openexr transition and packages which depend on it.

Matthias Klose (doko) wrote :

yes, the package owner should update the symbols file for all architectures to restore the status from the release pocket.

I'm adding that issue to the agenda of the next technical board meeting.

Rik Mills (rikmills) wrote :

Builds ok in my PPA with no symbols errors.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ilmbase (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Rik, thanks for your debdiff. I uploaded it to cosmic so we can unblock these transitions.

It still would be interesting to get answers to the two questions about ilmbase maintainership in Ubuntu and whether symbols files are mandatory for C++ libraries in main, but let's not block things for that.

Changed in ilmbase (Ubuntu):
status: Confirmed → Fix Committed
tags: added: cosmic
removed: block-proposed
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ilmbase - 2.2.1-2ubuntu1

---------------
ilmbase (2.2.1-2ubuntu1) cosmic; urgency=medium

  * Restore and update symbols file (LP: #1770748)

 -- Rik Mills <email address hidden> Sun, 20 May 2018 22:21:41 +0100

Changed in ilmbase (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.