ntpdate not being executed at boot time

Bug #82774 reported by Colin Smith on 2007-02-02
4
Affects Status Importance Assigned to Milestone
ifupdown (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: upstart

strange. I have an ubuntu server system with static IP address and when it boots, ntpdate doesn't seem to be called.

when I run /etc/init.d/networking start it does call ntpdate as part of if-up... How is the interface being configured then at boot if not through the init script?

It seems to be something to do with an init system called upstart, but I can't find any configuration information, useful man pages or even anything handy through google on setting it up.

At a guess, upstart is running /etc/event.d/rc-default which is falling through to an emulated runlevel of 2... Which doesn't link to /etc/init.d/networking... Which would explain the networking init script not being executed... So how is the interface being configured at all?

System is the current 6.10 server install.

Linux version 2.6.17-10-server (root@terranova) (gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)) #2 SMP Tue Dec 5 22:29:32 UTC 2006 (Ubuntu 2.6.17-10.34-server)

Wired connection was configured through System->Administration->Networking->Network Settings.

It does work while configured for DHCP btw.

networking is called from rcS, which upstart does run (otherwise your network interface would not have come up at all!)

Attach /var/log/boot and /etc/resolv.conf

Changed in ifupdown:
status: Unconfirmed → Needs Info

No response to requested information, and this works for most people.

Changed in ifupdown:
status: Needs Info → Rejected
AirOne (airone-k) wrote :

I'm experiencing exactly the same problem on dapper 6.06 LTS server.

Although when i run /et/init.d/networking restart manually or ifdown -a && ifup -a after init ntpdate is always called

Strange...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers