Upgrading ifupdown from lucid to maverick creates two spurious debconf questions

Bug #620956 reported by Mark Shuttleworth on 2010-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ifupdown (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ifupdown

During several Lucid->Maverick upgrades I've been asked two debconf replacement questions about conf files from ifupdown. In none of those cases had I personally modified the configuration files. Please can we identify this situation and make sure people aren't prompted in this way for a change they never made themselves?

Related branches

Michael Vogt (mvo) on 2010-08-30
Changed in ifupdown (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-10.10-beta
Michael Vogt (mvo) wrote :

I can reproduce this in the auto-upgrade testing setup. It appears the package did not have conffiles in
lucid but in maverick it does. That triggers a dpkg conffile prompt, here is the output with debug enabled:

Setting up ifupdown (0.6.10ubuntu2) ...
D000200: conffderef in='/etc/network/if-up.d/upstart' current working='/etc/network/if-up.d/upstart'

Configuration file `/etc/network/if-up.d/upstart'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
 The default action is to keep your current version.
*** upstart (Y/I/N/O/D/Z) [default=N] ?

Michael Vogt (mvo) wrote :

This change got triggered by the merge from debian and the removal of:

-# This is the debhelper compatability version to use.
-export DH_COMPAT=1

Michael Vogt (mvo) wrote :

There is another one for /etc/init/network-interface.conf

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ifupdown - 0.6.10ubuntu3

---------------
ifupdown (0.6.10ubuntu3) maverick; urgency=low

  * debian/ifupdown.preinst: since files in /etc were not conffiles in
    lucid, and /etc/network/if-up.d/upstart and
    /etc/init/network-interface.conf changed between lucid final and
    maverick, add extra handling to avoid spurious conffile prompts.
    LP: #620956.
 -- Steve Langasek <email address hidden> Tue, 31 Aug 2010 02:11:35 +0000

Changed in ifupdown (Ubuntu):
status: Triaged → Fix Released

Thanks Michael, you rock! The upgrade process is hugely important for
us, 70% of Maverick users will be upgrades, so thanks for your attention
to detail :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers