Please merge ifscheme 1.7-3(universe) from debian unstable(main)

Bug #592533 reported by Bhavani Shankar on 2010-06-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ifscheme (Debian)
Fix Released
Unknown
ifscheme (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ifscheme

Debian Changelog

 ifscheme (1.7-3) unstable; urgency=low
 .
   * Adopt 3.0 (quilt) format.
   * Bump Standards-Version.
   * Create /var/lib/ifscheme if it doesn't exist, and
   * Make sure the init script is also called when rebooting. Closes: #429481
   * Mention to use the full pathname to the ifscheme-mapping script in
     /etc/network/interfaces. Closes: #542219
   * Use dh_prep instead of dh_clean -k.

Related branches

Bhavani Shankar (bhavi) wrote :
Changed in ifscheme (Ubuntu):
status: New → Confirmed
Fabrice Coutadeur (fabricesp) wrote :

Hi,

Could you please submit the fix for #160585 to Debian? I'd say that Debian is also affected by this bug, so it should also be fixed there. However, the /var/run stuff is Ubuntu specific, and should be kept.

Thanks,
Fabrice

Changed in ifscheme (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
status: Confirmed → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Hi,

Debian switched to debsrc3.0, so you should be using the existing patch system, and not do direct update (you'll see in your debdiff that a patch has been automaticall created). Please update your debdiff to do so.

Subscribe again sponsors when you have a debdiff to sponsor.

Thanks,
Fabrice

Changed in ifscheme (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
status: In Progress → Incomplete
Bhavani Shankar (bhavi) wrote :

yes fabrice noticed that

On it now

Regards

Changed in ifscheme (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Bhavani Shankar (bhavi)
Fabrice Coutadeur (fabricesp) wrote :

any news? Is it really worth a merge?

tags: added: patch
Bhavani Shankar (bhavi) wrote :

I ve mailed the Debian Maintainer requesting him to add my patch but so far there is no news from him yet

Please wait a couple of days as I ll ping again tonight and try to get it fixed

regards

Bhavani Shankar (bhavi) wrote :

Hmm no response from the deb maint even after reporting a bug as per his request

Will work on merge tomorrow

regards

Changed in ifscheme (Debian):
status: Unknown → New
Bhavani Shankar (bhavi) wrote :

Hi fabrice,

here is the updated merge diff

Changed in ifscheme (Ubuntu):
status: In Progress → Confirmed
assignee: Bhavani Shankar (bhavi) → nobody
Changed in ifscheme (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
status: Confirmed → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Hi,

That's better, but I miss a DEP-5 header in both patches (the Description field is mandatory). Otherwise, looks good.

Thanks,
Fabrice

Changed in ifscheme (Ubuntu):
status: In Progress → Incomplete
Fabrice Coutadeur (fabricesp) wrote :

This is obviously a DEP-3 header that is missing in the patches...

Changed in ifscheme (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
Bhavani Shankar (bhavi) wrote :

hello fabrice,

here is the updated diff

regards

Changed in ifscheme (Ubuntu):
status: Incomplete → Confirmed
Changed in ifscheme (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ifscheme - 1.7-3ubuntu1

---------------
ifscheme (1.7-3ubuntu1) maverick; urgency=low

  * Merge from debian unstable. Remaining changes: LP: #592533
    o Split out changes due to new quilt format:
      - ifscheme-correct-state.diff:
        + Corrected new ifstate and scheme location
      - ifscheme-mapping.diff
        + Change /etc/network/run/scheme > /etc/network/scheme in
          ifscheme-mapping also closes LP: #160585, LP: #376641
          (Forwarded as DBTS: #589193)
 -- Bhavani Shankar <email address hidden> Sun, 25 Jul 2010 19:39:42 +0530

Changed in ifscheme (Ubuntu):
status: Fix Committed → Fix Released
Changed in ifscheme (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.