Documents in swiss-french are not spell checked

Bug #139570 reported by Jonathan Ernst on 2007-09-14
4
Affects Status Importance Assigned to Milestone
ifrench (Ubuntu)
Undecided
François Marier
Nominated for Intrepid by Jonathan Ernst
ifrench-gut (Debian)
Fix Released
Unknown
ifrench-gut (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Jonathan Ernst
openoffice.org-dictionaries (Ubuntu)
Undecided
François Marier
Nominated for Intrepid by Jonathan Ernst

Bug Description

When installing Ubuntu using fr-CH locale, spellchecking won't work out of the box in OpenOffice.org. After you selected default language as French (France) in OpenOffice, you'll have correct spell checking for new documents, but documents created for example using Microsoft Word with swiss-french locale won't be spell checked until you change the document's language which is really painful.

myspell-fr should register itself as swiss french dictionnary as well (it does for Canada and Belgium apparently)

François Marier (fmarier) wrote :

Hi Jonathan,

I have uploaded a new version of the package to Debian unstable. It should fix this problem, but it would be great if you could confirm that.

I've made a version for gutsy and it's in my personal package archive at:

  deb http://ppa.launchpad.net/fmarier/ubuntu gutsy main

If you confirm that it works for you, then I will request a sync to be made so that the package makes it into the next stable Ubuntu release.

Thanks.

Francois

Jonathan Ernst (jonathan.ernst) wrote :

Hello François,

Thanks for working on this bug !

I have added your ppa in my sources.list but I have not been presented with any update. Maybe your package version number is lower than the one in the default repositories ?

What package have you modified exactly ? myspell-fr, ifrench ?

Best regards.

François Marier (fmarier) wrote :

Sorry, the original build had failed and I hadn't noticed.

It should work fine now, I have just tested it (using apt-get upgrade) on a gutsy i386 machine.

Jonathan Ernst (jonathan.ernst) wrote :

I have just tested it and it works fine. Thank you.

François Marier (fmarier) wrote :

Thanks for testing this Jonathan.

I have requested a sync in LP#195348.

François Marier (fmarier) wrote :

New version synced in hardy.

Changed in ifrench:
status: New → Fix Released
Jonathan Ernst (jonathan.ernst) wrote :

Hello, I have installed two fresh hardy on two different computers and swiss french spellchecking is not enabled in openoffice.org anymore.

I don't know when the regression occured.

Changed in ifrench:
assignee: nobody → fmarier
status: Fix Released → New
Jonathan Ernst (jonathan.ernst) wrote :

Please note that by default ifrench is not installed, so you might need to patch ifrench-gut as well. (I have tryed replacing ifrench-gut by ifrench but it didn't fix the dictionnary list in oo.o)

François Marier (fmarier) wrote :

Hi Jonathan,

Can you confirm that you are running the 1.4-22 version of the ifrench package?

François Marier (fmarier) wrote :

Also, can you paste the contents of this file for both myspell-fr-gut and myspell-fr:

  /usr/share/myspell/infos/ooo/myspell-fr

Default hardy install (dictionnary doesn't work) :

jernst@jernst-desktop:~$ dpkg -l ifrench
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nom Version Description
+++-==============-==============-============================================
rc ifrench 1.4-22 The French dictionary for ispell (Hydro-Queb
jernst@jernst-desktop:~$ dpkg -l ifrench-gut
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nom Version Description
+++-==============-==============-============================================
ii ifrench-gut 1:1.0-19.1 The French dictionary for ispell (GUTenberg

cat /usr/share/myspell/infos/ooo/myspell-fr-gut
DICT fr FR fr
DICT fr BE fr
DICT fr CA fr

After removing ifrench-gut, myspell-fr-gut and installing ifrench and myspell-fr (dictionnary works) :

jernst@jernst-desktop:~$ dpkg -l ifrench-gut
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nom Version Description
+++-==============-==============-============================================
pn ifrench-gut <néant> (aucune description n'est disponible)
jernst@jernst-desktop:~$ dpkg -l ifrench
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nom Version Description
+++-==============-==============-============================================
ii ifrench 1.4-22 The French dictionary for ispell (Hydro-Queb
jernst@jernst-desktop:~$ dpkg -l ifrench-gut
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nom Version Description
+++-==============-==============-============================================
pn ifrench-gut <néant> (aucune description n'est disponible)

jernst@jernst-desktop:~$ cat /usr/share/myspell/infos/ooo/myspell-fr
DICT fr FR fr
DICT fr BE fr
DICT fr CA fr
DICT fr CH fr
DICT fr LU fr

My conclusion is that you successfully fixed ifrench (myspell-fr), but that you have to fix ifrench-gut (myspell-gut) because that's what is installed by default in current hardy.

Changed in ifrench:
status: New → Fix Released
François Marier (fmarier) wrote :

Thanks for the clarifications Jonathan.

Someone else maintains the ifrench-gut Debian package, but once he fixes it, then a sync of that package should be requested for hardy.

If you'd like to be notified directly about activity on the Debian side, email <email address hidden>

Cheers,

Francois

Changed in ifrench-gut:
status: Unknown → Fix Released
François Marier (fmarier) wrote :

I have requested a sync in bug #200056

François Marier (fmarier) wrote :

Fixed in hardy

Changed in ifrench-gut:
status: New → Fix Released

As far as I understand Intrepid will use hunspell instead of myspell which is good and fixes the fact that a lot of common words are missing from the myspell dictionnaries. However the exact same bug krept back in this package :

 cat /usr/share/myspell/infos/ooo/hunspell-fr
DICT fr FR fr_FR

All the other languages are missing...

François told me on irc he'll have a look at it as he fixed the same bug in the old packages before that.

Changed in openoffice.org-dictionaries:
assignee: nobody → fmarier
François Marier (fmarier) wrote :

I have just built a patched version of hunspell-fr. Could someone confirm that it works for non fr_FR locales on Ubuntu intrepid?

The package is available from my PPA:

  deb http://ppa.launchpad.net/fmarier/ubuntu intrepid main

I can see this:

  $ cat /usr/share/myspell/infos/ooo/hunspell-fr

  DICT fr FR fr_FR

  DICT fr BE fr_FR

  DICT fr CA fr_FR

  DICT fr CH fr_FR

  DICT fr LU fr_FR

But if someone else could confirm that the French dictionary actually works in OpenOffice using a non-France locale, that would be much appreciated.

Thanks François !

Your updated package fixes this bug on my fr_CH intrepid system.

Best regards

François Marier (fmarier) wrote :

Here is a debdiff between the current package in intrepid and the one in my PPA. As you can see, it is simply adding a few countries to the list of locales which make use of the French fr_FR dictionary.

Given the size of this change, the potential impact on the rest of the package (or distribution) is minimal.

However, this fix is quite important because without it French speakers outside of France will not be able to use the spellchecker in Open Office. I believe that this would be a show-stopper for a lot of users.

Therefore I would like to request a BetaFreeze Exception.

Francois

Latest intrepid + François Marier PPA + deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main (openoffice 3)

cat /usr/share/myspell/infos/ooo/hunspell-fr
DICT fr FR fr_FR
DICT fr BE fr_FR
DICT fr CA fr_FR
DICT fr CH fr_FR
DICT fr LU fr_FR

But Openoffice.org doesn't show French (suisse) as being installed

Pidgin is saying everything that I write is badly spell checked but that's another bug (maybe) : Bug #278943

Steve Langasek (vorlon) wrote :

freeze exception granted, please upload.

Changed in openoffice.org-dictionaries:
status: New → Confirmed
Martin Pitt (pitti) wrote :

Sponsored.

Changed in openoffice.org-dictionaries:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org-dictionaries - 1:2.4.0~m240-2ubuntu3

---------------
openoffice.org-dictionaries (1:2.4.0~m240-2ubuntu3) intrepid; urgency=low

  * Added fr_CA, fr_BE, fr_CH and fr_LU to the French dictionary (LP: #139570)

 -- Francois Marier <email address hidden> Mon, 29 Sep 2008 11:33:44 +1300

Changed in openoffice.org-dictionaries:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.