Ubuntu

using ifmetric reports "NETLINK: Packet too small or truncated! 40!=16!=1004 "

Reported by C.Lee Taylor on 2011-11-26
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ifmetric (Debian)
Fix Released
Unknown
ifmetric (Ubuntu)
Undecided
Unassigned

Bug Description

When trying to change metric for an interface doing ...

ifmetric eth1 10

I get a report back ...
NETLINK: Packet too small or truncated! 40!=16!=1004

I was able to find a Debian bug report - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=514197

With a patch, increasing a buffer and reporting saying that it worked for them.

Tried this on ...
Description: Ubuntu 11.10
Release: 11.10

C.Lee Taylor (leenx-leet) wrote :

The attachment "Debian Patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Yannick WEBER (yweb) wrote :

I get the same issue using ifmetric.0.3-2 with 11.10 64 bits.

I also confirm that the patch in #1 works.

I'm newbie with launchpad and ubuntu's packaging rules so how does it works now ? Does some one recompile the patched sources and submit it to some king of approval team?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ifmetric (Ubuntu):
status: New → Confirmed
Rob A (docsmooth) wrote :

Lack of "ifmetric" support breaks the "metric" statement in /etc/network/interfaces for users not using NetworkManager

Changed in ifmetric (Debian):
status: Unknown → New
Guilhem Lettron (guilhem-fr) wrote :

here is a fix lp:~guilhem-fr/ifmetric/fix-896584

and the repository with it (and FTBFS resolv) : https://launchpad.net/~guilhem-fr/+archive/ifmetric

1) I confirm than this bug is affecting Ubuntu LTS 12.04 AMD64 server on a Dell PowerEdge T310 (ifmetric_0.3-2_amd64)

2) The Guilhem version solve the problem for me (thanks ! )

3) This may be critical on server setup with multiple network interfaces as it is an often recommended way to set-up metrics in /etc/network/interfaces if interface priority is necessary

Michael Shuler (mshuler) on 2013-09-05
Changed in ifmetric (Ubuntu):
status: Confirmed → Fix Committed
Changed in ifmetric (Debian):
status: New → Fix Committed
Changed in ifmetric (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ifmetric - 0.3-3

---------------
ifmetric (0.3-3) unstable; urgency=low

  * New maintainer. Closes: #721769
  * Update to standards-version 3.9.4.
  * Update to compat 9 for hardening build flags.
  * Remove empty debian/{pre,post}{inst,rm} files.
  * Add debian/source/format - 3.0 (quilt).
  * Add Vcs-* and Homepage fields to debian/control.
  * Update debian/copyright to machine readable format.
  * Switch debian/copyright license reference from GPL symlink to GPL-2.
  * Move debian/ifmetric.ifup to debian/ifmetric.if-up.
  * Add debian/watch file.
  * Switch from cdbs to dh.
  * Add debian/source/local-options to keep build source clean.
  * Patch src/ifmetric.c for s/Recieved/Received/ typo.
  * Add debian/upstream_changelog from homepage News section.
  * Add patch to fix "NETLINK: Packet too small or truncated!" error.
    Thanks to Benedek László for the patch. Closes: #514197, LP: #896584

 -- Michael Shuler <email address hidden> Thu, 05 Sep 2013 14:53:17 -0500

Changed in ifmetric (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.