Volume (slider) item isn't highlighted when selected

Bug #524541 reported by Matthew Paul Thomas on 2010-02-19
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Indicator Display Objects
Fix Released
Medium
Charles Kerr
The Sound Menu
Invalid
Undecided
Unassigned
ido (Ubuntu)
Medium
Unassigned

Bug Description

indicator-sound 0.1.1-0ubuntu2, Ubuntu Lucid
libido-0.1-0 0.1.11-0ubuntu2, indicator-sound 0.4.0-0ubuntu1, Ubuntu Maverick

1. Open the sound menu, without any music players running.
2. Press the Down key.
3. Press the Down key.
4. Press the Down key.

What should happen:
2. The "Mute All" item is highlighted.
3. The volume item is highlighted.
4. The "Sound Preferences…" item is highlighted.

What actually happens:
3. The volume item is not highlighted.

<https://wiki.ubuntu.com/SoundMenu#Volume%20item>: "The item should highlight when navigated to, or on mouseover, just as normal menu items do".

Mockup: <https://launchpadlibrarian.net/89751824/Sound%20menu%20highlighting.gif>

Related branches

Conor Curran (cjcurran) wrote :

Noted, next version of IDO should support this.

Omer Akram (om26er) on 2010-02-19
Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Conor Curran (cjcurran) on 2010-03-04
Changed in indicator-sound (Ubuntu):
assignee: nobody → Cody Russell (bratsche)
Changed in ido:
status: New → In Progress
Changed in indicator-sound (Ubuntu):
assignee: Cody Russell (bratsche) → nobody
assignee: nobody → Conor Curran (cjcurran)
status: Triaged → Invalid
status: Invalid → Confirmed
Changed in indicator-sound:
status: New → Invalid
affects: indicator-sound (Ubuntu) → ido (Ubuntu)
Conor Curran (cjcurran) on 2010-03-04
Changed in ido:
assignee: nobody → Cody Russell (bratsche)
Cody Russell (bratsche) on 2010-03-04
Changed in ido (Ubuntu):
assignee: Conor Curran (cjcurran) → Cody Russell (bratsche)
Omer Akram (om26er) on 2010-03-08
Changed in ido (Ubuntu):
status: Confirmed → Triaged
Cody Russell (bratsche) on 2010-07-15
Changed in ido:
status: In Progress → New
David Barth (dbarth) on 2010-08-19
Changed in ido:
importance: Undecided → Medium
milestone: none → ubuntu-10.10-beta
status: New → Triaged
description: updated
frizzle21 (frederik-nnaji) wrote :

https://wiki.ubuntu.com/SoundMenu#Output%20volume%20item says:
"The item should highlight when navigated to, or on mouseover, just as normal menu items do, but the item should not be activatable (clicking it or pressing Enter should not close the menu)"

ok. The playback controls are the second example of horizontally arranged menu items / controls. For the playback controls, the spec says:
"When using the keyboard, the Play/Pause button alone should highlight in the same way. Pressing the Space key should visibly activate the Play/Pause button, and the Left and Right keys should visibly activate the Previous and Next buttons respectively."

wouldn't it be consistent to do the same thing with the volume item?
i.e. to "visibly activate" the Volume_To_Zero button upon CTRL+LEFT and the Volume_To_Max button upon CTRL+RIGHT?

This would mean that ONLY the fader would receive visible focus when navigated to or on hover..
Wouldn't that be easier also?

Matthew Paul Thomas (mpt) wrote :

That's not relevant to this bug. The buttons should appear pressed when their keyboard combos are invoked, but that should be reported as a separate bug.

frizzle21 (frederik-nnaji) wrote :

I still don't understand the bug description completely then:
which items should be highlighted exactly when navigated to via "down && down"?
the entire row with its 3 objects or only the slider?

Matthew Paul Thomas (mpt) wrote :

The entire row. That shows which item will respond to keypresses, for example.

I disagree: in the case of the volume slider, the thing which should be
highlighted is the grippy, since *that's* what will react to the left or
right keystrokes. In the case of the play/pause/next/previous row, it's
the play/pause button which should be highlighted. A left or right
stroke should *flash* the previous/next button, returning the highlight
to the central button immediately.

Mark

Changed in ido:
assignee: Cody Russell (bratsche) → Alberto Ruiz (alberto.ruiz)
Alberto Ruiz (alberto.ruiz) wrote :

Depending on which area we should highlight this bug is going to have different fixes.

Note however that if we only want to highlight the grip, things are slightly easier. If we want to highlight the whole row, the fix is going to be a bit harder, since we are using offscreen windows here and they can't be painted transparent yet. Gtk+ has a fix for this on master but we won't be able to take advantage of that until 3.4 is out.

So, should I take Mark's comment as a final word or is this issue still being discussed?

Andrea Cimitan (cimi) wrote :

can't you just use paint/render focus?

Matthew Paul Thomas (mpt) wrote :
description: updated
Changed in ido (Ubuntu):
assignee: Cody Russell (bratsche) → nobody
Charles Kerr (charlesk) on 2012-02-28
Changed in ido:
assignee: Alberto Ruiz (alberto.ruiz) → charles (charlesk)
Charles Kerr (charlesk) on 2012-03-10
Changed in ido (Ubuntu):
status: Triaged → In Progress
status: In Progress → Triaged
Changed in ido:
status: Triaged → In Progress
Charles Kerr (charlesk) on 2012-03-12
Changed in ido:
status: In Progress → Fix Committed
Charles Kerr (charlesk) on 2012-04-02
Changed in ido:
status: Fix Committed → Fix Released
Changed in ido (Ubuntu):
status: Triaged → Fix Released
Charles Kerr (charlesk) on 2012-04-12
Changed in ido:
milestone: ubuntu-10.10-beta → 0.3.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Bug attachments