Using calendar with keys might cause Indicator-datetime to crash unity-panel-service

Bug #1506427 reported by errors.ubuntu.com bug bridge on 2015-10-15
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ido (Ubuntu)
Medium
Marco Trevisan (Treviño)
Trusty
Undecided
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned

Bug Description

[Impact]
Unity panel service crashes (removing indicators from panel) when calendar menu is opened and there are some key presses.

[Test Case]
This is a quite random bug that is not easy to reproduce, it happens sometimes that you open the indicator-datetime and after a keypress the panel crashes.

[Regression Potential]
Nothing expected, but calendar item in datetime might behave differently on key-presses.
Although the fix is quite safe since we're just ensuring that we disconnect from parent widget signals on menuitem destruction.

=======

The Ubuntu Error Tracker has been receiving reports about a problem regarding unity. This problem was most recently seen with version 7.3.2+15.10.20151002.2-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/74901303bee889a2ca807616ea267069ad252435 contains more details.

Related branches

lp:~3v1n0/ido/parent-signals-disconnection
Andrea Azzarone: Approve on 2016-10-31
Andrea Azzarone: Approve on 2016-10-31
lp:~3v1n0/ido/parent-signals-disconnection-trusty
Approved for merging into lp:ido/14.04
Indicator Applet Developers: Pending requested 2017-04-03
Superseded for merging into lp:ido
Indicator Applet Developers: Pending requested 2017-04-03
Sebastien Bacher (seb128) wrote :
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Changed in unity:
importance: Undecided → High
status: New → Fix Released
no longer affects: unity (Ubuntu)
no longer affects: unity
Changed in ido (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 13.10.0+17.04.20161028-0ubuntu1

---------------
ido (13.10.0+17.04.20161028-0ubuntu1) zesty; urgency=medium

  * IdoCalendarMenuItem: disconnect from parent signals on item
    destruction (LP: #1506427)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 28 Oct 2016 22:42:17 +0000

Changed in ido (Ubuntu):
status: In Progress → Fix Released
description: updated
summary: - /usr/lib/unity/unity-panel-
- service:11:g_type_check_instance_is_a:ido_calendar_menu_item_key_press:_gtk_marshal_BOOLEAN__BOXED:g_closure_invoke:signal_emit_unlocked_R
+ Using calendar with keys might cause Indicator-datetime to crash unity-
+ panel-service
Brian Murray (brian-murray) wrote :

While we don't see any crashes about that this from 16.10 on the Error Tracker, shouldn't this also be fixed in that release?

I'm not sure if that has happened because the fix was marked as released, however maybe something changed in gtk, but this change is just something right to do, and I'd like to backport it to 16.04, thus the need of fixing it in both.

Hello errors.ubuntu.com, or anyone else affected,

Accepted ido into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ido/13.10.0+16.04.20161028-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ido (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

As xenial-release and yakkety-release have the same ido version, I forward-copied the xenial SRU to yakkety. This needs to be verified too, so that both can eventually be released. Otherwise x would have a higher version than y.

Changed in ido (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-done-xenial verification-neededd
removed: verification-done wily
Robie Basak (racb) on 2016-11-30
tags: added: verification-needed
removed: verification-neededd

Hello,

I've enabled proposed and installed all new packages but I'm still getting the problem.

As soon as I log in I need to open tty1 and kill the indicator-datetime-service.

This is what's happening when I'm starting it (manually):
http://storage7.static.itmages.com/i/16/1201/h_1480628539_5021348_6b2081423e.jpeg

$ sudo dpkg -l|grep -i indicator-datetime
ii indicator-datetime 15.10+16.10.20160820.1-0ubuntu1 amd64 Simple clock

$ lsb_release -d
Description: Ubuntu 16.10

$ uname -a
Linux wcomnisky 4.8.0-28-generic #30-Ubuntu SMP Fri Nov 11 14:03:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

William,

I think the problem you mention is unrelated to this bug. Did you get any crash of unity panel service in /var/crash ?

Hi Marco,

Yep, you right. No relation with Unity panel service.

Changed in ido (Ubuntu Xenial):
importance: Undecided → Medium
Changed in ido (Ubuntu Yakkety):
importance: Undecided → Medium
tags: added: verification-done
removed: verification-needed
Robie Basak (racb) wrote :

@Marco

Please describe what package versions you tested, how you tested them and what your results were before marking verification-done.

tags: added: verification-needed
removed: verification-done verification-done-xenial

I'm testing both xenial, yakkety and zesty for months... Crashes just don't happen anymore.
There's no a common way to reproduce, but it always happened after some time of uptime and indicators+keyboard usage, and this has been fixed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 13.10.0+16.04.20161028-0ubuntu1

---------------
ido (13.10.0+16.04.20161028-0ubuntu1) xenial; urgency=medium

  * IdoCalendarMenuItem: disconnect from parent signals on item
    destruction (LP: #1506427)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 28 Oct 2016 22:43:02 +0000

Changed in ido (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ido has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 13.10.0+16.04.20161028-0ubuntu1

---------------
ido (13.10.0+16.04.20161028-0ubuntu1) xenial; urgency=medium

  * IdoCalendarMenuItem: disconnect from parent signals on item
    destruction (LP: #1506427)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 28 Oct 2016 22:43:02 +0000

Changed in ido (Ubuntu Xenial):
status: Fix Committed → Fix Released
Robie Basak (racb) wrote :

It looks like 13.10.0+14.04.20170403-0ubuntu1 still needs verifying from trusty-proposed.

09:41 <rbasak> [SRU] could someone glance at bug 1506427 please? I'm not sure how it ended up in trusty-proposed. I see no message about it (plus it doesn't appear to have been verified in trusty, but that's a separate matter)

tags: added: verification-needed
removed: verification-done
Adam Conrad (adconrad) on 2017-04-12
Changed in ido (Ubuntu Trusty):
status: New → Fix Committed

I'm running fixed version for some weeks in my trusty machine.

No crash anymore so far.

tags: added: verification-done
removed: verification-needed

By "fixed version" I meant 13.10.0+14.04.20170403-0ubuntu1 from trusty proposed.

No regression so far.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers