unity-panel-service crashed with SIGSEGV in ido_calendar_menu_item_key_press()

Bug #1350821 reported by Daniel Holbach on 2014-07-31
106
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ido (Ubuntu)
High
Marco Trevisan (Treviño)
Nominated for Utopic by Alberto Salvia Novella
Trusty
High
Unassigned

Bug Description

[Impact]
Unity panel service crashes when opening the Calendar menu

[Test Case]
There's not a way to reproduce this systemically. Just open frequently the calendar menu, but this crash can happen or not.

[Regression Potential]
None, the code change consists only on protecting against a null pointer (recorded in the stacktraces here), so it's just pretty safe.

ProblemType: CrashDistroRelease: Ubuntu 14.10
Package: unity-services 7.3.0+14.10.20140711-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-6.11-generic 3.16.0-rc7
Uname: Linux 3.16.0-6-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.5-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Jul 31 13:53:14 2014
DistUpgraded: Fresh install
DistroCodename: utopic
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.3.12, 3.16.0-5-generic, x86_64: installed
 virtualbox, 4.3.12, 3.16.0-6-generic, x86_64: installed
ExecutablePath: /usr/lib/unity/unity-panel-service
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21da]
InstallationDate: Installed on 2013-12-22 (221 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131221)
MachineType: LENOVO 429149G
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 PATH=(custom, user)
 LANGUAGE=de_DE
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-6-generic root=UUID=23a70067-84b7-4d69-8cbc-11f2fe3f429d ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7ffbbaf3b766: mov 0x10(%rdx),%ecx
 PC (0x7ffbbaf3b766) ok
 source "0x10(%rdx)" (0x00000010) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11SourcePackage: unity
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libido3-0.1.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-panel-service crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm autopilot cdrom dip lpadmin plugdev sambashare scanner sudo
dmi.bios.date: 05/18/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET46WW (1.16 )
dmi.board.asset.tag: Not Available
dmi.board.name: 429149G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET46WW(1.16):bd05/18/2011:svnLENOVO:pn429149G:pvrThinkPadX220:rvnLENOVO:rn429149G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 429149G
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11+14.10.20140707-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.54-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.3-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Wed Jul 30 18:55:05 2014
xserver.configfile: default
xserver.errors:
 intel: Failed to load module "dri3" (module does not exist, 0)
 intel: Failed to load module "present" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 728
 vendor LGD
xserver.version: 2:1.15.1-0ubuntu8

Related branches

Daniel Holbach (dholbach) wrote :
Changed in unity (Ubuntu):
importance: Undecided → Medium
summary: - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
+ unity-panel-service crashed with SIGSEGV in
+ ido_calendar_menu_item_key_press()
tags: removed: need-amd64-retrace
Changed in unity:
importance: Undecided → Medium
tags: added: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
information type: Private → Public
no longer affects: unity (Ubuntu)
Changed in unity:
status: New → Invalid
Changed in ido (Ubuntu):
status: New → Confirmed
no longer affects: indicator-datetime (Ubuntu)
affects: unity → hundredpapercuts
no longer affects: hundredpapercuts
Changed in ido (Ubuntu):
importance: Undecided → High
no longer affects: ido
Changed in ido (Ubuntu):
status: Confirmed → Triaged
Charles Kerr (charlesk) wrote :

> Thread 1 (Thread 0x7ffbbbaa39c0 (LWP 2565)):
> #0 ido_calendar_menu_item_key_press (widget=widget@entry=0x1e090f0, event=0x7fff8761dad0, data=0x0, data@entry=0x1e37790) at idocalendarmenuitem.c:159

The crash is straightforward enough, but I'm not sure yet what's causing it.

data is NULL, and ido_calendar_menu_item_key_press() casts it to an IdoCalendarMenuItem* and dereferences it:

> static gboolean
> ido_calendar_menu_item_key_press (GtkWidget *widget,
> GdkEventKey *event,
> gpointer data)
> {
> IdoCalendarMenuItem *menuitem = (IdoCalendarMenuItem *)data;
>
> if (menuitem->priv->selected)
> {

...

tags: added: bugpattern-needed
Changed in ido (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 13.10.0+15.10.20150728-0ubuntu1

---------------
ido (13.10.0+15.10.20150728-0ubuntu1) wily; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * IdoCalendarMenuItem: add crash guard on
    ido_calendar_menu_item_key_press (LP: #1350821)

 -- CI Train Bot <email address hidden> Tue, 28 Jul 2015 21:12:27 +0000

Changed in ido (Ubuntu):
status: In Progress → Fix Released
description: updated

Hello Daniel, or anyone else affected,

Accepted ido into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ido/13.10.0+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ido (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Mathew Hodson (mhodson) on 2015-11-04
Changed in ido (Ubuntu Trusty):
importance: Undecided → High
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 13.10.0+14.04.20151021-0ubuntu1

---------------
ido (13.10.0+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * IdoCalendarMenuItem: add crash guard on
    ido_calendar_menu_item_key_press (LP: #1350821)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:52:32 +0000

Changed in ido (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ido has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Shamank (lucianofantuzzi) wrote :

I'm in Ubuntu 14.04 (updated) and this is still happening, and very often.

5 Mar 24 10:14:05 Paula kernel: [200470.769785] unity-panel-ser[22006]: segfault at 40000001a ip 00007f934bcc9d6c sp 00007ffed2876b98 error 4 in libgobject-2.0.so.0.4002.0[7f934bc98000+4f000]

It always happens the first time I click the calendar widget (after reboot). Apport goes to 100% of cpu and after the crash, the widgets looks to work normally.

Is there some workaround for this?

Sorry, the proper fix has not been released to trusty...

However you can manually install the fixed .deb from http://packages.ubuntu.com/xenial/libido3-0.1-0
Just pick the one for your architecture and `sudo dpkg -i` it.

Otherwise you can just add this ppa: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/2689

Packages will be there shortly, and then released to trusty after the SRU process will be finished.
Please subscribe to bug https://pad.lv/1506427 and follow the verification steps in order to get this fix delivered.

reg (ppguara) wrote :

@Marco...
Thanks for the info on the fix manual-install, but on my system 14.04 nothing has changed, bug still alive and well.

JmAbuDabi (dambldor91) wrote :

After click calendar My system Ubuntu 18.04 Unity freeze and not response any click mouse and keyboard.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers