Arabic support in icewm

Bug #270019 reported by Usama Akkad on 2008-09-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
icewm (Fedora)
Fix Released
High
icewm (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Usama Akkad
Nominated for Lucid by Usama Akkad

Bug Description

Binary package hint: icewm

This patch is to fix this bug:
[ 1440618 ] bidi support (fribidi)
Languages such as Hebrew and Arabic are written from
right to left. Hence processing them requires "bidirectional" text rendering: the text flows in some
cases from left to right and in others: from left to right.

This patch is necessary because the letters in those languages are shown in
the opposite direction.

it has been modified by Khaled Hosny. to work better and it wast tested.

the bug:
http://sourceforge.net/tracker/index.php?func=detail&aid=1440618&group_id=31&atid=300031

And icewm team isn't responding.

It's prepackaged here with Arabic support:
http://ppa.launchpad.net/khaledhosny/ubuntu

Thanks.

Tags: rtl Edit Tag help
Usama Akkad (damascene) wrote :
Usama Akkad (damascene) wrote :

The problem is still in Ubuntu 9.04 (Jaunty Jackalope)
I hope you fix that because the patch is provided.
thanks

Description of problem:
Arabic, Hebrew, Farsi, and Urdu needs BiDi support to work probably. there was a batch that have been made to support BiDi in Icewm and it has been tested on Ojuba (a fedora based distribution)

Version-Release number of selected component (if applicable):

How reproducible:
try to open Arabic web page using Icewm and look into the title bar. the same applies for programs with Arabic title. or any Arabic text that displays in the windows or the menus of the window manager.

Steps to Reproduce:
1.open your browser
2.go to this site http://www.ojuba.org/wiki/
3.look at the title bar.

Actual results:
you will find the Arabic word (أعجوبة) revised and it's letters seperated.

Expected results:
the Arabic text should be displayed probably.

Additional info:

there is a batch and more info here:
http://sourceforge.net/tracker/index.php?func=detail&aid=1440618&group_id=31&atid=300031

Sorry for the late reply - I bugzilla email somehow laded in the wrong folder.
The patch itself is for 1.3.2, but I had no problem back porting it to 1.2.37.

A fix will land shortly.

- Gilboa

icewm-1.2.37-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/icewm-1.2.37-5.fc11

icewm-1.2.37-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/icewm-1.2.37-5.fc10

P.S. Seems to be working just fine in Hebrew. Please check Arabic web-sites.

icewm-1.2.37-5.fc11 has been pushed to the Fedora 11 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update icewm'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10020

icewm-1.2.37-5.fc10 has been pushed to the Fedora 10 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update icewm'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10030

icewm-1.2.37-5.fc10 has been pushed to the Fedora 10 stable repository. If problems still persist, please make note of it in this bug report.

icewm-1.2.37-5.fc11 has been pushed to the Fedora 11 stable repository. If problems still persist, please make note of it in this bug report.

Usama Akkad (damascene) on 2010-02-04
Changed in icewm (Ubuntu):
status: New → Confirmed
Usama Akkad (damascene) wrote :

It still with Ubuntu Lucid.
IceWM 1.3.6

Usama Akkad (damascene) wrote :

Seems like fedora have fixed it:
https://bugzilla.redhat.com/show_bug.cgi?id=515134

This bug also effect other language that is Right To Left(RTL)

Usama Akkad (damascene) wrote :

Red Hat Bugzilla are more connected to fedora and it's fixed there

Yaron (sh-yaron) on 2010-10-31
tags: added: rtl
Changed in icewm (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.