Allow other browsers as dependency

Bug #766559 reported by Julien Lavergne on 2011-04-19
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
icedtea-web (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

icedtea-plugin 1.1~20110406-0ubuntu2 have a strict and exclusive depends on only 1 browser : firefox. But the plugin works also with Chromium, without the need of firefox package.

Please add some alternative to firefox depends in debian/rules (line 72 : xulrunner_depends = firefox (>= 4.0~b7) | chromium-browser | other_browser ....)

Wladimir Mutel (mwg) wrote :

Agreed. Not everyone wants to have Firefox installed on their system just for the sake of using Java plugin

Julien Lavergne (gilir) wrote :

Attached debdiff add chromium-browser as an alternative, or xulrunner to keep compatibility with previous behavior. As I'm not a xul/firefox expert, the last one is maybe not necessary.

Changed in icedtea-web (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) wrote :

Please don't add xulrunner-2.0 since there's only one browser left that uses it. Can't we solve this (for oneiric and on) by making the NPAPI capable browsers provide a virtual package that these plugins can depend on?

Changed in icedtea-web (Ubuntu):
status: Confirmed → Incomplete
Felix Braun (felix-braun) wrote :

Why has this been marked incomplete (meaning the *report* is incomplete)? Comment #4 suggests that the fix should be revisited for oneiric. But still the suggested fix should be pushed into natty!

Changed in icedtea-web (Ubuntu):
status: Incomplete → In Progress
Julien Lavergne (gilir) wrote :

The virtual package sound like a good idea for oneiric. But for natty, we should add others browsers not to force people to have firefox to use Java. I updated the debdiff.

Changed in icedtea-web (Ubuntu):
status: In Progress → Confirmed
Stéphane Graber (stgraber) wrote :

Looking at this, I'm not even sure why we'd depend on a web browser at all.
Shouldn't it be done in a similar way as for flashplugin-installer where the web browsers are suggests instead of recommends/depends?

Martin Pitt (pitti) wrote :

Julien's debdiff looks fine for a natty SRU, I added a natty task and uploaded to the natty queue.

Note that as per the SRU rules this needs to be fixed in oneiric before it can get to natty-updates. Please report this bug to Debian and proposed dropping the Depends to a Suggests:

Changed in icedtea-web (Ubuntu Natty):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Unsubscribing sponsors, as there currently is nothing more to upload.

Changed in icedtea-web (Ubuntu):
status: Confirmed → Triaged
Matthias Klose (doko) wrote :

please wait until later this week for the 1.1 release (see bug #767144)

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package icedtea-web - 1.1~20110530-1ubuntu1

---------------
icedtea-web (1.1~20110530-1ubuntu1) oneiric; urgency=low

  * Regenerate the control file.
  * Add other browsers as an alternative to firefox depends. LP: #766559.

icedtea-web (1.1~20110530-1) unstable; urgency=low

  * Update to hg 20110530, taken from the icedtea-web-1.1 release branch.
 -- Matthias Klose <email address hidden> Mon, 30 May 2011 22:25:14 +0200

Changed in icedtea-web (Ubuntu):
status: Triaged → Fix Released

Accepted icedtea-web into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Peter Wu (lekensteyn) on 2011-06-13
summary: - Forcing installation of firefox
+ Allow other browsers as dependency
Makoto (makotothedragon) wrote :

Just tested it from natty-proposed, curious if there's any reason at all to have a dependency on any sort of browser. I personally don't want Chromium on my machine; all I want is the icedtea plugin.

Martin Pitt (pitti) on 2011-06-15
tags: added: verification-done
removed: verification-needed
Clint Byrum (clint-fewbar) wrote :

This SRU seems to be lacking the SRU justification required at

https://wiki.ubuntu.com/StableReleaseUpdates

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package icedtea-web - 1.1~20110420-0ubuntu1.1

---------------
icedtea-web (1.1~20110420-0ubuntu1.1) natty-proposed; urgency=low

  * debian/rules:
   - Add other browsers as an alternative to firefox depends.
     LP: #766559
 -- Julien Lavergne <email address hidden> Wed, 20 Apr 2011 19:51:07 +0200

Changed in icedtea-web (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers