icedtea-plugin crashes on firefox-4.0 and chromium

Bug #727365 reported by Alex Mayorga on 2011-03-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenJDK
Fix Released
Medium
icedtea-web (Ubuntu)
Undecided
Unassigned

Bug Description

icedtea-plugin crashes and makes firefox-4.0 and chromium crash.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: openjdk-6-jre-headless 6b21~pre3-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
Date: Tue Mar 1 13:16:38 2011
ExecutablePath: /usr/lib/jvm/java-6-openjdk/jre/bin/java
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
LocalLibraries: /home/alex-mayorga/hob/jwt/addwebres/libUSLinJni.so /home/alex-mayorga/hob/jwt/addwebres/libx11rdpui_v6.so
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: openjdk-6
UpgradeStatus: Upgraded to natty on 2010-11-25 (95 days ago)

Alex Mayorga (alex-mayorga) wrote :
Alex Mayorga (alex-mayorga) wrote :

The Firefox 4.0 crash details can be found at https://bugzilla.mozilla.org/show_bug.cgi?id=608256

summary: - npviewer.bin keeps going "zombie" with icedtea-plugin, java claims is
- "sleeping"; CPU usage is 0% but firefox-4.0 is locked up pretty badly
+ icedtea-plugin crashes on firefox-4.0 and chromium
Alex Mayorga (alex-mayorga) wrote :

Similar crash using Chromium.

Alex Mayorga (alex-mayorga) wrote :

The exception in Firefox:

(firefox-4.0-bin:4511): GLib-CRITICAL **: g_string_erase: assertion `pos + len <= string->len' failed
Exception in thread "Thread-8" java.lang.RuntimeException: Unable to find processor for message plugin PluginProxyInfo reference 2527 DIRECT
 at sun.applet.PluginStreamHandler.finishCallRequest(PluginStreamHandler.java:317)
 at sun.applet.PluginStreamHandler.handlePluginMessage(PluginStreamHandler.java:284)
 at sun.applet.PluginStreamHandler.handleMessage(PluginStreamHandler.java:205)
 at sun.applet.PluginMessageHandlerWorker.run(PluginMessageHandlerWorker.java:80)

The exception in Chromium:

(exe:5411): GLib-CRITICAL **: g_string_erase: assertion `pos + len <= string->len' failed
Exception in thread "Thread-3" java.lang.RuntimeException: Unable to find processor for message plugin PluginProxyInfo reference 5012 DIRECT
 at sun.applet.PluginStreamHandler.finishCallRequest(PluginStreamHandler.java:317)
 at sun.applet.PluginStreamHandler.handlePluginMessage(PluginStreamHandler.java:284)
 at sun.applet.PluginStreamHandler.handleMessage(PluginStreamHandler.java:205)
 at sun.applet.PluginMessageHandlerWorker.run(PluginMessageHandlerWorker.java:80)

description: updated
Alex Mayorga (alex-mayorga) wrote :

Filed a new bug for the firefox-4.0 crashes:
Bug 642117 - xcb_io.c "poll_for_event: Assertion `(((long) (event_sequence) - (long) (dpy->request)) <= 0)' failed" with IcedTea [@ libc-2.13.so@0x33xxx ]
https://bugzilla.mozilla.org/show_bug.cgi?id=642117

Alex Mayorga (alex-mayorga) wrote :

The chromium crash is Bug #727190

Alex Mayorga (alex-mayorga) wrote :

Seems like this issue happens in Fedora 14 as well
https://bugzilla.redhat.com/show_bug.cgi?id=586194

Download full text (3.1 KiB)

#58 0x00007fd788c65525 in ?? () from /usr/lib/firefox-trunk-6.0a1/libxul.so
#59 0x00007fd782a96578 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#60 0x00007fd7836a781c in g_closure_invoke (closure=0x7fd7600f8790,
    return_value=0x7fd760dfe2b0, n_param_values=2,
    param_values=0x7fd75f43f3a0, invocation_hint=0x7fd760dfe270)
    at /build/buildd/glib2.0-2.28.6/./gobject/gclosure.c:767
#61 0x00007fd7836b9019 in signal_emit_unlocked_R (node=<value optimized out>,
    detail=0, instance=0x7fd76868db80, emission_return=0x7fd760dfe420,
    instance_and_params=0x7fd75f43f3a0)
    at /build/buildd/glib2.0-2.28.6/./gobject/gsignal.c:3252
#62 0x00007fd7836c1fa9 in g_signal_emit_valist (
    instance=<value optimized out>, signal_id=<value optimized out>,
    detail=<value optimized out>, var_args=<value optimized out>)
    at /build/buildd/glib2.0-2.28.6/./gobject/gsignal.c:2993
#63 0x00007fd7836c241f in g_signal_emit (instance=<value optimized out>,
    signal_id=<value optimized out>, detail=<value optimized out>)
    at /build/buildd/glib2.0-2.28.6/./gobject/gsignal.c:3040
#64 0x00007fd782bb24d1 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#65 0x00007fd782a94cff in gtk_main_do_event ()
   from /usr/lib/libgtk-x11-2.0.so.0
#66 0x00007fd7821a27dc in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#67 0x00007fd78219d73b in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#68 0x00007fd78219f929 in gdk_window_process_all_updates ()
   from /usr/lib/libgdk-x11-2.0.so.0
#69 0x00007fd78219f999 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#70 0x00007fd78217cc46 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#71 0x00007fd782fe3bcd in g_main_dispatch (context=0x7fd77e528440)
    at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:2440
#72 g_main_context_dispatch (context=0x7fd77e528440)
    at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3013
#73 0x00007fd782fe43a8 in g_main_context_iterate (context=0x7fd77e528440,
    block=<value optimized out>, dispatch=1, self=<value optimized out>)
    at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3091
#74 0x00007fd782fe4639 in g_main_context_iteration (context=0x7fd77e528440,
    may_block=0) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3154
#75 0x00007fd75e3e3f57 in JavaRequestProcessor::postAndWaitForResponse(std::basic_string<char, std::char_traits<char>, std::allocator<char> >) ()
   from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#76 0x00007fd75e3e66dd in JavaRequestProcessor::getString(std::basic_string<char, std::char_traits<char>, std::allocator<char> >) ()
   from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#77 0x00007fd75e3efda4 in PluginRequestProcessor::sendMember(std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >*, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> >*> >*)
    () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#78 0x00007fd75e3f0f3f in queue_processor(void*) ()
   from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#79 0x00007fd78a043d8c in start_thread ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
#80 0x00007fd78628604d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#81 0x00000000000...

Read more...

alex-mayorga@VPCCW1FFXL:~$ java -version
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.1) (6b22-1.10.1-0ubuntu1)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)
alex-mayorga@VPCCW1FFXL:~$ uname -a
Linux VPCCW1FFXL 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

1.10.1 doesn't have a plugin included.

Please take a look at about:plugins and check what version of the plugin is being used.

Thanks for reporting this. I became aware of the issue a few days ago when trying to figure out issues w/ chromium. I have started working on it, but unfortunately it is not going to be easy to fix, so it will have to be deferred to 1.1.1.

This should remained assigned to icedtea-web.

(In reply to comment #3)
> Thanks for reporting this. I became aware of the issue a few days ago when
> trying to figure out issues w/ chromium. I have started working on it, but
> unfortunately it is not going to be easy to fix, so it will have to be deferred
> to 1.1.1.

Thanks to you for working on this!
These crashes have been haunting me for months now =)
FWIW there are a couple more reports I filed on Ubuntu's bug tracker for the exact same or very similar crashes on both Chromium and Firefox:

https://bugs.launchpad.net/bugs/727190
https://bugs.launchpad.net/bugs/727365

Hope these help you somehow.

(In reply to comment #2)
> 1.10.1 doesn't have a plugin included.
>
> Please take a look at about:plugins and check what version of the plugin is
> being used.
>

about:plugins reports:
IcedTea-Web Plugin (using IcedTea-Web 1.1pre (1.1~20110420-0ubuntu1))

alex-mayorga@VPCCW1FFXL:~$ aptitude show icedtea-plugin
Package: icedtea-plugin
New: yes
State: installed
Automatically installed: no
Version: 1.1~20110420-0ubuntu1
Priority: extra
Section: web
Maintainer: Ubuntu Developers <email address hidden>
Uncompressed Size: 406 k
Depends: openjdk-6-jre, icedtea-netx (= 1.1~20110420-0ubuntu1), firefox (>=
         4.0~b7), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.3.4), libcairo2 (>=
         1.2.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>=
         1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.16.0),
         libgtk2.0-0 (>= 2.8.0), libpango1.0-0 (>= 1.14.0), libstdc++6 (>= 4.5)
Conflicts: icedtea-gcjwebplugin (< 1.0-1ubuntu4), icedtea6-plugin (<
           6b21.0~20101127~)
Replaces: icedtea-gcjwebplugin, icedtea6-plugin (< 6b21.0~20101127~),
          openjdk-6-jre (< 6b20-1.10~pre2)
Provides: icedtea6-plugin
Description: web browser plugin based on OpenJDK and IcedTea to execute Java applets
 IcedTeaPlugin is a web browser plugin to execute Java applets, supporting
 LiveConnect/JavaScript. It is targeted for xulrunner-1.9 and compatible
 browsers that support the NPAPI.
Homepage: http://icedtea.classpath.org/wiki/IcedTea-Web

This bug report, on the Mozilla side, appears relevant:

    https://bugzilla.mozilla.org/show_bug.cgi?id=640908

*** Bug 511 has been marked as a duplicate of this bug. ***

Targeting for 1.1

Changed in openjdk:
importance: Unknown → Medium
status: Unknown → In Progress
Changed in openjdk:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-6 (Ubuntu):
status: New → Confirmed
Alex Mayorga (alex-mayorga) wrote :

icedtea-web (1.1-1) unstable; urgency=low

  * IcedTea-Web 1.1 release.

 -- Matthias Klose <email address hidden> Thu, 09 Jun 2011 11:58:59 +0200

http://changelogs.ubuntu.com/changelogs/pool/main/i/icedtea-web/icedtea-web_1.1.1-0ubuntu1~11.04.2/changelog
http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=721#c9

affects: openjdk-6 (Ubuntu) → icedtea-web (Ubuntu)
Changed in icedtea-web (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.