update-alternatives broken after installing icedtea-plugin (or even icedtea-netx) in Utopic Unicorn

Bug #1385478 reported by arty on 2014-10-24
174
This bug affects 39 people
Affects Status Importance Assigned to Milestone
icedtea-web (Ubuntu)
Undecided
Unassigned

Bug Description

Today I removed all icedtea packages and tried to install icedtea-plugin via `sudo apt-get install icedtea-plugin`. It resulted in error message "E: Sub-process /usr/bin/dpkg returned an error code (1)". Investigation shows that when installing icedtea-netx package following messages are printed to the console:

icedtea-netx:i386 (1.5.1-1ubuntu1) wird eingerichtet ...
update-alternatives: Warnung: Neuinstallation der Alternative /usr/lib/jvm/java-7-openjdk-i386/jre/bin/itweb-settings ist erzwungen, weil Linkgruppe itweb-settings defekt ist
update-alternatives: Warnung: /usr/share/man/man1/itweb-settings.1.gz wird nicht durch einen Link ersetzt
update-alternatives: Warnung: Neuinstallation der Alternative /usr/lib/jvm/java-7-openjdk-i386/jre/bin/itweb-settings ist erzwungen, weil Linkgruppe itweb-settings defekt ist
update-alternatives: Warnung: /usr/share/man/man1/itweb-settings.1.gz wird nicht durch einen Link ersetzt
update-alternatives: Fehler: Alternativen-Pfad /usr/lib/jvm/java-8-openjdk-i386/jre/bin/javaws existiert nicht
dpkg: Fehler beim Bearbeiten des Paketes icedtea-netx:i386 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
Fehler traten auf beim Bearbeiten von:
 icedtea-netx:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: icedtea-netx (not installed)
ProcVersionSignature: Ubuntu 3.16.0-23.31-generic 3.16.4
Uname: Linux 3.16.0-23-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu8
Architecture: i386
CurrentDesktop: Unity
Date: Fri Oct 24 22:22:08 2014
InstallationDate: Installed on 2012-03-24 (944 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: icedtea-web
UpgradeStatus: Upgraded to utopic on 2014-10-23 (0 days ago)

arty (me-arty) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in icedtea-web (Ubuntu):
status: New → Confirmed
Luis Alvarado (luisalvarado) wrote :

I thought so. It affects 32-bit and 64-bit versions of Ubuntu 14.10. Already tried in 5 PCs. Same problem. The thing is, we wish to NOT use the oracle one but stick to icedtea. This is mostly used for banking sites which would be awesome if the update came before Monday.

Jeremielapuree (jeremielapuree) wrote :

I am affected too :(

János Milus (jmilus) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.