Ubuntu

LiveConnect/javascript not yet implemented in icedtea-gcjwebplugin

Reported by Matthias Klose on 2008-03-26
76
This bug affects 1 person
Affects Status Importance Assigned to Milestone
icedtea-gcjwebplugin (Ubuntu)
Medium
Unassigned
openjdk-6 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: icedtea-gcjwebplugin

[opening this as a new report to collect duplicates]

LiveConnect/javascript is not yet implemented in icedtea-gcjwebplugin.

Related branches

Matthias Klose (doko) on 2008-03-26
Changed in icedtea-gcjwebplugin:
importance: Undecided → Medium
status: New → Confirmed
Marck Robinson (marck) wrote :

When running an applet that uses live connect the class netscape/javascript/JSObject is not found.

This has been tested using the 64-bit version of Firefox in Ubuntu 8.04 beta. The following is written to standard out as soon as the applet attempts to use live connect:

java.lang.NoClassDefFoundError: netscape/javascript/JSObject
GCJ PLUGIN: thread 0x622950: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x622950: plugin_in_pipe_callback: setting status error: netscape/javascript/JSObject.
 at java.lang.Class.getDeclaredConstructors0(Native Method)
 at java.lang.Class.privateGetDeclaredConstructors(Class.java:2406)
 at java.lang.Class.getConstructor0(Class.java:2716)
 at java.lang.Class.newInstance0(Class.java:343)
 at java.lang.Class.newInstance(Class.java:325)
 at sun.applet.AppletPanel.createApplet(AppletPanel.java:796)
 at sun.applet.AppletPanel.runLoader(AppletPanel.java:725)
 at sun.applet.AppletPanel.run(AppletPanel.java:379)
 at java.lang.Thread.run(Thread.java:636)
  PIPE: plugin read: status error: netscape/javascript/JSObject.
Caused by: java.lang.ClassNotFoundException: netscape.javascript.JSObject
GCJ PLUGIN: thread 0x622950: plugin_in_pipe_callback return
 at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:201)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
 at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:145)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
 at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
 ... 9 more
Caused by: java.io.IOException: open HTTP connection failed.
 at sun.applet.AppletClassLoader.getBytes(AppletClassLoader.java:304)
 at sun.applet.AppletClassLoader.access$100(AppletClassLoader.java:62)
 at sun.applet.AppletClassLoader$1.run(AppletClassLoader.java:191)
 at java.security.AccessController.doPrivileged(Native Method)
 at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:188)
 ... 13 more

Jarkko Lietolahti (jarkko-jab) wrote :

Missing LiveConnect is one of the biggest obstacles on the way to 64bit Java applet support. Is there something that could be done?

Raedwulf (tcmreastwood) wrote :

There is an experimental liveconnect plugin in the icedtea7 repository. I have no idea what works and doesn't in it though.

jeanseb (jeanseb-valette) wrote :

this is a real issue as online broker tools use it for streaming.
Got the problem on 32bit arch too.

Should work in recent openJDK's

http://fitzsim.org/blog/?p=28
http://fitzsim.org/blog/?p=23

Maybe the packages just need to be configured to use it?

James Stansell (jamesstansell) wrote :

Technically the –enable-liveconnect is in the icedtea project, instead of OpenJDK, but that's a nit. The reason it's not enabled is that it's alpha-quality at best.

In the post from February that you referenced, Thomas mentioned Sun's new Java plugin. That one actually has a lot of promise, if Sun will put it into OpenJDK. They are at least thinking about it.

http://java.sun.com/developer/community/askxprt/sessions/2008/jl0707.jsp
(search for "new applet plugin")

Ken Russell: As the technical lead of the new Java Plug-In project, I strongly support incorporating it into OpenJDK. Discussions on this topic are ongoing within Sun, and I hope that news will be forthcoming in the near future.

Ah, yes. It's in Icedtea. But I presume that is where the Ubuntu OpenJDK builds come from, so that is not a problem?

Does Fedora run with "–enable-liveconnect"? And wouldn't "alpha quality at best" be better than "not working"?

But great news with the new Sun Java plugin. Thanks.

biehl schrieb:
> Ah, yes. It's in Icedtea. But I presume that is where the Ubuntu OpenJDK
> builds come from, so that is not a problem?

It is a problem, because for both plugins the sources are differently patched.
So you do have to rebuild the openjdk-6 package as well. You could provide such
a build in your PPA.

> Does Fedora run with "–enable-liveconnect"?

No.

> And wouldn't "alpha quality at best" be better than "not working"?

Show us the packages, and update the existing bug reports for these.

  Matthias

Matthias Klose (doko) wrote :

please recheck with the icedtea6-plugin in the openjdk PPA (intrepid).

Changed in icedtea-gcjwebplugin:
status: Confirmed → In Progress
Craig (candrews-integralblue) wrote :

Here's a very simple test: http://developer.apple.com/internet/safari/samples/ColorBlockApplet.html

Using the PPA, it works! Awesome! I've never been quite this excited about a color changing box before.

Jarkko Lietolahti (jarkko-jab) wrote :

What's the address for the PPA?

Michael B. Trausch (mtrausch) wrote :

The PPA build seems to have it working right. I don't have access to my original test case at the moment, but the test from Apple in comment 10 works great now, whereas it did not before. Will this be included in Intrepid?

@Jarkko, add the following to a new file, /etc/apt/sources.list.d/openjdk-ppa.list for Intrepid:

deb http://ppa.launchpad.net/openjdk/ubuntu intrepid main
deb-src http://ppa.launchpad.net/openjdk/ubuntu intrepid main

Timothy G. Rundle (tgrundle) wrote :

The test link Craig provided worked for me, but the site I am looking to work still fails (http://www.jigzone.com/puzzles/daily-jigsaw). I have attached the FF3 output

James Stansell (jamesstansell) wrote :

Hi Timothy,

I looked through your output and didn't see anything obviously wrong. I did notice though that the applet tag had mayscript="" where I would have expected that value to be set to true in order to use LiveConnect.

-james.

jeanseb (jeanseb-valette) wrote :

For me it 's worst.
Crash just after the error message "applet not inited"

Matthias Klose (doko) wrote :

split out the jigzone issue in bug #282570, closing the report.

Changed in icedtea-gcjwebplugin:
status: In Progress → Won't Fix
Matthias Klose (doko) wrote :

fixed in 6b12~pre2

Changed in openjdk-6:
importance: Undecided → Medium
status: New → Fix Released
mkaz (mubashir-kazia) wrote :

Please reopen this bug, only one side of the issue is fixed. JS to Applet communication work but applet to JS communication does not work. You can verify this with the apple liveconnect test at http://developer.apple.com/internet/safari/samples/ColorBlockApplet.html
You'll see the color change when you click on the buttons but when you double click the applet there is no alert message.

Matthias Klose (doko) wrote :

filed bug #282762 instead.

Jarkko Lietolahti (jarkko-jab) wrote :

Btw,
 I just noticed that the OpenJDK PPA requires pulseaudio >= 0.9.12 but Inteprid is currently using 0.9.10

jarkko@gandalf:~$ sudo apt-get install openjdk-6-jdk openjdk-6-jre
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
  openjdk-6-jre: Riippuvuudet: libpulse0 (>= 0.9.12) mutta 0.9.10-2ubuntu8 on merkitty asennettavaksi
                 Suosittelut: pulseaudio (>= 0.9.12) mutta 0.9.10-2ubuntu8 on merkitty asennettavaksi
E: Rikkinäiset paketit

sorry for the Finnish message ;)

Jarkko Lietolahti schrieb:
> Btw,
> I just noticed that the OpenJDK PPA requires pulseaudio >= 0.9.12 but Inteprid is currently using 0.9.10

yes, you need to add tthemuso's PPA to your sources.list now (or use standard intrepid without the PPA).

Thelasko (stever530) wrote :

Has a fix been applied to Hardy?

jeanseb (jeanseb-valette) wrote :

seem not applied

BooVeMan (burkhard-vogel) wrote :

Any chance to have them applied?
I tried the ppa but won't let me install either as it requieres ca-certificates-java, which isn't provided for hardy.
I'm stuck with kubuntu on hardy as I cannot upgrade to kde4...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments