pinyin not listed by default on a fresh installation

Bug #944035 reported by Jean-Baptiste Lallement on 2012-03-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Medium
Michael Terry
Precise
Medium
Michael Terry

Bug Description

Ubuntu Desktop 20120301

On a simplified chinese installation, pinyin is not listed by default and it must be manually added in ibus preferences.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ibus 1.4.0-3ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Thu Mar 1 15:35:30 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
SourcePackage: ibus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/944035

tags: added: iso-testing
tags: added: rls-mgr-p-tracking
Changed in ibus (Ubuntu Precise):
importance: Undecided → Medium
Changed in ibus (Ubuntu Precise):
status: New → Confirmed

Same as ibus-anthy in Japanese.

Martin Pitt (pitti) wrote :

Unfortunately we don't have anyone who is particularly experienced with ibus. Mike, do you have a few cycles to take a look at this? Please unassign yourself again if not. Thanks!

Changed in ibus (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)

Hi Martin and Mike.
I found a patch by Fedora and it works great.
Strictly, this patch is not fix, but new feature.
So we need to break UI freeze and feature freeze.

Peng Huang (shawn-p-huang) wrote :

Fedora uses this patch for a while. It works great. Do not see any problems. I think ubuntu users will like it.

Martin Pitt (pitti) on 2012-03-16
tags: added: rls-p-tracking
removed: rls-mgr-p-tracking

The attachment "lp944035.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Michael Terry (mterry) on 2012-03-16
Changed in ibus (Ubuntu Precise):
status: Confirmed → In Progress
Michael Terry (mterry) wrote :

Alright, Pitti and I don't think this needs an FFe, and it's a slight UIFe that Pitti is fine with.

The code looks fine, Fedora's been running with it for over a year. I ran with it, and it didn't *break* anything. But I had a hard time validating that it did what it was supposed to (not a Chinese or Japanese speaker/typist). I'm going to upload and trust that I'll get feedback if it doesn't work as advertised.

So jibel and ikuya-fruitsbasket [1]: can you please test after I upload and comment?

[1] Nice, Fruits Basket :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.4.1-1ubuntu3

---------------
ibus (1.4.1-1ubuntu3) precise; urgency=low

  * debian/patches/ibus-530711-preload-sys.patch:
    - Set default IMEngine (LP: #944035).
    - Taken from Fedora.
      https://bugzilla.redhat.com/show_bug.cgi?id=530711
 -- Ikuya Awashiro <email address hidden> Fri, 16 Mar 2012 17:18:35 +0900

Changed in ibus (Ubuntu Precise):
status: In Progress → Fix Released

Thank you for your upload.

1. sudo apt-get update; sudo apt-get upgrade
2. logout
3, login on Guest account (all settings clean)
4. start editor
5. push Hankaku-Zenkaku key (IBus started)
6. push any keys and appear Japanese Hiragana.

It works great.

satoritsu (satoritsu) wrote :

I followed #10 steps, and confirmed everything works fine in Japanese. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.