the ibus' indicator fallback icon doesn't have a proper name

Bug #885080 reported by Meng Zhuo on 2011-11-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libappindicator
Fix Released
High
Ted Gould
ibus (Ubuntu)
Low
Unassigned

Bug Description

gnome-shell
version: 3.2.1-0ubuntu1
ibus
version : 1.3.99.20110419-1ubuntu3

in statusIconDispatcher.js there is a
ibus-ui-gtk
but it had been deprecated long time ago.
they named it "main.py" now.

Related branches

The attachment "/usr/share/gnome-shell/js/ui/statusIconDispatcher.js" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed

谢谢你.

The patch works perfectly!

I believe that ibus is the package "at fault". It probably gets patched by Ubuntu Maintainers to be named main.py. (Probably to make it compatible with Unity)

Unfortunately "main.py" is too generic and probably not the best choice for it's name

affects: gnome-shell (Ubuntu) → ibus (Ubuntu)
Changed in ibus (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

the libappindicator issue is somewhat similar to bug #875770

summary: - ibus doesn't display in gnome-shell tray
+ the ibus' indicator fallback icon doesn't have a proper name
Changed in libappindicator:
status: New → Confirmed
importance: Undecided → Low
Ted Gould (ted) wrote :

Okay, so two parts of this bug.
1) libappindicator should use the ID of the indicator on the fallback and set_name() based on that
2) ibus should set it's name to ibus-ui-gtk
Each of the bug tasks represent those different fixes. So I think we're good.

The bug is still present in Ubuntu Precise (as of Feb 6 2012)

I've added ibus to this bug, but I guess the ibus packaging team which should be reported.

no longer affects: ibus

I can report that Debian's ibus package shows up in the top bar as expected.

Ted Gould (ted) on 2012-02-29
Changed in libappindicator:
importance: Low → High
milestone: none → 0.5.0
Ted Gould (ted) on 2012-03-02
Changed in libappindicator:
status: Confirmed → In Progress
milestone: 0.5.0 → 0.4.91
Ted Gould (ted) on 2012-03-02
Changed in libappindicator:
assignee: nobody → Ted Gould (ted)
Charles Kerr (charlesk) wrote :
Changed in libappindicator:
status: In Progress → Fix Committed

Unfortunately ibus still presents the bug.

Ted Gould (ted) on 2012-03-09
Changed in libappindicator:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.4.1-1ubuntu2

---------------
ibus (1.4.1-1ubuntu2) precise; urgency=low

  * debian/patches/05_appindicator.patch: tweak the id so the fallback icon
    gets the same name as the normal gtkstatusicon (lp: #885080)
 -- Sebastien Bacher <email address hidden> Fri, 09 Mar 2012 22:23:18 +0100

Changed in ibus (Ubuntu):
status: Confirmed → Fix Released

Nice. Thumbs up! ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints