Ubuntu

ibus GUI not loading, unable to use input

Reported by Copernicvs on 2011-09-20
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ibus (Debian)
Fix Released
Unknown
ibus (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using oneiric since alpha3, and despite all the updates and bugfixes, ibus is just not working under ubuntu, nor kubuntu.

kernel: 3.0.0-11 (also previous versions)
ibus: 1.3.99.20110419-1ubuntu3 (also ibus-gtk, ibus-gtk3, ibus-qt4, ibus-pinyin packages are installed and up-to-date, with all dependencies)
kubuntu 11.10

The problem is that even though ibus-daemon starts up at login, but it doesn't do anything, the icon doesn't appear in the notificaion area, and I can't seem to switch to a different method with the hotkey either. When I try running ibus-daemon from the command line, i get the answer that it's already running for this session. Also there is no way under language support to install chinese language pack, only the translations, all the other options are greyed out (input methods, etc) since oneiric.

There isn't any error messages whatsoever, it just doesn't work, and also the same with scim and uim too.

Related branches

This is error message when start ibus-daemon -x -v.

Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/main.py", line 130, in <module>
    main()
  File "/usr/share/ibus/ui/gtk/main.py", line 125, in main
    launch_panel(replace)
  File "/usr/share/ibus/ui/gtk/main.py", line 92, in launch_panel
    UIApplication(replace).run()
  File "/usr/share/ibus/ui/gtk/main.py", line 52, in __init__
    self.__panel = panel.Panel(self.__bus)
  File "/usr/share/ibus/ui/gtk/panel.py", line 138, in __init__
    self.__appindicator_update_menu()
  File "/usr/share/ibus/ui/gtk/panel.py", line 554, in __appindicator_update_menu
    item.set_image(_icon.IconWidget("gtk-info", size[0]))
  File "/usr/share/ibus/ui/gtk/icon.py", line 38, in __init__
    pixbuf = theme.load_icon(gtk.STOCK_MISSING_IMAGE, size, 0)
glib.GError: Icon 'gtk-missing-image' not present in theme

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
monkey_boy (bobby-dogboneinc) wrote :

After messing around with it some more I was able to get it partially working. No icon in the tray and no candidate list is displayed but it will switch to Japanese with my shortcut key.

These are the steps I took to get it here

Purged my system of all Japanese system language, ibus and anthy packages to ensure I did not have a conflict.

Restarted the system

In the "System Languages" module I select Japanese however the only component I can select is "Translations", "Input methods" is grayed out.

Restarted the system

In the package manager I install "ibus-anthy" and its dependents(this included ibus-common).

Start the "Keyboard Input Method"(ibus-setup) config utility. It ask to start up the ibus deamon, I said OK. Then I got a message
  "IBus has been started! If you can not use IBus, please run System -> Administration -> Language Support and set the "Keyboard Input Method" to "ibus", then log out and back in again."
I set the keyboard method for English system language to ibus and set my ibus preferences are set the way I want.

Restarted the system

やった!! I can switch with my shortcut key.

The lack of a system tray icon and candidate list is still a bug that needs to be fixed.

I read above error message and just run "sudo apt-get install gnome-icon-theme".
It looks good to me.

zhangzhaowei (alphapolaris) wrote :

follow the way by Awshiro, it works.

Michal Sylwester (msylwester) wrote :

I just had same problem on Kubuntu 12.04 after fresh install (and some unrelated issues with getting anthy to work). Perhaps someone could add gnome-icon-theme as prerequisite to one of the ibus packages (I have no idea which one would be appropriate, perhaps just ibus?), this should easily solve this for everyone.

Xiaojun Ma (damage3025) on 2012-06-21
affects: ubuntu → ibus (Ubuntu)
Xiaojun Ma (damage3025) wrote :

Simply using "dpkg -L ibus" can show that the files related to the error is from "ibus" package.

So "ibus" should depends on "gnome-icon-theme".

It is certainly not the case now.
http://packages.debian.org/sid/ibus
http://packages.ubuntu.com/precise/ibus

So Kubuntu users still suffer from this bug over and over.
https://groups.google.com/group/ibus-user/browse_thread/thread/2569afaf8051328f

Xiaojun Ma (damage3025) on 2012-06-22
tags: added: packaging
Changed in ibus (Debian):
status: Unknown → New
Changed in ibus (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.4.1-7ubuntu1

---------------
ibus (1.4.1-7ubuntu1) quantal; urgency=low

  * Merge from Debian unstable (LP: #854333), remaining changes:
    - debian/control: Install im-switch instead of im-config by default.
    - debian/rules: Build with dh_translations. Add dh-translations build
      dependency.
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"
    - Add 05_appindicator.patch: Use an indicator rather than a notification
      icon. Add python-appindicator recommends.
    - debian/control: Recommends on ibus-gtk, ibus-qt4, ibus-clutter need to
      be alternatives, because we want derivatives to be able to pick the ones
      they need.
    - add ibus-530711-preload-sys.patch: Set default IMEngine.
      Taken from Fedora:
      https://bugzilla.redhat.com/show_bug.cgi?id=530711

ibus (1.4.1-7) unstable; urgency=low

  * Add dependency to gnome-icon-theme. Closes: #678422
  * Use Hardening Options.

ibus (1.4.1-6) unstable; urgency=low

  * Fix build-depend by adding python-dbus-dev. Closes: #673853

ibus (1.4.1-5) unstable; urgency=low

  * Fix multiarch bug for gir1.2-ibus-1.0. Closes: #669982
  * Add Suggests: ibus-doc. Closes: #666466

ibus (1.4.1-4) unstable; urgency=low

  * Fix FTBFS by cleaning up install. Closes: Bug#669545
  * Fix control for "Multi-Arch:".
 -- AWASHIRO Ikuya <email address hidden> Mon, 30 Jul 2012 17:01:16 +0900

Changed in ibus (Ubuntu):
status: Confirmed → Fix Released
Xiaojun Ma (damage3025) wrote :

Dear maintainers, thank you very much for your work!

Would you fix also cover 12.04? As is known to all, it is an LTS version~

Dennis Schridde (devurandom) wrote :

Has this been fixed for Ubuntu 12.04, yet?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.