a setting window flashes when ibus-chewing added into IBus which causes typing difficulty.

Bug #659690 reported by Hsin-Yi, Chen (hychen)
104
This bug affects 26 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Fix Released
High
Unassigned
ibus (Ubuntu)
Fix Released
Medium
Unassigned
Natty
Fix Released
Medium
Unassigned
ibus-chewing (Ubuntu)
Fix Released
Medium
Unassigned
Natty
Fix Released
Medium
Unassigned

Bug Description

Binary package hint: ibus

Dsitribution: Ubuntu Maverick
Package: ibus_1.3.7-1ubuntu3

Step to reproduce:
1. Press Ctrl + Space to active ibus-chewing
2. setup dialog of ibus-chewing flashes

What patch I attached does:

This patch let ibus does not try set input method engine many times when ibus-chewing actived by pressing Ctrl+Space that Tradintional Users can not type Chinese. After applied the patch, end user can type Chinese again.

This patch does not fix bug really, the setup dialog still flashs sometimes.

Tags: patch
Revision history for this message
Hsin-Yi, Chen (hychen) (ossug-hychen) wrote :
tags: added: patch
Revision history for this message
Hsin-Yi, Chen (hychen) (ossug-hychen) wrote :

Not sure if it happens in original ibus, but there is a problem after the following packages are installed.
from czchen reported, my patch has a problem, I will check it.

ii ibus 1.3.7-1ubuntu3hychen1 New input method framework using dbus
ii ibus-gtk 1.3.7-1ubuntu3hychen1 New input method framework using dbus
ii libibus2 1.3.7-1ubuntu3hychen1 New input method framework using dbus
ii python-ibus 1.3.7-1ubuntu3hychen1 New input method framework using dbus

Duplicate procedures:

1. Place -> Home Folder.
    The Nautilus will be opened

2. Change view to list view.
    This issue only happens in list view, icon view and compact view are okay.

3. Select a file and press F2 to rename it. (Or add a new file/folder by right click -> Create Folder/Create Document)

4. Cannot rename file because setting windows flashes.

This issue won't happen if ibus daemon is killed.

Revision history for this message
Perry Thompson (rypervenche) wrote :

Is there any way we can get this released? I have been asking for people to help me with the patch, but apparently it's rather difficult. I am also suffering from this bug https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/637671 which has a patch, and this one https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/660276 which has yet to be looked at.

I was told that I will have to wait until Natty for these to be fixed in the distribution, is that true? I can't go 6 months without being able to type in Chinese, and I am not downgrading.

Revision history for this message
Karl Lattimer (karl-qdh) wrote :

I have included this modification in my next patch for ibus, I'm currently in the process of debugging a series of issues and will be pushing the fixes out as soon as I can.

Changed in ibus (Ubuntu):
status: New → In Progress
assignee: nobody → Karl Lattimer (karl-qdh)
Changed in ibus-chewing (Ubuntu):
status: New → In Progress
assignee: nobody → Karl Lattimer (karl-qdh)
Steve Magoun (smagoun)
Changed in oem-priority:
importance: Undecided → High
Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
Changed in ibus-chewing (Ubuntu):
importance: Undecided → Medium
Changed in ibus (Ubuntu):
importance: Undecided → Medium
Changed in oem-priority:
assignee: Canonical Platform QA Team (canonical-platform-qa) → nobody
description: updated
description: updated
Revision history for this message
Hsin-Yi, Chen (hychen) (ossug-hychen) wrote :

This bug is fixed in ibus 1.3.7-1ubuntu4 in maverick-proposed

Input method I used: ibus-chewing 1.3.6-20100730-1

Changed in oem-priority:
status: New → Fix Committed
Karl Lattimer (karl-qdh)
Changed in ibus (Ubuntu Natty):
assignee: Karl Lattimer (karl-qdh) → nobody
status: In Progress → Fix Committed
Changed in ibus-chewing (Ubuntu Natty):
assignee: Karl Lattimer (karl-qdh) → nobody
status: In Progress → Fix Committed
Revision history for this message
Hsin-Yi, Chen (hychen) (ossug-hychen) wrote :

this bug is fixed-release in Natty

Revision history for this message
Hsin-Yi, Chen (hychen) (ossug-hychen) wrote :

verified this bug does not happen in Oneiric.

suggest move all status to Fix Released

Revision history for this message
Steve Magoun (smagoun) wrote :

Marking Fix Released based on comments #6 + 7

Changed in ibus (Ubuntu):
status: Fix Committed → Fix Released
Changed in ibus (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in ibus-chewing (Ubuntu):
status: Fix Committed → Fix Released
Changed in ibus-chewing (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers