Please merge ibus (1.3.7-1) from Debian Squeeze

Bug #611224 reported by Aron Xu on 2010-07-29
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ibus

Please merge the latest ibus (1.3.7-1) from Debian, it provides lots of exciting new features which results in a better user experience, updating it will also benefit Ubuntu maintenance with a better upstream support.

PTS: http://packages.qa.debian.org/i/ibus.html
DSC: http://ftp.debian.org/debian/pool/main/i/ibus/ibus_1.3.7-1.dsc

Debian changelog since last Ubuntu sync/merge:

 ibus (1.3.7-1) unstable; urgency=low

   [ Asias He ]
   * New upstream release.
   * debian/control: bump standards version to 3.9.1.
   * debian/libibus2.symbols: updated.
   * debian/control: added im-config to Recommends (closes: #587269)

 -- LI Daobing <email address hidden> Wed, 04 Aug 2010 21:47:44 +0800

 ibus (1.3.6-1) unstable; urgency=low

   [ Asias He ]
   * New upstream release. (closes: #586976)
   * debian/libibus2.symbols: updated.
   * debian/patches/*: updated.
   * debian/control: bump standards version to 3.9.0.
   * debian/ibus.install: updated.
   * debian/libibus-dev.install: updated.

   [ LI Daobing ]
   * debian/control: replaces and breaks ibus (<< 1.3.6)

 -- LI Daobing <email address hidden> Tue, 06 Jul 2010 16:02:22 +0800
ibus (1.3.5-1) unstable; urgency=low

   [ Asias He ]
   * New upstream release.
   * debian/libibus2.symbols: updated.

 -- LI Daobing <email address hidden> Sat, 12 Jun 2010 19:37:05 +0800
ibus (1.3.4-1) unstable; urgency=low

   [ Asias He ]
   * New upstream release.

   [ LI Daobing ]
   * debian/libibus2.symbols: updated.

 -- LI Daobing <email address hidden> Sun, 30 May 2010 10:35:47 +0800
ibus (1.3.3-1) unstable; urgency=low

   * New upstream release.

 -- LI Daobing <email address hidden> Thu, 06 May 2010 19:42:32 +0800
ibus (1.3.2-1) unstable; urgency=low

   * New upstream release.
   * debian/libibus2.symbols: updated.
   * debian/control:
     - change maintainer to IME Packaging Team, add me to uploaders.
     - update Vcs-* fields.

 -- LI Daobing <email address hidden> Thu, 29 Apr 2010 19:51:08 +0800
ibus (1.3.1-2) unstable; urgency=low

   * Fix "Please fix python-notify dependancy" (Closes: #577587)
     - debian/control: ibus depends on python-notify
   * improve manpages (Closes: #562542)
     - debian/ibus.1 -> debian/ibus.7, and add setup information.
     - debian/ibus-daemon.1: updated.
     - debian/ibus-setup.1: updated.
     - debian/ibus-gconf.1, debian/ibus-ui-gtk.1, debian/ibus-x11.1: removed.
     - debian/ibus.manpages: updated.
   * debian/source/format: 3.0.
     - remove dpatch, update debian/control, debian/rules, debian/patches

 -- LI Daobing <email address hidden> Wed, 14 Apr 2010 20:59:30 +0800
ibus (1.3.1-1) unstable; urgency=low

   * New upstream release.

 -- LI Daobing <email address hidden> Sat, 03 Apr 2010 18:53:10 +0800
ibus (1.3.0-1) experimental; urgency=low

   * New upstream release.
   * debian/source/format: missing-debian-source-format
   * debian/libibus2.symbols: updated.

 -- LI Daobing <email address hidden> Wed, 24 Mar 2010 20:47:49 +0800

Benjamin Drung (bdrung) wrote :

There is no debdiff or bzr branch to sponsor. Therefore unsubscribing ubuntu-sponsors.

Arne Goetje (arnegoetje) wrote :

I'm working on the merge to version 1.3.7-1 now. However, it would be nice if the patches could be rewritten, so that they can be sent to upstream for inclusion. 01-ubuntu_desktop clearly qualifies for being applied upstream. 02_title_update.dpatch should get updated, so that it can be used in Debian and Ubuntu (check if distribution is Debian/Ubuntu and if im-switch is present, then display different strings than in upstream). 05_appindicator.dpatch and 06_show_menuitem.dpatch: I don't know enough about appindicator and GTK in order to comment on that. But it would be nice if those code changes could also go into upstream, maybe with a check if appindicator is present on the system...

Changed in ibus (Ubuntu):
assignee: nobody → Arne Goetje (arnegoetje)
importance: Undecided → Medium
milestone: none → ubuntu-10.10-beta
status: New → In Progress

On Fri, Aug 6, 2010 at 3:05 PM, Arne Goetje <email address hidden>wrote:

> 05_appindicator.dpatch and 06_show_menuitem.dpatch

these two also need to be updated accordingly.

Aron Xu (happyaron) on 2010-08-07
description: updated
summary: - Please merge ibus (1.3.6-1) from Debian Squeeze
+ Please merge ibus (1.3.7-1) from Debian Squeeze
Xhacker Liu (xhacker) wrote :

Please sync ibus-pinyin from Debian as well, thanks.

Sebastien Bacher (seb128) wrote :

Thanks for the work there, Luke could you review if the changes are correct and sponsor that? The indicator patch is being reworked by dx so we can probably rebase and fix that once the new version is in but can you check the other packaging changes?

Changed in ibus (Ubuntu):
assignee: Arne Goetje (arnegoetje) → Luke Yelavich (themuso)
Sebastien Bacher (seb128) wrote :

In fact the launchpad diff didn't really reflect the changes, it's easier than it seemed and I will do it now

Changed in ibus (Ubuntu):
assignee: Luke Yelavich (themuso) → nobody
Changed in ibus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.3.7-1ubuntu1

---------------
ibus (1.3.7-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable (LP: #611224), remaining changes:
    - debian/control: Add python-appindicator recommends.
    - Patches (adjusted, to work with the new version):
      + 02_title_update.dpatch
      + 05_appindicator.dpatch
      + 06_show_menuitem.dpatch

ibus (1.3.7-1) unstable; urgency=low

  [ Asias He ]
  * New upstream release.
  * debian/control: bump standards version to 3.9.1.
  * debian/libibus2.symbols: updated.
  * debian/control: added im-config to Recommends (closes: #587269)

ibus (1.3.6-1) unstable; urgency=low

  [ Asias He ]
  * New upstream release. (closes: #586976)
  * debian/libibus2.symbols: updated.
  * debian/patches/*: updated.
  * debian/control: bump standards version to 3.9.0.
  * debian/ibus.install: updated.
  * debian/libibus-dev.install: updated.

  [ LI Daobing ]
  * debian/control: replaces and breaks ibus (<< 1.3.6)

ibus (1.3.5-1) unstable; urgency=low

  [ Asias He ]
  * New upstream release.
  * debian/libibus2.symbols: updated.

ibus (1.3.4-1) unstable; urgency=low

  [ Asias He ]
  * New upstream release.

  [ LI Daobing ]
  * debian/libibus2.symbols: updated.

ibus (1.3.3-1) unstable; urgency=low

  * New upstream release.

ibus (1.3.2-1) unstable; urgency=low

  * New upstream release.
  * debian/libibus2.symbols: updated.
  * debian/control:
    - change maintainer to IME Packaging Team, add me to uploaders.
    - update Vcs-* fields.

ibus (1.3.1-2) unstable; urgency=low

  * Fix "Please fix python-notify dependancy" (Closes: #577587)
    - debian/control: ibus depends on python-notify
  * improve manpages (Closes: #562542)
    - debian/ibus.1 -> debian/ibus.7, and add setup information.
    - debian/ibus-daemon.1: updated.
    - debian/ibus-setup.1: updated.
    - debian/ibus-gconf.1, debian/ibus-ui-gtk.1, debian/ibus-x11.1: removed.
    - debian/ibus.manpages: updated.
  * debian/source/format: 3.0.
    - remove dpatch, update debian/control, debian/rules, debian/patches

ibus (1.3.1-1) unstable; urgency=low

  * New upstream release.

ibus (1.3.0-1) experimental; urgency=low

  * New upstream release.
  * debian/source/format: missing-debian-source-format
  * debian/libibus2.symbols: updated.

ibus (1.2.99.20100202-1) experimental; urgency=low

  * New upstream release.
  * debian/control: bump standards version to 3.8.4.
  * libibus1 -> libibus2 transition:
    - debian/control: updated
    - debian/libibus1.*: deleted
    - debian/libibus2.*: added
    - debian/rules: updated.
 -- Arne Goetje <email address hidden> Fri, 06 Aug 2010 19:30:57 +0800

Changed in ibus (Ubuntu):
status: Fix Committed → Fix Released
ZhengPeng Hou (zhengpeng-hou) wrote :

Actually, the merge still doesn't work at all, hope 05_appindicator.dpatch and 06_show_menuitem.dpatch can be dropped as soon as possible.

Changed in ibus (Ubuntu):
status: Fix Released → New
Sebastien Bacher (seb128) wrote :

the source has been merged, that issue is closed the other issues should get new bugs describing what is wrong

Changed in ibus (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers