Panel no longer shows which input method is being used

Bug #564034 reported by Matthew Paul Thomas on 2010-04-15
102
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Ayatana Ubuntu
High
Karl Lattimer
libindicator
Fix Released
Undecided
Unassigned
ibus (Ubuntu)
Critical
Karl Lattimer
Lucid
Undecided
Canonical Desktop Team

Bug Description

Binary package hint: ibus

In ibus 1.2.0.20091215-1ubuntu3 and 1.2.0.20091215-1ubuntu2, IBus was changed to use a custom status menu ("application indicator") instead of a notification area item.

Application indicators currently do not allow bitmap icons. So in bug 528213, the new indicator was altered to use a generic keyboard icon instead of the icon representing the current input method whenever the latter is a bitmap -- which is most of the time.

This makes it unreasonably difficult to tell what input method you are currently using. According to Emmet Hikory, this problem will affect anyone who uses IBus to type Chinese, Japanese, or Korean, who uses an input method that does not cover all the characters they use, but who does not use a dedicated keyboard with specific keys for changing input method.

Because of the number of people this affects, I think this may deserve fixing for Ubuntu 10.04, even though we're past Final Freeze. As I understand it, fixing it would involve removing 05_appindicator.dpatch from the package.

Problem occurs in: Ubuntu Lucid
Does not occur in: Ubuntu 9.10

Related branches

Matthew Paul Thomas (mpt) wrote :
Matthew Paul Thomas (mpt) wrote :
tags: added: regression-potential
Sebastien Bacher (seb128) wrote :

Seems the indicator limitations don't allow to fix that properly for lucid, we should consider dropping the application indicator change in lucid maybe there

Changed in ibus (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in ibus (Ubuntu Lucid):
status: New → Confirmed

Won't fixing the Lucid task. The product is baked, and changes of this magnitude are out of scope. Should be addressed in Maverick, and perhaps enhance lipindicate to handle this better.

Changed in ibus (Ubuntu Lucid):
status: Confirmed → Won't Fix
Roy (rdstrac) wrote :

Since Lucid is a long term support version, this problem could hang around for years. I could possibly see ignoring the problem in a normal release but this could be a problem for International business and should be fixed ASAP. As I understand it, LTS releases are there to encourage business use. This is sending the wrong message.

Sebastien Bacher (seb128) wrote :

> could be a problem for International business and should be fixed ASAP

Thank you for your interest in the issue but usually telling volunteers what they should be doing asap doesn't work quite the contrary.

Tt would be nice to start to explain how it's an important issue because so far the bug has been opened by somebody not using ibus and no user complained about it yet. we might want to look at it but there has been no indication so far the issue is considered as important by the Ubuntu user base.

Changed in ibus (Ubuntu):
importance: Undecided → Low
Rossen Apostolov (rapostolo) wrote :

I confirm the bug and agree that this is a problem for multi-language users that should be resolved.

Aleksei Gusev (hron) wrote :

I also confirm the bug and agree that this is a real problem for me.

Toshio Ito (debug-ito) wrote :

I use Japanese input method (ibus-anthy) and this bug affects me also. I wish the bug would be fixed in Lucid.
However I don't think the bug is REALLY important (at least for Japanese people),
because you can tell which input method is used by showing the language bar when ibus-anthy is activated.
I like the language bar not to be shown at any time (it consumes my precious desktop space),
but it is a small regression.

Jorge Castro (jorge) wrote :

Karl,

Information on the upstream conversation is here: http://code.google.com/p/ibus/issues/detail?id=780
Original distro bug about the patch is bug #497878

Changed in ibus (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Karl Lattimer (karl-qdh)
importance: Low → High
milestone: none → maverick-alpha-3
Matthew Paul Thomas (mpt) wrote :

I think there are two short-term ways of fixing this problem.
1. Extend the menu code so that a bitmap can be used as the icon in a menu title (with the bitmap being scaled to suit the panel size).
2. Change iBus so that it converts the bitmap for each input method to a vector graphic (consisting of lots of little squares), and then passes that vector graphic to be used as the menu title.

The long-term way to fix the problem is to redraw the icon for each input method as a genuine vector graphic, so that (a) it works regardless of panel size, and (b) it uses symbolic icon colors, making it resilient to theme changes. Many of these vector graphics could be functionally generated, as they seem to be currently. Pseudocode examples:
    icon(greek) = overlay_glyph_with_caption("Ω", "KBD")
    icon(armenian) = overlay_glyph_with_caption("ក", "YNS")

Karl Lattimer (karl-qdh) wrote :

The best solution here would be to follow MPT's suggetion No. 1, in theory this would be supported by the theme, and therefore there's space to replace all of the icons with SVGs in the future. Rendering and scaling shouldn't be a problem and it appears to be the best solution.

I will start looking into adding bitmap loading to indicator-applet.

Karl Lattimer (karl-qdh) wrote :

The attached patch is part 1, an updated appindicator patch for ibus is also required, but I've got this working nicely.
This patch is against libindicator, and should probably be tagged against that.

Tomorrow I will cook the patch for ibus, which requires a bit more hackery as it's on top of a previous patch and I'd like them to be one.

The API for this is somewhat obscured in that if it fails to do anything else, it will load an absolute path, if that fails then fail...
There is no sense in publicising this API or documenting it.

tags: added: patch
Karl Lattimer (karl-qdh) wrote :

This patch fixes a few different things, firstly menu was being called with add, which just isn't proper so this has been replaced with append. Also, the items *MUST* be shown before they are added or else the signal gets lost. This is really not ideal but it works for now, and doesn't do any harm, easy to get stung with this bug.

Some investigation into the app indicator python bindings required in order to discover the root cause of this issue.

Jorge Castro (jorge) on 2010-07-26
Changed in ibus (Ubuntu):
assignee: Karl Lattimer (karl-qdh) → Canonical Desktop Team (canonical-desktop-team)
Sebastien Bacher (seb128) wrote :

Ted, could you review the libindicator change there?

Karl Lattimer (karl-qdh) wrote :

re-tested my patch today and it seems that showing the menu item only makes it more reliable and still not 100% reliable :/ bugs a plenty in gtk signalling hopefully already fixed and waiting packaging...

Sebastien Bacher (seb128) wrote :

does the ibus change depends on the libindicate one?

Karl Lattimer (karl-qdh) on 2010-08-05
Changed in libindicator:
status: New → Fix Committed
status: Fix Committed → In Progress
Sebastien Bacher (seb128) wrote :

Ted, could you review Karl's changes?

Changed in ibus (Ubuntu):
milestone: maverick-alpha-3 → ubuntu-10.10-beta
Ted Gould (ted) wrote :

Karl,

Are you finished with the libindicator work? I noticed there is a branch, but it hasn't be proposed for merging. Also, it looks like it's based on the packaging branch instead of the upstream branch. If you could make it against lp:libindicator that would make merging it easier.

Thanks,
Ted

Karl Lattimer (karl-qdh) wrote :

This isn't a complete branch right now, I still want to add the further *try and find a theme icon* strategy by splitting the filename that we get. Bare in mind, I consider these additions fall backs rather than API, I think it's best not to advertise the fact that we're hacking around some icon path problems.

Karl Lattimer (karl-qdh) wrote :

@Ted, I've updated the branch and will make a merge request, the further features for ibus can wait until after feature freeze

Sebastien Bacher (seb128) wrote :

Karl, could you clarify what needs to land and in which order? Seems the libindicate review has been approved, what do we need to do once that one lands?

Karl Lattimer (karl-qdh) wrote :

Well, once the libindicate package has been released the ibus package can be updated to include the patch attached here replacing the existing patch. That'll be it.

Ted Gould (ted) on 2010-08-12
Changed in libindicator:
milestone: none → 0.3.11
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

Karl, we got a new ibus uploaded, do you think you could update the patch to that version tomorrow (or today when you will read this comment)?

Changed in ibus (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Karl Lattimer (karl-qdh)
Karl Lattimer (karl-qdh) on 2010-08-13
Changed in ibus (Ubuntu):
status: Confirmed → In Progress
Karl Lattimer (karl-qdh) wrote :

As requested updated patch

Changed in ibus (Ubuntu):
assignee: Karl Lattimer (karl-qdh) → nobody
Sebastien Bacher (seb128) wrote :

could you describe how to get the icon to show?

Karl Lattimer (karl-qdh) wrote :

You have to add a bunch of input methods i added korean and english and then you switch between them by clicking them in the list. It changes icon when in a window which will accept input using the selected method.

Karl Lattimer (karl-qdh) wrote :

Replaces previous patch

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.3.7-1ubuntu2

---------------
ibus (1.3.7-1ubuntu2) maverick; urgency=low

  * debian/patches/05_appindicator.patch:
    - updated by Karl Lattimer, the icon reflect the input method now
      (lp: #564034)
  * debian/patches: rename the changes, dpatch has been replaced with quilt now
 -- Sebastien Bacher <email address hidden> Fri, 13 Aug 2010 13:48:19 +0200

Changed in ibus (Ubuntu):
status: In Progress → Fix Released
ZhengPeng Hou (zhengpeng-hou) wrote :

The latest upload still hasn't fix it yet, I propose to drop indicator support to ibus, since indicator support can't be merged into upstream in a short while, and Input Method is a very very important fundamental application for most non-latin users, so sync it from Debian directly might make more sense. And we all know there is no a team in Ubuntu can take care all those IM related package, so leverage the work in Debian might be the easiest way for both Ubuntu developer and users.

Changed in ibus (Ubuntu):
importance: High → Critical
status: Fix Released → New
Karl Lattimer (karl-qdh) wrote :

This bug is certainly fixed.

Can you ensure that you have the latest libindicate and ibus installed?

Can you indicate the behaviour you're experiencing?

YunQiang Su (wzssyqa) wrote :

I can confirm this bug.

Once I upgrade ibus to the one in repo,this occered

Changed in ibus (Ubuntu):
status: New → Confirmed
Download full text (4.1 KiB)

On Sun, Aug 15, 2010 at 9:06 PM, Karl Lattimer <email address hidden> wrote:

> This bug is certainly fixed.
>
> Can you ensure that you have the latest libindicate and ibus installed?
>
 freeflying@zphou:/tmp$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu maverick (development branch)
Release: 10.10
Codename: maverick
freeflying@zphou:/tmp$ dpkg -l |grep ibus
ii ibus 1.3.7-1ubuntu2
             New input method framework using dbus
ii ibus-gtk 1.3.7-1ubuntu2
             New input method framework using dbus
freeflying@zphou:/tmp$ dpkg -l |grep indicator
ii evolution-indicator 0.2.10-0ubuntu1
              GNOME panel indicator applet for Evolution
ii indicator-applet 0.4.3-0ubuntu1
             GNOME panel indicator applet
ii indicator-applet-session 0.4.3-0ubuntu1
             Clone of the GNOME panel indicator applet
ii indicator-application 0.2.3-0ubuntu2
             Application Indicators
ii indicator-appmenu 0.0.9-0ubuntu1
             Indicator for application menus.
ii indicator-datetime 0.0.5-0ubuntu2
             A very, very simple clock
ii indicator-me 0.2.6-0ubuntu2
             indicator showing user information and status
ii indicator-messages 0.3.9-0ubuntu1
             indicator that collects messages that need a response
ii indicator-session 0.2.10-0ubuntu1
              An indicator showing session management, status and user
switching.
ii indicator-sound 0.3.9-0ubuntu2
             A system sound indicator.
ii libappindicator0 0.2.3-0ubuntu2
             Application Indicators
ii libappindicator0.1-cil 0.2.3-0ubuntu2
             CLI bindings for libappindicator
ii libindicate-gtk2 0.4.1-0ubuntu2
             GNOME panel indicator applet - shared library
ii libindicate4 0.4.1-0ubuntu2
             GNOME panel indicator applet - shared library
ii libindicator0 0.3.11-0ubuntu2
              panel indicator applet - shared library
ii python-appindicator 0.2.3-0ubuntu2
             Python bindings for libappindicator

> Can you indicate the behaviour you're experiencing?
>
There should have a icon in notification area to notify which IME is being
used, but now, this icon doesn't show up.

>
> --
> Panel no longer shows which input method is being used
> https://bugs.launchpad.net/bugs/564034
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (617865).
>
> Status in Libindicator: Fix Released
> Status in “ibus” package in Ubuntu: New
> Status in “ibus” source package in Lucid: Won't Fix
>
> Bug description:
> Binary package hint: ibus
>
> In ibus 1.2.0.20091215-1ubuntu3 and 1.2.0.20091215-1ubuntu2, IBus was
> changed to use a custom status menu ("application indicator") instead of a
> notification area item.
>
> Application indicators currently do not allo...

Read more...

ZhengPeng Hou (zhengpeng-hou) wrote :

On Sun, Aug 15, 2010 at 9:06 PM, Karl Lattimer <email address hidden> wrote:

> This bug is certainly fixed.
>
I'm not sure how did you do the test to confirm its been fixed certainly.

>
> Can you ensure that you have the latest libindicate and ibus installed?
>
> Can you indicate the behaviour you're experiencing?
>
> --
> Panel no longer shows which input method is being used
> https://bugs.launchpad.net/bugs/564034
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (617865).
>
> Status in Libindicator: Fix Released
> Status in “ibus” package in Ubuntu: New
> Status in “ibus” source package in Lucid: Won't Fix
>
> Bug description:
> Binary package hint: ibus
>
> In ibus 1.2.0.20091215-1ubuntu3 and 1.2.0.20091215-1ubuntu2, IBus was
> changed to use a custom status menu ("application indicator") instead of a
> notification area item.
>
> Application indicators currently do not allow bitmap icons. So in bug
> 528213, the new indicator was altered to use a generic keyboard icon instead
> of the icon representing the current input method whenever the latter is a
> bitmap -- which is most of the time.
>
> This makes it unreasonably difficult to tell what input method you are
> currently using. According to Emmet Hikory, this problem will affect anyone
> who uses IBus to type Chinese, Japanese, or Korean, who uses an input method
> that does not cover all the characters they use, but who does not use a
> dedicated keyboard with specific keys for changing input method.
>
> Because of the number of people this affects, I think this may deserve
> fixing for Ubuntu 10.04, even though we're past Final Freeze. As I
> understand it, fixing it would involve removing 05_appindicator.dpatch from
> the package.
>
> Problem occurs in: Ubuntu Lucid
> Does not occur in: Ubuntu 9.10
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/libindicator/+bug/564034/+subscribe
>

Karl Lattimer (karl-qdh) wrote :

http://dl.dropbox.com/u/889043/ibus-open.png

this is a screenshot of the fixed bug, can you tell me what you see, and which distribution you are using, this has ONLY been fixed in maverick.

Karl Lattimer (karl-qdh) wrote :

This is possibly related to a packing problem which has occurred between 1.2.0 and 1.3.7 the packaging issue means the ibus-m17n package has been removed and the files it provides have not been replaced in any other package.

In order to test this, please add another input method, i.e. ibus-latex which doesn't rely on the m17n package

ZhengPeng Hou (zhengpeng-hou) wrote :

For CJK end users, we're using ibus+ibus-pinyin/anthy/chewing, what I can
tell, the latest upload of ibus can't make it work with latest ibus-pinyin
in my ppa.
On Sun, Aug 15, 2010 at 9:37 PM, Karl Lattimer <email address hidden> wrote:

> This is possibly related to a packing problem which has occurred between
> 1.2.0 and 1.3.7 the packaging issue means the ibus-m17n package has been
> removed and the files it provides have not been replaced in any other
> package.
>
> In order to test this, please add another input method, i.e. ibus-latex
> which doesn't rely on the m17n package
>
>

> --
> Panel no longer shows which input method is being used
> https://bugs.launchpad.net/bugs/564034
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (617865).
>
> Status in Libindicator: Fix Released
> Status in “ibus” package in Ubuntu: Confirmed
> Status in “ibus” source package in Lucid: Won't Fix
>
> Bug description:
> Binary package hint: ibus
>
> In ibus 1.2.0.20091215-1ubuntu3 and 1.2.0.20091215-1ubuntu2, IBus was
> changed to use a custom status menu ("application indicator") instead of a
> notification area item.
>
> Application indicators currently do not allow bitmap icons. So in bug
> 528213, the new indicator was altered to use a generic keyboard icon instead
> of the icon representing the current input method whenever the latter is a
> bitmap -- which is most of the time.
>
> This makes it unreasonably difficult to tell what input method you are
> currently using. According to Emmet Hikory, this problem will affect anyone
> who uses IBus to type Chinese, Japanese, or Korean, who uses an input method
> that does not cover all the characters they use, but who does not use a
> dedicated keyboard with specific keys for changing input method.
>
> Because of the number of people this affects, I think this may deserve
> fixing for Ubuntu 10.04, even though we're past Final Freeze. As I
> understand it, fixing it would involve removing 05_appindicator.dpatch from
> the package.
>
> Problem occurs in: Ubuntu Lucid
> Does not occur in: Ubuntu 9.10
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/libindicator/+bug/564034/+subscribe
>

Karl Lattimer (karl-qdh) wrote :

The latest release doesn't include the updated patch in comment #28, other than that the following dbus error is observed when testing with the above patch;

Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/panel.py", line 533, in __im_menu_item_activate_cb
    focus_ic.set_engine(engine)
  File "/usr/lib/pymodules/python2.6/ibus/inputcontext.py", line 239, in set_engine
    return self.__context.SetEngine(engine.name)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.IBus.NoEngine: can not find engine with name m17n:ko:han2

This problem has crept in from *somewhere* since Friday when I last tested the 1.3.7 patch, sorry for the inconvenience.

Karl Lattimer (karl-qdh) wrote :

This seems to be my error as it doesn't occur with the notification area icon at all. I'll try and debug this further.

Karl Lattimer (karl-qdh) on 2010-08-17
Changed in ibus (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
status: Confirmed → In Progress
Karl Lattimer (karl-qdh) wrote :

This seems heavily dependent on some dbus stuff, possibly related to changes in dbusmenu, possibly some other changes in libindicator, still requires more investigation but could be a problem elsewhere still.

David Barth (dbarth) on 2010-08-18
Changed in ayatana-ubuntu:
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → High
milestone: none → ubuntu-10.10-beta
status: New → In Progress
Karl Lattimer (karl-qdh) wrote :

I have uploaded my fixed and tested ibus package to the following ppa: https://launchpad.net/~karl-qdh/+archive/ppa

The libindicator update is due either tonight or tomorrow, the libindicator update is required to show the icons.

ZhengPeng Hou, YunQiang Su I hope you both can find the time to test this fix

YunQiang Su (wzssyqa) wrote :

yes, it appears on indicator,now.
good job.

On Thu, Aug 19, 2010 at 12:27 AM, Karl Lattimer <email address hidden> wrote:
> I have uploaded my fixed and tested ibus package to the following ppa:
> https://launchpad.net/~karl-qdh/+archive/ppa
>
> The libindicator update is due either tonight or tomorrow, the
> libindicator update is required to show the icons.
>
> ZhengPeng Hou, YunQiang Su I hope you both can find the time to test
> this fix
>
> --
> Panel no longer shows which input method is being used
> https://bugs.launchpad.net/bugs/564034
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (617865).
>
> Status in Ayatana Ubuntu Love Project: In Progress
> Status in Libindicator: Fix Released
> Status in “ibus” package in Ubuntu: In Progress
> Status in “ibus” source package in Lucid: Won't Fix
>
> Bug description:
> Binary package hint: ibus
>
> In ibus 1.2.0.20091215-1ubuntu3 and 1.2.0.20091215-1ubuntu2, IBus was changed to use a custom status menu ("application indicator") instead of a notification area item.
>
> Application indicators currently do not allow bitmap icons. So in bug 528213, the new indicator was altered to use a generic keyboard icon instead of the icon representing the current input method whenever the latter is a bitmap -- which is most of the time.
>
> This makes it unreasonably difficult to tell what input method you are currently using. According to Emmet Hikory, this problem will affect anyone who uses IBus to type Chinese, Japanese, or Korean, who uses an input method that does not cover all the characters they use, but who does not use a dedicated keyboard with specific keys for changing input method.
>
> Because of the number of people this affects, I think this may deserve fixing for Ubuntu 10.04, even though we're past Final Freeze. As I understand it, fixing it would involve removing 05_appindicator.dpatch from the package.
>
> Problem occurs in: Ubuntu Lucid
> Does not occur in: Ubuntu 9.10
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-ubuntu/+bug/564034/+subscribe
>

--
YunQiang Su

Xhacker Liu (xhacker) wrote :

Updating to the ppa version, the bug fixed with 4 issues:
1. the icon is too close to the top of the screen.
2. click the icon, it will change to the general one (a keyboard).
3. i can't call the preference dialog while the input method starts.
4. embedded input method properties doesn't work.

Karl Lattimer (karl-qdh) wrote :

This patch improves the app indicator by adding radio menu items to be consistent with the g-s-d keyboard indicator, one string is changed in this patch to allow for the new menu.

"Turn off input method" -> "Input method Off"

This is only a minor improvement, and any other issues are still waiting to be addressed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.3.7-1ubuntu3

---------------
ibus (1.3.7-1ubuntu3) maverick; urgency=low

  * debian/patches/05_appindicator.patch:
    - updated by Karl Lattimer to fix issues with the previous version...
      (lp: #564034)
  * clean other changes creating issues
 -- Sebastien Bacher <email address hidden> Fri, 20 Aug 2010 16:52:18 +0200

Changed in ibus (Ubuntu):
status: In Progress → Fix Released
YunQiang Su (wzssyqa) wrote :

Should update ibus-pinyin and ibus-table-wubi ?

On Fri, Aug 20, 2010 at 11:00 PM, Launchpad Bug Tracker
<email address hidden> wrote:
> This bug was fixed in the package ibus - 1.3.7-1ubuntu3
>
> ---------------
> ibus (1.3.7-1ubuntu3) maverick; urgency=low
>
>  * debian/patches/05_appindicator.patch:
>    - updated by Karl Lattimer to fix issues with the previous version...
>      (lp: #564034)
>  * clean other changes creating issues
>  -- Sebastien Bacher <email address hidden>   Fri, 20 Aug 2010 16:52:18 +0200
>
> ** Changed in: ibus (Ubuntu)
>       Status: In Progress => Fix Released
>
> --
> Panel no longer shows which input method is being used
> https://bugs.launchpad.net/bugs/564034
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (617865).
>
> Status in Ayatana Ubuntu Love Project: In Progress
> Status in Libindicator: Fix Released
> Status in “ibus” package in Ubuntu: Fix Released
> Status in “ibus” source package in Lucid: Won't Fix
>
> Bug description:
> Binary package hint: ibus
>
> In ibus 1.2.0.20091215-1ubuntu3 and 1.2.0.20091215-1ubuntu2, IBus was changed to use a custom status menu ("application indicator") instead of a notification area item.
>
> Application indicators currently do not allow bitmap icons. So in bug 528213, the new indicator was altered to use a generic keyboard icon instead of the icon representing the current input method whenever the latter is a bitmap -- which is most of the time.
>
> This makes it unreasonably difficult to tell what input method you are currently using. According to Emmet Hikory, this problem will affect anyone who uses IBus to type Chinese, Japanese, or Korean, who uses an input method that does not cover all the characters they use, but who does not use a dedicated keyboard with specific keys for changing input method.
>
> Because of the number of people this affects, I think this may deserve fixing for Ubuntu 10.04, even though we're past Final Freeze. As I understand it, fixing it would involve removing 05_appindicator.dpatch from the package.
>
> Problem occurs in: Ubuntu Lucid
> Does not occur in: Ubuntu 9.10
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-ubuntu/+bug/564034/+subscribe
>

--
YunQiang Su

YunQiang Su (wzssyqa) wrote :

Now icon of ibus is in notify area, is it ?

On Sat, Aug 21, 2010 at 12:41 AM, YunQiang Su <email address hidden> wrote:
> Should update ibus-pinyin and ibus-table-wubi ?
>
> On Fri, Aug 20, 2010 at 11:00 PM, Launchpad Bug Tracker
> <email address hidden> wrote:
>> This bug was fixed in the package ibus - 1.3.7-1ubuntu3
>>
>> ---------------
>> ibus (1.3.7-1ubuntu3) maverick; urgency=low
>>
>>  * debian/patches/05_appindicator.patch:
>>    - updated by Karl Lattimer to fix issues with the previous version...
>>      (lp: #564034)
>>  * clean other changes creating issues
>>  -- Sebastien Bacher <email address hidden>   Fri, 20 Aug 2010 16:52:18 +0200
>>
>> ** Changed in: ibus (Ubuntu)
>>       Status: In Progress => Fix Released
>>
>> --
>> Panel no longer shows which input method is being used
>> https://bugs.launchpad.net/bugs/564034
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug (617865).
>>
>> Status in Ayatana Ubuntu Love Project: In Progress
>> Status in Libindicator: Fix Released
>> Status in “ibus” package in Ubuntu: Fix Released
>> Status in “ibus” source package in Lucid: Won't Fix
>>
>> Bug description:
>> Binary package hint: ibus
>>
>> In ibus 1.2.0.20091215-1ubuntu3 and 1.2.0.20091215-1ubuntu2, IBus was changed to use a custom status menu ("application indicator") instead of a notification area item.
>>
>> Application indicators currently do not allow bitmap icons. So in bug 528213, the new indicator was altered to use a generic keyboard icon instead of the icon representing the current input method whenever the latter is a bitmap -- which is most of the time.
>>
>> This makes it unreasonably difficult to tell what input method you are currently using. According to Emmet Hikory, this problem will affect anyone who uses IBus to type Chinese, Japanese, or Korean, who uses an input method that does not cover all the characters they use, but who does not use a dedicated keyboard with specific keys for changing input method.
>>
>> Because of the number of people this affects, I think this may deserve fixing for Ubuntu 10.04, even though we're past Final Freeze. As I understand it, fixing it would involve removing 05_appindicator.dpatch from the package.
>>
>> Problem occurs in: Ubuntu Lucid
>> Does not occur in: Ubuntu 9.10
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/ayatana-ubuntu/+bug/564034/+subscribe
>>
>
>
>
> --
> YunQiang Su
>

--
YunQiang Su

Xhacker Liu (xhacker) wrote :

It's another issue. (Bug #526499)

2010/8/22 YunQiang Su <email address hidden>

> Now icon of ibus is in notify area, is it ?
>
> On Sat, Aug 21, 2010 at 12:41 AM, YunQiang Su <email address hidden> wrote:
> > Should update ibus-pinyin and ibus-table-wubi ?
> >
> > On Fri, Aug 20, 2010 at 11:00 PM, Launchpad Bug Tracker
> > <email address hidden> wrote:
> >> This bug was fixed in the package ibus - 1.3.7-1ubuntu3
> >>
> >> ---------------
> >> ibus (1.3.7-1ubuntu3) maverick; urgency=low
> >>
> >> * debian/patches/05_appindicator.patch:
> >> - updated by Karl Lattimer to fix issues with the previous version...
> >> (lp: #564034)
> >> * clean other changes creating issues
> >> -- Sebastien Bacher <email address hidden> Fri, 20 Aug 2010 16:52:18
> +0200
> >>
> >> ** Changed in: ibus (Ubuntu)
> >> Status: In Progress => Fix Released
> >>
> >> --
> >> Panel no longer shows which input method is being used
> >> https://bugs.launchpad.net/bugs/564034
> >> You received this bug notification because you are a direct subscriber
> >> of a duplicate bug (617865).
> >>
> >> Status in Ayatana Ubuntu Love Project: In Progress
> >> Status in Libindicator: Fix Released
> >> Status in “ibus” package in Ubuntu: Fix Released
> >> Status in “ibus” source package in Lucid: Won't Fix
> >>
> >> Bug description:
> >> Binary package hint: ibus
> >>
> >> In ibus 1.2.0.20091215-1ubuntu3 and 1.2.0.20091215-1ubuntu2, IBus was
> changed to use a custom status menu ("application indicator") instead of a
> notification area item.
> >>
> >> Application indicators currently do not allow bitmap icons. So in bug
> 528213, the new indicator was altered to use a generic keyboard icon instead
> of the icon representing the current input method whenever the latter is a
> bitmap -- which is most of the time.
> >>
> >> This makes it unreasonably difficult to tell what input method you are
> currently using. According to Emmet Hikory, this problem will affect anyone
> who uses IBus to type Chinese, Japanese, or Korean, who uses an input method
> that does not cover all the characters they use, but who does not use a
> dedicated keyboard with specific keys for changing input method.
> >>
> >> Because of the number of people this affects, I think this may deserve
> fixing for Ubuntu 10.04, even though we're past Final Freeze. As I
> understand it, fixing it would involve removing 05_appindicator.dpatch from
> the package.
> >>
> >> Problem occurs in: Ubuntu Lucid
> >> Does not occur in: Ubuntu 9.10
> >>
> >> To unsubscribe from this bug, go to:
> >> https://bugs.launchpad.net/ayatana-ubuntu/+bug/564034/+subscribe
> >>
> >
> >
> >
> > --
> > YunQiang Su
> >
>
>
> --
> YunQiang Su
>
> --
> Panel no longer shows which input method is being used
> https://bugs.launchpad.net/bugs/564034
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (617865).
>

Karl Lattimer (karl-qdh) wrote :

The last comment refers to a bug which isn't in gsd, apparently according to tedg a release for a fix is due.

Changed in ayatana-ubuntu:
status: In Progress → Fix Released
Karl Lattimer (karl-qdh) wrote :

Oops, sorry for the spam, wrong bug #

Karl Lattimer (karl-qdh) on 2010-08-24
Changed in ayatana-ubuntu:
status: Fix Released → In Progress
Karl Lattimer (karl-qdh) on 2010-08-25
Changed in ayatana-ubuntu:
status: In Progress → Fix Committed
Changed in ayatana-ubuntu:
status: Fix Committed → Fix Released

The ibus 1.3.7-1ubuntu4 is still has this error

(ibus-daemon:26063): IBUS-CRITICAL **: _context_request_engine_cb: assertion `bus_input_context_has_focus (context)' failed
Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/panel.py", line 545, in __im_menu_item_activate_cb
    focus_ic.set_engine(engine)
  File "/usr/lib/pymodules/python2.6/ibus/inputcontext.py", line 239, in set_engine
    return self.__context.SetEngine(engine.name)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.IBus.NoEngine: can not find engine with name chewing

the indicator patch occurs LP:658911 , a setting window flashes when ibus-chewing added into IBus which causes typing difficulty.

A patch to don't run set_engine too many times while active single received.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.