ibus is in "other" category in the menu

Bug #420282 reported by Sarah Kowalik on 2009-08-28
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Medium
Martin Pitt
Karmic
Medium
Martin Pitt

Bug Description

Binary package hint: ibus

Latest karmic

Version: 1.2.0.20090723-1

ibus should not be in the "other" category. It should be somewhere more descriptive.

Thanks.

Steve Kowalik (stevenk) on 2009-09-01
tags: added: ubuntu-unr
Loïc Minier (lool) on 2009-09-01
tags: removed: ubuntu-unr
Arne Goetje (arnegoetje) wrote :

IMHO the ibus.desktop file, which puts the entry into the "Other" category is not necessary and should be removed. IBus configuration is already accessible via System->Preferences.

@LI Daobing:
what's your opinion on this?

LI Daobing (lidaobing) wrote :

ibus-setup.desktop is used to config ibus, and it is already in Settings category.
ibus.desktop is used to start ibus

How about add ibus.desktop to "System" category?

Arne Goetje (arnegoetje) wrote :

well, on Debian/Ubuntu ibus is started with the X session using im-switch. Therefor a separate menu entry to "start" ibus is misleading and should be removed. Since the environment variables must be set before ibus is started and that needs to happen in the X session anyways, it's even contra productive to provide an additional menu item, which misleads the user he could start and use ibus that way.

Michael Vogt (mvo) wrote :

I'm not sure this belongs here or in a seperate report, but it would be nice if ibus-setup.desktop.in would become a bit more descriptive too. Something like "Comment="IBus input method Preferences" would be nice.

LI Daobing (lidaobing) on 2009-09-08
Changed in ibus (Ubuntu Karmic):
assignee: nobody → LI Daobing (lidaobing)
LI Daobing (lidaobing) wrote :

debdiff ibus_1.2.0.20090723-1ubuntu1.debdiff in attachment.

debian version 1.2.0.20090904-1 have fixed this problem

Steve Langasek (vorlon) on 2009-09-10
Changed in ibus (Ubuntu Karmic):
importance: Undecided → Medium
LI Daobing (lidaobing) wrote :
Changed in ibus (Ubuntu Karmic):
assignee: LI Daobing (lidaobing) → Ubuntu Sponsors for main (ubuntu-main-sponsors)
status: New → Confirmed
Martin Pitt (pitti) wrote :

Taking for sponsoring. Many thanks, LI!

Changed in ibus (Ubuntu Karmic):
assignee: Ubuntu Sponsors for main (ubuntu-main-sponsors) → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.2.0.20090723-1ubuntu1

---------------
ibus (1.2.0.20090723-1ubuntu1) karmic; urgency=low

  * remove ibus.desktop (LP: #420282)

 -- LI Daobing <email address hidden> Tue, 08 Sep 2009 20:54:53 +0800

Changed in ibus (Ubuntu Karmic):
status: Confirmed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers