CTRL-Space no longer works under Unity

Bug #1278511 reported by Anmar Oueja on 2014-02-10
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
High
Aron Xu

Bug Description

No changes were done at all to any hot keys or settings. It was working last night before the latest update from 14.04. I am guessing Unity is somehow intercepting CTRL-space somewhere. I checked all the hot keys and nothing.

Please fix. This is critical for all Emacs users.

BTW, CTRL-Space works just fine using GNOME shell on the same OS install.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.1.2+14.04.20131106.1-0ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-8.27-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: GNOME
Date: Mon Feb 10 11:58:48 2014
InstallationDate: Installed on 2013-12-17 (54 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131217)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Anmar Oueja (anmar) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Barry Warsaw (barry) wrote :

Note too that this is another regression that causes severe pain to Emacs users: LP: #1278582

I'm not actually sure if it's the HUD, Unity, or something else.

Sebastien Bacher (seb128) wrote :

that seems an issue with ibus, does it work if you run ibus-setup and change the keybinding there?

affects: unity (Ubuntu) → ibus (Ubuntu)
Changed in ibus (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
importance: Undecided → High

On 11 February 2014 12:06, Sebastien Bacher <email address hidden> wrote:
> that seems an issue with ibus, does it work if you run ibus-setup and
> change the keybinding there?

That seemed to have fixed it. I am not sure what UI will get me to
ibus-setup. I didn't even know it existed.

Please note that I didn't have the reported problem when I was using
Gnome Shell. Is ibus only in Unity?

Thanks for the heads up.

From what I remember the Keyboard indicator changes the hotkey to activate IMs through Super+Space now. Be sure to check that out. IBus 1.5.3? or .5? Changed it to Super+Space, if I recall correctly... Check your ibus-setup hotkey to ensure its Ctrl+Space.

William Hua (attente) wrote :

So given that gnome-settings-daemon is doing the work of switching between keyboard layouts and IMs, we can try disabling IBus' input method switching under Unity.

The attachment "Disable input method trigger in IBus" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Aron Xu (happyaron) on 2014-02-17
Changed in ibus (Ubuntu):
status: Confirmed → In Progress
Iain Lane (laney) wrote :

Is there a way to ask gnome/unity-settings-daemon this question directly?

Trying to think what might be an upstreamable solution here.

Pete Woods (pete-woods) wrote :

seb128:
> that seems an issue with ibus, does it work if you run ibus-setup and change the keybinding there?

Yes, that works around the issue for the moment.

Aron Xu (happyaron) wrote :

I've uploaded with attente's patch, the change is sane and is verified to be working for me.

Changed in ibus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.5.5-1ubuntu2

---------------
ibus (1.5.5-1ubuntu2) trusty; urgency=medium

  * debian/patches/ubuntu-disable-trigger.patch:
    - Disable input method switching under Unity; it's handled by
      gnome-settings-daemon. (LP: #1278511)
 -- William Hua <email address hidden> Thu, 13 Feb 2014 18:33:46 -0500

Changed in ibus (Ubuntu):
status: Fix Committed → Fix Released
Swarup Dev (swarup-bhai1) wrote :

I installed Ubuntu 14.04 a few days ago, and the fix described on 2014-02-20 has not been implemented. CTRL-Space is not working to enable/disable the input editor. I have gone to the following page seeking a fix:

https://launchpad.net/ubuntu/+source/ibus/1.5.5-1ubuntu2

However there are three downloads listed there and I do not know which I need, or how to install it. Please kindly give some user-friendly advice on how to fix this issue.
Thanks,
Swarup

Swarup Dev (swarup-bhai1) wrote :

Also please note that the problem is still there when I boot into the Gnome-shell. CTRL-Space is not working either in Unity or in Gnome.

Swarup Dev (swarup-bhai1) wrote :

Also please note that I already have ibus (1.5.5-1ubuntu3) installed. According to the Launchpad Janitor's note "This bug was fixed in the package ibus - 1.5.5-1ubuntu2", given that I have what looks to be perhaps an even more up-t0-date installation, the bug should have been fixed in my Ubuntu 14.04 installation. However, the bug remains there. Please kindly inform what is the solution. I am attaching a screenshot of Synaptic showing that ibus (1.5.5-1ubuntu3) is already installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers