ibus-ui-gtk3 big memory leak

Bug #1271839 reported by Alex Tasin on 2014-01-23
88
This bug affects 19 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu 13.10 64bit
2gb of memory leak

Also seen on Ubuntu 14.04 64Bit

Quinn Balazs (qbalazs) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in ibus (Ubuntu):
status: New → Incomplete
Alex Tasin (alextasin) wrote :

I read the wiki.
ibus-ui-gtk3 start automaticaly at boot, how to start ibus-ui-gtk3 only with valgrind?

Sorry for my english

Me too. Also running 13.10 x86_64 with ibus 1.5.3-6ubuntu2.1

I have two of these processes running (two users logged in with Unity desktop). After about 1 week, one process is 8MB while the other is 16GB.

% ps -eo comm,rss | grep ibus-ui-gtk3
ibus-ui-gtk3 7896
ibus-ui-gtk3 16786100

No Valgrind data here, either. This was the first and only (observed) occurrence.

boon (boon-9ft1s) wrote :

I too am experiencing this problem (twice so far since upgrading to 13.10 and I don't think I had the problem before that).

The system becomes fairly unresponsive e.g. can't unminimise windows from the launch bar and it may not even be possible to minimise windows.

I can start System Monitor and it shows that ibus-ui-gtk3 has taken 8GB of memory (half what I have) and growing quickly. I have not let it get beyond that. I think that logging out clears the problem.

boon (boon-9ft1s) wrote :

PS I don't think this problem should be allowed to expire because of its "incomplete" status. It seems a fairly serious problem to me.

If you want valgrind information, you are going to have to provide additional information about how this process gets started - if it is even possible to use valgrind in this case.

bzzt (stavros1) wrote :

Same problem here. 1.3 GB of RAM used by ibus-ui-gtk3.

Ryan Davis (ryan-mokeys) wrote :

Same problem here. Computer went to sleep and work up with 4GB used by ibus-ui-gtk3. The only funny thing I did today was `kill -HUP gvfsd-metadata` because it was eating my disk trying to index network shares that I don't care about.

Chris Brower (idrum4316) wrote :

I'm also having the same problem. ibus-ui-gtk3 is using 3.6GB of memory.

David Parks (davidparks21) wrote :

Seeing 2.9GB on 14.04 LTS desktop 64 bit

Launchpad Janitor (janitor) wrote :

[Expired for ibus (Ubuntu) because there has been no activity for 60 days.]

Changed in ibus (Ubuntu):
status: Incomplete → Expired
description: updated
Stephanus Teggy (rystian) wrote :

Saw 1.8GB mem usage on 14.04 desktop 64 bit - this might help http://askubuntu.com/a/490326

Kiko Rodriguez (ibagazha) wrote :
hrvooje (hrvooje-gmail) wrote :

Happend to me too on Ubuntu 14.04 64bit. ibus-ui-gtk3 has taken 1,6GB of RAM

Dan Kegel (dank) wrote :

Bug 1276186 may be an acute form of this bug.
I saw both the high CPU usage and extreme RAM usage (about 1 megabyte/second leak).
It happened when I minimized Chrome, but continued long after I killed all the chrome processes.
ibus-ui-gtk3 got up to 2+ gigabytes of ram pretty quickly. I'll attach an apport log.

I guess I could figure out how to valgrind the app by disabling ibus in System Settings / Language Support,
then following https://code.google.com/p/ibus/wiki/IBusStartUpTroubleShooting,
or maybe by looking at the startup hook installed by im-config and modifying it.
But since I don't need an input method, I may just live with ibus disabled.

Valentas (vk-registrator) wrote :

seems to have happened to me once in a 1-2 years of usage on 16.04.

Valentas (vk-registrator) wrote :

ibus-daemon + ibus-ui-gtk3 > 5 GB RAM usage

Dennis (moneysac) wrote :

I can confirm that this bug ist still present in Ubuntu Ubuntu 16.04.2 LTS.
ibus-daemon and ibus-ui-gtk3 allocated together at least 2GB of ram. They also caused together approximately 40% CPU load.

Changed in ibus (Ubuntu):
status: Expired → Confirmed
Yogeshwaran (yogeshwaran) wrote :

I'm impacted with this issue in ubuntu 16.04 LTS. It sucked up 7.5 GB of my RAM and my system became extremely slow.

Ilya Kopysov (justletmedie) wrote :

I'm impacted with this issue in Ubuntu 17.04. It consumed 6.5GB of my RAM and I killed it after I noticed freezes. I believe it because I used "Suspend" instead of "Turn off" 3 days in a row(though my computer was working 3-5 hours per day. So its around 12-15 hours).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers