Avoid conflicting <Super>Space shortcut with g-s-d

Bug #1249208 reported by Aron Xu on 2013-11-08
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
High
Aron Xu
Saucy
High
Unassigned

Bug Description

[Impact]
Now we are using <Super>Space as the shortcut of switching IME forward, and the shortcut is handled twice: first in g-s-d and then in ibus. This leads to a conflict and the shortcut does not really work.

[Test Case]
Old behavior:
Press <Super>Space does not have any effect of changing the IME forward.

Expected behavior:
After installing the updated package, user removes ibus configuration files in ~/.config/ibus and ~/.cache/ibus, and re-login to the system, <Super>Space should work for people who are using Unity or GNOME Shell.

[Regression Potential]
IBus may still push notification message about <Super>Space as the shortcut for users of other desktop, but the shortcut in effect would be <Ctrl>Space when there is no other program grabbing the key press (like what g-s-d does).

Aron Xu (happyaron) on 2013-11-08
Changed in ibus (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
status: New → In Progress
Changed in ibus (Ubuntu Saucy):
assignee: nobody → Aron Xu (happyaron)
Changed in ibus (Ubuntu):
importance: Undecided → High
Changed in ibus (Ubuntu Saucy):
importance: Undecided → High
Aron Xu (happyaron) on 2013-11-08
Changed in ibus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.5.3-6ubuntu3

---------------
ibus (1.5.3-6ubuntu3) trusty; urgency=low

  * Use <Ctrl>Space as the shortcut of switching IME forward in ibus,
    avoiding the conflict with g-s-d shortcut handling (LP: #1249208).
 -- Aron Xu <email address hidden> Fri, 08 Nov 2013 14:32:13 +0800

Changed in ibus (Ubuntu):
status: Fix Committed → Fix Released

It is good solution for Ubuntu. And this does not affect on Ubuntu GNOME.
But Kubuntu/Xubuntu/Lubuntu etc affect this fix. Users may get into a mess.

Aron Xu (happyaron) wrote :

I talked with seb128 and wants to re-evaluate the way of shortcuts handling, so this is a transitional solution in trusty. We have a chance to get rid of ibus integration from GNOME in trusty to avoid such odd situation.

Also <Super>Space isn't really good UX, and might be reverted later.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus (Ubuntu Saucy):
status: New → Confirmed

I see.
> Also <Super>Space isn't really good UX
I think so. too.

Aron Xu (happyaron) on 2013-11-08
Changed in ibus (Ubuntu Saucy):
status: Confirmed → Triaged
Aron Xu (happyaron) on 2014-02-20
Changed in ibus (Ubuntu Saucy):
assignee: Aron Xu (happyaron) → nobody
Neal McBurnett (nealmcb) wrote :

By overriding the upstream default of super-space to fix something for one desktop, you've broken emacs, eclipse, NetBeans, and many others that use ctrl-space on every other desktop it seems. See bug 1278569.

Please fix this properly in Trusty, which is after all a Long Term Support system, hardly fit for a "transitional solution".

Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in ibus (Ubuntu Saucy):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers