ibus-ui-gtk3 crashed with SIGABRT in _g_log_abort()

Bug #1221593 reported by Lena on 2013-09-06
154
This bug affects 72 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
High
Unassigned

Bug Description

?

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: ibus 1.5.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic i686
ApportVersion: 2.12.1-0ubuntu3
Architecture: i386
CasperVersion: 1.336
Date: Fri Sep 6 07:53:22 2013
ExecutablePath: /usr/lib/ibus/ibus-ui-gtk3
LiveMediaBuild: Ubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130905)
MarkForUpload: True
ProcCmdline: /usr/lib/ibus/ibus-ui-gtk3
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
Signal: 6
SourcePackage: ibus
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
Title: ibus-ui-gtk3 crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Lena (lena-2) wrote :

StacktraceTop:
 _g_log_abort () at /build/buildd/glib2.0-2.37.6/./glib/gmessages.c:255
 g_assertion_message (domain=domain@entry=0x8060c95 "IBUS", file=file@entry=0x8061fe1 "panel.c", line=line@entry=3502, func=func@entry=0x8062aa2 <__PRETTY_FUNCTION__.53202> "panel_switch_engine", message=message@entry=0x957ebd0 "assertion failed: (i >= 0 && i < m_engines.length)") at /build/buildd/glib2.0-2.37.6/./glib/gtestutils.c:2278
 g_assertion_message_expr (domain=domain@entry=0x8060c95 "IBUS", file=file@entry=0x8061fe1 "panel.c", line=line@entry=3502, func=func@entry=0x8062aa2 <__PRETTY_FUNCTION__.53202> "panel_switch_engine", expr=expr@entry=0x806253c "i >= 0 && i < m_engines.length") at /build/buildd/glib2.0-2.37.6/./glib/gtestutils.c:2293
 panel_switch_engine (self=0x9482930, i=<optimized out>, force=<optimized out>) at panel.c:3502
 panel_update_engines (self=self@entry=0x9482930, var_engines=var_engines@entry=0xb4d1f908, var_order=var_order@entry=0xb4d1f220) at panel.c:4143

Changed in ibus (Ubuntu):
importance: Undecided → Medium
summary: - ibus-ui-gtk3 crashed with SIGABRT in g_assertion_message()
+ ibus-ui-gtk3 crashed with SIGABRT in _g_log_abort()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
information type: Private → Public
Changed in ibus (Ubuntu):
importance: Medium → High
Sebastien Bacher (seb128) wrote :

Could the users having the issue run "setxkbmap -query" and copy the result here?

Seems similar to https://bugzilla.redhat.com/show_bug.cgi?id=1004006

Changed in ibus (Ubuntu):
assignee: nobody → Aron Xu (happyaron)

[image: Inline image 1]

On Wed, Oct 23, 2013 at 1:05 AM, Sebastien Bacher <email address hidden> wrote:

> Could the users having the issue run "setxkbmap -query" and copy the
> result here?
>
> Seems similar to https://bugzilla.redhat.com/show_bug.cgi?id=1004006
>
> ** Changed in: ibus (Ubuntu)
> Assignee: (unassigned) => Aron Xu (happyaron)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1227810).
> https://bugs.launchpad.net/bugs/1221593
>
> Title:
> ibus-ui-gtk3 crashed with SIGABRT in _g_log_abort()
>
> Status in “ibus” package in Ubuntu:
> Confirmed
>
> Bug description:
> ?
>
> ProblemType: Crash
> DistroRelease: Ubuntu 13.10
> Package: ibus 1.5.3-0ubuntu1
> ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
> Uname: Linux 3.11.0-4-generic i686
> ApportVersion: 2.12.1-0ubuntu3
> Architecture: i386
> CasperVersion: 1.336
> Date: Fri Sep 6 07:53:22 2013
> ExecutablePath: /usr/lib/ibus/ibus-ui-gtk3
> LiveMediaBuild: Ubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130905)
> MarkForUpload: True
> ProcCmdline: /usr/lib/ibus/ibus-ui-gtk3
> ProcEnviron:
> TERM=linux
> PATH=(custom, no user)
> LANG=de_DE.UTF-8
> Signal: 6
> SourcePackage: ibus
> StacktraceTop:
> ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
> ?? ()
> ?? ()
> Title: ibus-ui-gtk3 crashed with SIGABRT in g_assertion_message()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1221593/+subscriptions
>

Aron Xu (happyaron) wrote :

I cannot reproduce this bug, also tried the described steps on RH bugzilla with no luck. Can you provide some details on the step of reproducing this crash?

Aron Xu (happyaron) on 2013-11-08
Changed in ibus (Ubuntu):
status: Confirmed → Triaged
Aron Xu (happyaron) wrote :

It looks the crash is triggered by an assertion that user's input method list shouldn't be empty, but when first boot ibus-ui-gtk3 starts before ibus populate the input method list to user configurations.

This bug is caused by a patch from upstream developer applied in Fedora 19, but when ibus upgraded to 1.5.4 there he no longer cares about 1.5.3 and updates his patch against 1.5.4 only.

Aron Xu (happyaron) on 2014-02-14
Changed in ibus (Ubuntu):
assignee: Aron Xu (happyaron) → nobody
nico (ponte-nicolas) wrote :

??????

Aron Xu (happyaron) wrote :

Fixed in newer releases.

Changed in ibus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.