ibus-engine-sunpinyin crashed with SIGSEGV in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::assign()

Bug #809714 reported by Tom Zhou on 2011-07-13
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ibus-sunpinyin (Ubuntu)
High
Canonical Desktop Team
Oneiric
High
Canonical Desktop Team

Bug Description

choose sunpinyin in ibus preferences dialog, then press ctrl+space to switch to chinese input method, sunpinyin engine crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: ibus-sunpinyin 2.0.3-1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Jul 13 13:53:06 2011
ExecutablePath: /usr/lib/ibus-sunpinyin/ibus-engine-sunpinyin
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: /usr/lib//ibus-sunpinyin/ibus-engine-sunpinyin --ibus
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f154f3cf1c3: lock xadd %eax,0x10(%rdi)
 PC (0x7f154f3cf1c3) ok
 source "%eax" ok
 destination "0x10(%rdi)" (0xfffffffffffffff8) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: ibus-sunpinyin
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 std::basic_string<char, std::char_traits<char>, std::allocator<char> >::assign(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 ?? ()
 ?? ()
 ?? ()
Title: ibus-engine-sunpinyin crashed with SIGSEGV in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::assign()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: admin cdrom dialout libvirtd lpadmin plugdev sambashare sudo

Tom Zhou (zhouqt) wrote :

StacktraceTop:
 __exchange_and_add (this=0xffffffffffffffe8, __a=...) at /build/buildd/gcc-4.6-4.6.1/build/x86_64-linux-gnu/libstdc++-v3/include/ext/atomicity.h:48
 __exchange_and_add_dispatch (this=0xffffffffffffffe8, __a=...) at /build/buildd/gcc-4.6-4.6.1/build/x86_64-linux-gnu/libstdc++-v3/include/ext/atomicity.h:81
 std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_Rep::_M_dispose (this=0xffffffffffffffe8, __a=...) at /build/buildd/gcc-4.6-4.6.1/build/x86_64-linux-gnu/libstdc++-v3/include/bits/basic_string.h:240
 _M_dispose (this=0x617ec0, __str=<value optimized out>) at /build/buildd/gcc-4.6-4.6.1/build/x86_64-linux-gnu/libstdc++-v3/include/bits/basic_string.h:235
 std::basic_string<char, std::char_traits<char>, std::allocator<char> >::assign (this=0x617ec0, __str=<value optimized out>) at /build/buildd/gcc-4.6-4.6.1/build/x86_64-linux-gnu/libstdc++-v3/include/bits/basic_string.tcc:252

Changed in ibus-sunpinyin (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in ibus-sunpinyin (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
Changed in ibus-sunpinyin (Ubuntu Oneiric):
importance: Medium → High
visibility: private → public
Changed in ibus-sunpinyin (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

Can you please test this on current oneiric builds? I tried that yesterday in the live system, and it worked quite fine. Thanks!

Changed in ibus-sunpinyin (Ubuntu Oneiric):
status: Confirmed → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

I can not reproduce with Beta 1. Closing.

Changed in ibus-sunpinyin (Ubuntu Oneiric):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers