Spaces and certain other characters are inserted out of order after an input sequence is completed

Bug #886568 reported by Alex Lee on 2011-11-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ibus-m17n (Ubuntu)
Undecided
Unassigned

Bug Description

1) Xubuntu 11.10
2) ibus-m17n 1.3.2-1ubuntu1

(Apologies if my terminology is not quite right here, by the way.)

When I finish off an input sequence by entering a character that does not continue the sequence further, it often happens that this last letter that I type (typically a space) will be inserted *before* the character that was being built by the input sequence.

For example, active grc-mizuochi and try to type a Greek alpha with an acute accent. Follow it with a space.

The input sequence would be "a/ ".
Expected output is "ά ".
But what I instead get is " ά".

Now, I found that if I edit the .mim file and add the following rule:
(" " ? )
Then the behavior changes to what I would expect. That is, I have to explicitly define the space character in the .mim file in order to get the result "ά ". In fact, I think that any character that is not explicitly defined in the .mim file will exhibit the behavior I describe above; the problem isn't specific to the space character.

This wasn't a problem with ibus on earlier versions of Ubuntu (I used it extensively on 10.10 and 11.04). Is there a way to get the old behavior back? Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus-m17n (Ubuntu):
status: New → Confirmed
madurax86 (madura-x86) on 2011-11-24
Changed in ibus-m17n (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
madurax86 (madura-x86) wrote :

Please install ibus from here https://github.com/fujiwarat/ibus

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers