quantal alpha3: ibus-engine-chewing crashed with SIGABRT in __assert_fail_base()

Bug #1028746 reported by Victor Zhou on 2012-07-25
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ibus-chewing (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

Description:

I met a crash after I installed the quantal alpha3 desktop i386 iso(version:20120724.2) into a VM with choosing the Traditional Chinese as the installation language.

Steps to reproduce:

1. install the quantal alpha3 desktop i386 iso(version:20120724.2) into a VM with choosing the Traditional Chinese as the installation language.
2. login the system after the installing and open gedit
3. Click on the keyboard icon on the notification area and select Chewing as the input method to switch to. --- you will find you can not swith to it.
4. try more times on step 3, and click the 偏好设置(setting/preference), try to restart the input method. the app crashs.

More Information:

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: ibus-chewing 1.3.10+clean-3
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic i686
ApportVersion: 2.4-0ubuntu5
Architecture: i386
Date: Wed Jul 25 14:13:12 2012
ExecutablePath: /usr/lib/ibus-chewing/ibus-engine-chewing
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
ProcCmdline: /usr/lib/ibus-chewing/ibus-engine-chewing --ibus
Signal: 6
SourcePackage: ibus-chewing
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 __assert_fail () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /usr/lib/i386-linux-gnu/libchewing.so.3
Title: ibus-engine-chewing crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 gnome-session[1489]: WARNING: Session 'ubuntu' runnable check failed: 程式以代碼 1 結束
 (gnome-settings-daemon:1565): color-plugin-WARNING **: failed to get edid: unable to get EDID for output
 (gnome-settings-daemon:1565): color-plugin-WARNING **: unable to get EDID for xrandr-default: unable to get EDID for output
 (gnome-settings-daemon:1565): color-plugin-WARNING **: failed to reset xrandr-default gamma tables: gamma size is zero
 (gnome-settings-daemon:1565): GLib-CRITICAL **: g_variant_get_int32: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_INT32)' failed

Victor Zhou (victor.zhou) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0xb6ff08d8 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=0xb718412c "plat_mmap_is_valid( &tree_mmap )", file=0xb7184123 "tree.c", line=121, function=0xb718426c "InitTree") at assert.c:94
 __GI___assert_fail (assertion=0xb718412c "plat_mmap_is_valid( &tree_mmap )", file=0xb7184123 "tree.c", line=121, function=0xb718426c "InitTree") at assert.c:103
 InitTree (prefix=0x80582e4 "/usr/share/libchewing3/chewing") at tree.c:121
 chewing_Init (dataPath=0x80582e4 "/usr/share/libchewing3/chewing", hashPath=0xbf853aa8 "/home/v/.chewing") at chewingio.c:159
 ?? ()

Changed in ibus-chewing (Ubuntu):
importance: Undecided → Medium
summary: - quantal alpha3: ibus-engine-chewing crashed with SIGABRT in raise()
+ quantal alpha3: ibus-engine-chewing crashed with SIGABRT in
+ __assert_fail_base()
tags: removed: need-i386-retrace
description: updated
description: updated
tags: added: iso-testing
description: updated
visibility: private → public
Changed in ibus-chewing (Ubuntu):
importance: Medium → High
tags: added: qa-manual-testing rls-q-incoming
tags: removed: rls-q-incoming
tags: added: rls-q-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus-chewing (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

Luke, can you have a look at this one, please?

Changed in ibus-chewing (Ubuntu Quantal):
assignee: nobody → Luke Yelavich (themuso)
importance: High → Medium
tags: removed: rls-q-incoming
Shih-Yuan Lee (fourdollars) wrote :

Hi,

Could you try to rebuild the same Debian package ?
It seems because ibus API changed and it just needs to be rebuild again.

Changed in ibus-chewing (Ubuntu Quantal):
status: Confirmed → Fix Committed
assignee: Luke Yelavich (themuso) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus-chewing - 1.3.10+clean-3build1

---------------
ibus-chewing (1.3.10+clean-3build1) quantal; urgency=low

  * No change rebuild with the current ibus version (lp: #1028746)
 -- Sebastien Bacher <email address hidden> Wed, 03 Oct 2012 23:32:24 +0200

Changed in ibus-chewing (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers