Lacking dependencies

Bug #829876 reported by Ikuya Awashiro on 2011-08-20
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ibus-anthy (Debian)
Fix Released
Unknown
ibus-anthy (Ubuntu)
High
Steve Langasek

Bug Description

Version:
1.2.6-2 (Oneiric)

How to reproduce:
1. start gnome-terminal
2. push setting icon on toolbar with no response
3. run "python /usr/share/ibus-anthy/setup/main.py"
 Traceback (most recent call last):
   File "/usr/share/ibus-anthy/setup/main.py", line 27, in <module>
     from gtk import glade
 ImportError: cannot import name glade
4. sudo apt-get install python-glade2
5. works fine

Related branches

Here is the debdiff for fix.

Steve Langasek (vorlon) wrote :

In fact, there are several other modules being imported for which we also do not have package dependencies. Most of the others may already be installed by default, but we should still have declared dependencies for them:

import gtk
import pango
from gtk import glade
from ibus import keysyms, modifier, Bus
from gettext import dgettext, bindtextdomain

Could you please work out the correct dependencies for each of these modules, and include them in the patch?

Changed in ibus-anthy (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
status: New → Incomplete
importance: Undecided → High
Steve Langasek (vorlon) wrote :

this one, too:

from anthyprefs import AnthyPrefs

Steve Langasek (vorlon) wrote :

ah, not that one; anthyprefs is from the same package so no dependency needed.

btw, even with all the required modules installed on my system, main.py fails like this:

$ python /usr/share/ibus-anthy/setup/main.py
Traceback (most recent call last):
  File "/usr/share/ibus-anthy/setup/main.py", line 1334, in <module>
    AnthySetup().run()
  File "/usr/share/ibus-anthy/setup/main.py", line 45, in __init__
    self.__config = Bus().get_config()
  File "/usr/lib/python2.7/dist-packages/ibus/bus.py", line 61, in __init__
    self.__dbusconn = dbus.connection.Connection(common.get_address())
TypeError: expected string or Unicode object, NoneType found
$

tags: added: patch

Hi Steve, thank you for your effort.

This patch may fix this issue.

> btw, even with all the required modules installed on my system, main.py fails like this:
I am very sorry, please run this command instead.
$ /usr/lib/ibus-anthy/ibus-setup-anthy

>> btw, even with all the required modules installed on my system, main.py fails like this:
> I am very sorry, please run this command instead.
> $ /usr/lib/ibus-anthy/ibus-setup-anthy
>

Also need to startup ibus-daemon.

summary: - Lacking dependency
+ Lacking dependencies
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus-anthy - 1.2.6-2ubuntu1

---------------
ibus-anthy (1.2.6-2ubuntu1) oneiric; urgency=low

  * debian/control: add some Python modules to Depends (LP: #829876)
 -- Ikuya Awashiro <email address hidden> Tue, 23 Aug 2011 16:42:50 +0900

Changed in ibus-anthy (Ubuntu):
status: Incomplete → Fix Released
Changed in ibus-anthy (Debian):
status: Unknown → New
Changed in ibus-anthy (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.