Switching keyboard layouts from some non-English to Japanese (Anthy, Mozc) does not work on 14.04

Bug #1311990 reported by Abhabongse Janthong on 2014-04-24
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ibus-anthy (Ubuntu)
Medium
Unassigned

Bug Description

I'm using Ubuntu 14.04 LTS with multiple keyboard layouts: English (US) – Thai – Japanese (Anthy, Mozc), as appeared in Text Entry settings.

The problem is that … when I cycle through the layouts in this order [EN → TH → JP], I would have expected to be able to type Japanese properly; however, although the indicator on the top right says JP, the output was still in TH.

However, if I cycle in the reverse order [TH → EN → JP], the Japanese input works correctly.

In more details, whenever I switch to JP from TH (by switching to "next" input if TH precedes JP in the settings, or by switching to "previous" input if TH succeeds JP in the settings), the output is in TH instead of JP (but the indicator is already in JP). On the other hand, switching to JP from EN works fine.

Here's what the output from apt-cache policy ibus:

ibus:
  Installed: 1.5.5-1ubuntu3
  Candidate: 1.5.5-1ubuntu3
  Version table:
 *** 1.5.5-1ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, how do you cycle through layout. Does it happen if you use the indicator menu to change inputs? Does it happen every time?

I cycle through layouts via shortcuts set by "Switch to next/previous source using:" settings in Text Entry. In my case, they are the defaults, [Super+Space] and [Shift+Super+Space] respectively. Anyway, when I change the shortcut to something else (I tried [Shift+Alt_L]) and the same bug still occurs.

I tried using indicator menu to switch layouts too. The similar thing occurs: if I switch to JP from TH from indicator menu, it has the same effect as if I cycled to JP from TH. But if I switch to JP from EN using indicator menu, it is working fine as if I did the same thing through the shortcut.

This bug occurs consistently.

More info:

It seems that the actual keyboard layout does not change when I switch from TH to JP. That is, when on Anthy (or Mozc), if I press a key that corresponds to a Thai alphabet (on Thai layout), that same Thai alphabet appears. However, if I press a key that corresponds to some symbols on Thai layout that Anthy or Mozc knows how to deal with, then dropdown pops up as if Anthy (or Mozc) is working.

For example, assume that I did [TH → JP] and I'm currently on JP (Anthy). If I press F (ด on the Thai layout), then the letter ด appears. But if I press 3 (- on the Thai layout), then "ー" pops up as a suggestion as if Anthy is working fine.

I just found that there is a "keyboard layout" options inside Anthy settings under the Typing Method tab which allows me to set the layout to US (instead of "Default") and it works perfectly.

 It was originally not obvious to me that I would have to change this option in the settings in order for this to work.

Thanks for your help, Sebastian. I'm changing this report to invalid.

Changed in ibus (Ubuntu):
status: New → Invalid
Nicholas (drkoljan) wrote :

This is still a bug, since it's not the expected behavior. Anthy shouldn't use the previously selected layout.

Changed in ibus (Ubuntu):
status: Invalid → Confirmed
Aron Xu (happyaron) wrote :

ibus-anthy should be the relevant part that decide/reset the layout to use if it's not purely an engine that adapts to whatever layout the system is using.

affects: ibus (Ubuntu) → ibus-anthy (Ubuntu)
Changed in ibus-anthy (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers