[20.04] Please remove ibmasm-utils package from the Archive

Bug #1853003 reported by Christian Ehrhardt  on 2019-11-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ibmasm-utils (Ubuntu)
Undecided
Ubuntu Package Archive Administrators

Bug Description

Hi,
this package is severely outdated has no upstream anymore and is meant to support HW that doesn't exist for years.

The package src:ibmasm-utils in the version that Ubuntu has is responsible and providing drivers for (from its Readme):
- Remote Supervisor Adapter, which is an option on specific models
of xSeries servers (Remote Mouse / Keyboard available if the
Adapter firmware supports those functions)

There are newer versions in Suse/RedHat (http://rpmfind.net/linux/RPM/dag/redhat/el6/i386/ibmusbasm-1.10.2-1.2.el6.rf.i686.html) that would build more:
- Advanced System Management PCI Adapter card and its associated
Shared Serial Port.
- Advanced System Management Processor, which is part of the
planar board on specific models of Netfinity and IBM eServer
xSeries servers
- Automatic Server Restart (ASR) which is built onto the
planar board of specific models of xSeries servers
- Remote Supervisor Adapter, which is an option on specific models
of xSeries servers

But even in RH/Suse this was removed later releases it seems.

But all that is outdated and no more needed IMHO.
The product itself is at [1] and in Wiki [2].

There is a kernel driver which still exists "ibmasm" but the last real update (not just global search and replace to API/infrastructure changes) is more than a decade ago.

I doubt it is ever used in former still active releases of Ubuntu, but if so that is fine.
OTOH I think it would be wrong to let it enter another Ubuntu LTS, therefore please consider removing this from Ubuntu releases.

[1]: https://www.ibm.com/support/pages/overview-remote-supervisor-adapter
[2]: https://en.wikipedia.org/wiki/IBM_Remote_Supervisor_Adapter

Related branches

Hi Frank,
I guess my assumptions are right, but before passing this to the AAs could you get this onto the Topic list in IBM calls and then come back with an official "yes it is ok to be dropped" from there to be added here?

description: updated
Changed in ibmasm-utils (Ubuntu):
assignee: nobody → Christian Ehrhardt  (paelzer)
assignee: Christian Ehrhardt  (paelzer) → Frank Heimes (frank-heimes)
Changed in ibmasm-utils (Ubuntu):
assignee: Frank Heimes (frank-heimes) → nobody

Frank pulled a lot of strings, we have to realize that those servers are not sold for more than a decade. After all those servers were IBM, but are taken over by Lenovo since quite some time.
So we found no one to talk about the old reasons or the old servers it was added for.
But OTOH this also is an argument that shows that this seems to be no more needed.

Assigning archive admins to resolve this.

Changed in ibmasm-utils (Ubuntu):
assignee: nobody → Ubuntu Package Archive Administrators (ubuntu-archive)
Sebastien Bacher (seb128) wrote :

Removing packages from focal:
 ibmasm-utils 3.0-1ubuntu12 in focal
  ibmasm-utils 3.0-1ubuntu12 in focal amd64
  ibmasm-utils 3.0-1ubuntu12 in focal i386
Comment: outdated has no upstream anymore and is meant to support HW that doesn't exist for years (lp: #1853003)
Remove [y|N]? y
1 package successfully removed.

Changed in ibmasm-utils (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers