Ubuntu

32 bit GL on amd64 is broken on oneiric with nvidia-graphics-drivers

Reported by Yotam Benshalom on 2011-09-17
146
This bug affects 32 people
Affects Status Importance Assigned to Milestone
ia32-libs (Ubuntu)
Medium
Unassigned

Bug Description

After updates which took place during the last several days, several OpenGL commercial games stopped recognising GLX and would not load. This happens on gnome-shell and unity, with nvidia-current and nvidia 173.

Lugaru says:
SDL_SetVideoMode() failed: Couldn't find matching GLX visual
forcing 640x480...

Atom Zombie Smasher says:
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 8 (X_MapWindow)
  Resource id in failed request: 0x0
  Serial number of failed request: 32
  Current serial number in output stream: 34

X-Plane says:
Whoah -- no matter how hard I tried, I failed to get a GLX visual. Something's seriously wonky on your machine.

And Yet It Moves says:
Could not find a compatible OpenGL display resolution. Please check your driver configuration. (Error: Couldn't find matching GLX visual)

Aquaria says:
Message: Couldn't set resolution [1280x800]
Couldn't find matching GLX visual

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia wl
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.gpus.1: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/1'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,grid,imgpng,gnomecompat,mousepoll,resize,regex,vpswitch,wall,place,unitymtgrabhandles,move,wobbly,session,animation,scale,workarounds,expo,ezoom,unityshell]
CompositorRunning: None
Date: Sun Sep 18 01:01:35 2011
DistUpgraded: Log time: 2011-08-29 17:40:27.834407
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 nVidia Corporation G98 [GeForce 9200M GS] [10de:06e8] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0271]
 nVidia Corporation C79 [GeForce 9400M G] [10de:0866] (rev b1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0271]
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
MachineType: Dell Inc. Studio XPS 1340
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=eb46fc15-d83a-490d-b085-d4b98ff0e167 ro vga=792 splash ipv6.disable=1 quiet quiet nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap
SourcePackage: xorg
UpgradeStatus: Upgraded to oneiric on 2011-08-29 (19 days ago)
dmi.bios.date: 04/08/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.name: 0K183D
dmi.board.vendor: Dell Inc.
dmi.board.version: A15
dmi.chassis.asset.tag: 1234567890
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A15
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd04/08/2011:svnDellInc.:pnStudioXPS1340:pvrA15:rvnDellInc.:rn0K183D:rvrA15:cvnDellInc.:ct8:cvrA15:
dmi.product.name: Studio XPS 1340
dmi.product.version: A15
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu22
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Yotam Benshalom (benshalom) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Yotam Benshalom (benshalom) wrote :

A workaround for this bug:
LD_LIBRARY_PATH=/usr/lib32/nvidia-current your_program_name

This seems to fix the issues.

This means that this bug belongs in nvidia-current package,

BTW, this bug also prevents every wine game from loading.

affects: xorg (Ubuntu) → nvidia-drivers-ubuntu

I noticed this same bug yesterday. My workaround was to replace all softlinks pointing to the mesa libGL.so libraries with ones pointing to the nvidia libraries - but the LD_LIBRARY_PATH workaround is cleaner. :)

Genefy (genefy) wrote :

Is there a way to put this in a shell script? I tried for the last few hrs, but even with perfect formatting. It won't work without me typing/copy-pasting into a terminal myself.

Gnurfos (gnurfos) wrote :

Either you write it on the same line as the command (wine?) like indicated by Yotam:

LD_LIBRARY_PATH=/usr/lib32/nvidia-current wine "fooooooofofofoo"

Or you set it before with export:

export LD_LIBRARY_PATH=/usr/lib32/nvidia-current
wine "fooooooofofofoo"

sparker256 (bgood) wrote :

I use the following line in a script to start X-Plane.

LD_LIBRARY_PATH=/usr/lib32/nvidia-current ./X-Plane-i686

affects: nvidia-drivers-ubuntu → nvidia-graphics-drivers (Ubuntu)
Alberto Milone (albertomilone) wrote :

can you attach the output of the following command, please?

ldconfig -p | grep GL

Yotam Benshalom (benshalom) wrote :

ׁHere:

yotam@aku:~$ ldconfig -p | grep GL
 libQtOpenGL.so.4 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libQtOpenGL.so.4
 libGLw.so.1 (libc6,x86-64) => /usr/lib/libGLw.so.1
 libGLU.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLU.so.1
 libGLU.so.1 (libc6) => /usr/lib32/libGLU.so.1
 libGLU.so (libc6) => /usr/lib32/libGLU.so
 libGLEWmx.so.1.5 (libc6,x86-64) => /usr/lib/libGLEWmx.so.1.5
 libGLEW.so.1.5 (libc6,x86-64) => /usr/lib/libGLEW.so.1.5
 libGLESv2.so.2 (libc6,x86-64, OS ABI: Linux 2.4.20) => /usr/lib/x86_64-linux-gnu/mesa-egl/libGLESv2.so.2
 libGLESv1_CM.so.1 (libc6,x86-64, OS ABI: Linux 2.4.20) => /usr/lib/x86_64-linux-gnu/mesa-egl/libGLESv1_CM.so.1
 libGLC.so.0 (libc6,x86-64) => /usr/lib/libGLC.so.0
 libGL.so.1 (libc6,x86-64) => /usr/lib/nvidia-current/libGL.so.1
 libGL.so.1 (libc6, OS ABI: Linux 2.4.20) => /usr/lib32/libGL.so.1
 libGL.so.1 (libc6) => /usr/lib32/nvidia-current/libGL.so.1
 libGL.so (libc6,x86-64) => /usr/lib/nvidia-current/libGL.so
 libGL.so (libc6, OS ABI: Linux 2.4.20) => /usr/lib32/libGL.so
 libGL.so (libc6) => /usr/lib32/nvidia-current/libGL.so
 libEGL.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1
 libCgGL.so (libc6,x86-64) => /usr/lib/libCgGL.so

Steven Kuck (skuck71) wrote :

This bug was reported a week ago and is unassigned and has undecided importance. I can't decide the importance for Ubuntu, but I can tell you the importance for me: show-stopper. I can't prove it is the same bug, but at the same time as all these games failed due to an error using OpenGL, all of my WINE games broke too. World of Warcraft, StarCraft 2, Portal.

Booting with Ubuntu 10.04, using the same WINE version, and the same program directories, they work perfectly. I'm using the free version of WoW, so Ubuntu testers can try it out themselves.
I suspect it is the same error because this is the first line of the errors produced starting WoW:
steven@galactica:~/.wine/drive_c/Program Files/World of Warcraft$ wine Wow.exe
err:wgl:X11DRV_WineGL_InitOpenglInfo couldn't initialize OpenGL, expect problems

Gaming is far from the only thing I do, but this bug affects a more than just a handful of indie games (the ones listed just happen to be from the Humble Indie Bundle). It seems to affect many things that use OpenGL.

Dominik (dominalien) wrote :

This occurred on Kubuntu 11.10 for me. A show stopper indeed.

Loris Zinsou (the-lz-himself) wrote :

Confirmed with Crayon Physics Deluxe. No window is created on startup, but you can hear the game menu sound.

Mark Schmidt (schmidtm) wrote :

I have the same problem running a application using wine on kubuntu oneiric amd64 with graphics driver nvidia-current-updates. As a workaround for me helps lib preloading
LD_PRELOAD=/usr/lib32/nvidia-current-updates/libGL.so.1 wine <prg name>

Loris Zinsou (the-lz-himself) wrote :

Is this problem present in x-updates and xorg-edgers PPAs ?

Joeman1 (jgiles) wrote :

I heard that if you install the package from Nvidia manually, it will resolve the issue.

Didn't try x-updates or xorg-edgers, however. Might want to try that first.

I do know that on other distro's this issue is not present with Gnome 3 or KDE 4.7.x, so its more than likely a packaging issue with Ubuntu.

Joeman1 (jgiles) wrote :

It does seem odd that its been confirmed, but not assigned to anyone. Unfortunately, for me, this seems typical as I have other confirmed bugs in from the beginning of the year and nothing has been done.

The work around seems to work for me as it only seems to affect 32bit games (Ironically, ID based games only (Doom3, ETQW, Etc...) :-D), but 64 bit games seems to work fine as does desktop composting.

Robert Hooker (sarvatt) on 2011-09-28
summary: - GLX is broken for several commercial OpenGL games
+ 32 bit GL on amd64 is broken on oneiric with nvidia-graphics-drivers
Robert Hooker (sarvatt) wrote :

It looks like this is ia32-libs fault, it's installing a mesa /usr/lib32/libGL.so.1 that is higher priority to ldconfig than the proprietary driver ones in /usr/lib32/foo/libGL.so.1

affects: nvidia-graphics-drivers (Ubuntu) → ia32-libs (Ubuntu)
Changed in ia32-libs (Ubuntu):
importance: Undecided → Medium
Emphy (emphyrio) wrote :

Had a similar problem with the ati drivers, installing them after the ia32 libs solved the problem for me.

(latest drivers from the amd website)

To post a comment you must log in.